blob: 9db26dccc7caeb7cff8bf07097e3ce69f27b46d8 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Target Communication Framework for the Eclipse IDE"
2HOMEPAGE = "http://wiki.eclipse.org/TCF"
3BUGTRACKER = "https://bugs.eclipse.org/bugs/"
4
5LICENSE = "EPL-1.0 | EDL-1.0"
6LIC_FILES_CHKSUM = "file://edl-v10.html;md5=522a390a83dc186513f0500543ad3679"
7
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008SRCREV = "2dddd5f440a15d5406032fac20f206484513646f"
9PV = "1.4.0+git${SRCPV}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050010
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050011UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060012SRC_URI = "git://git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent;branch=1.4_neon_bugfix \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013 file://fix_ranlib.patch \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050014 file://ldflags.patch \
15 file://0001-canonicalize_file_name-is-specific-to-glibc.patch;striplevel=2 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016 file://tcf-agent.init \
17 file://tcf-agent.service \
18 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019UPSTREAM_VERSION_UNKNOWN = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020
21DEPENDS = "util-linux openssl"
22RDEPENDS_${PN} = "bash"
23
24S = "${WORKDIR}/git/agent"
25
26inherit update-rc.d systemd
27
28SYSTEMD_SERVICE_${PN} = "tcf-agent.service"
29
30INITSCRIPT_NAME = "tcf-agent"
31INITSCRIPT_PARAMS = "start 99 3 5 . stop 20 0 1 2 6 ."
32
33# mangling needed for make
Brad Bishopd7bf8c12018-02-25 22:55:05 -050034MAKE_ARCH = "`echo ${TARGET_ARCH} | sed s,i.86,i686, | sed s,aarch64,a64,`"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050035MAKE_OS = "`echo ${TARGET_OS} | sed s,^linux.*,GNU/Linux,`"
36
37EXTRA_OEMAKE = "MACHINE=${MAKE_ARCH} OPSYS=${MAKE_OS} 'CC=${CC}' 'AR=${AR}'"
38
Brad Bishopd7bf8c12018-02-25 22:55:05 -050039LCL_STOP_SERVICES = "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050040 -DSERVICE_Memory=0 -DSERVICE_Registers=0 -DSERVICE_MemoryMap=0 \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050041 -DSERVICE_StackTrace=0 -DSERVICE_Expressions=0"
42
43
44# These features don't compile for several cases.
45#
46CFLAGS_append_mips = " ${LCL_STOP_SERVICES}"
47CFLAGS_append_mips64 = " ${LCL_STOP_SERVICES}"
48CFLAGS_append_libc-musl = " ${LCL_STOP_SERVICES}"
49CFLAGS_append_powerpc64 = " ${LCL_STOP_SERVICES}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050050
51do_install() {
52 oe_runmake install INSTALLROOT=${D}
53 install -d ${D}${sysconfdir}/init.d/
54 install -m 0755 ${WORKDIR}/tcf-agent.init ${D}${sysconfdir}/init.d/tcf-agent
55 install -d ${D}${systemd_unitdir}/system
56 install -m 0644 ${WORKDIR}/tcf-agent.service ${D}${systemd_unitdir}/system
57 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/tcf-agent.service
58}
59