blob: 258ac38e15711072054bf6f06920ab8cce4feb9f [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Midnight Commander is an ncurses based file manager"
2HOMEPAGE = "http://www.midnight-commander.org/"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05003DESCRIPTION = "GNU Midnight Commander is a visual file manager, licensed under GNU General Public License and therefore qualifies as Free Software. It's a feature rich full-screen text mode application that allows you to copy, move and delete files and whole directory trees, search for files and run commands in the subshell. Internal viewer and editor are included."
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00004LICENSE = "GPL-3.0-only"
Brad Bishop19323692019-04-05 15:28:33 -04005LIC_FILES_CHKSUM = "file://COPYING;md5=270bbafe360e73f9840bd7981621f9c2"
6SECTION = "console/utils"
Andrew Geisslerd159c7f2021-09-02 21:05:58 -05007DEPENDS = "ncurses glib-2.0 util-linux file-replacement-native"
Patrick Williams213cb262021-08-07 19:21:33 -05008RDEPENDS:${PN} = "ncurses-terminfo-base"
9RRECOMMENDS:${PN} = "ncurses-terminfo"
Brad Bishop19323692019-04-05 15:28:33 -040010
11SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \
Andrew Geissler82c905d2020-04-13 13:39:40 -050012 file://nomandate.patch \
Brad Bishop19323692019-04-05 15:28:33 -040013 "
Andrew Geissler5082cc72023-09-11 08:41:39 -040014SRC_URI[sha256sum] = "38171f22f889e3030ec9055463d3ecd7843984ab24e6497d8294d1c441a7ddb4"
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050015
Brad Bishop19323692019-04-05 15:28:33 -040016inherit autotools gettext pkgconfig
17
18#
19# Both Samba (smb) and sftp require package delivered from meta-openembedded
20#
21PACKAGECONFIG ??= ""
Brad Bishop19323692019-04-05 15:28:33 -040022PACKAGECONFIG[sftp] = "--enable-vfs-sftp,--disable-vfs-sftp,libssh2,"
23
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000024# enable NCURSES_WIDECHAR=1 only if ENABLE_WIDEC has not been explicitly disabled (e.g. by the distro config).
25# When compiling against the ncurses library, NCURSES_WIDECHAR needs to explicitly set to 0 in this case.
26CFLAGS:append:libc-musl = "${@' -DNCURSES_WIDECHAR=1' if bb.utils.to_boolean((d.getVar('ENABLE_WIDEC') or 'True')) else ' -DNCURSES_WIDECHAR=0'}"
Brad Bishop1d80a2e2019-11-15 16:35:03 -050027EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --disable-configure-args"
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050028EXTRANATIVEPATH += "file-native"
Brad Bishop19323692019-04-05 15:28:33 -040029
30CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060031CACHED_CONFIGUREVARS += "ac_cv_path_PERL_FOR_BUILD='/usr/bin/env perl'"
Brad Bishop1d80a2e2019-11-15 16:35:03 -050032CACHED_CONFIGUREVARS += "ac_cv_path_PYTHON='/usr/bin/env python'"
33CACHED_CONFIGUREVARS += "ac_cv_path_GREP='/usr/bin/env grep'"
Andrew Geissler82c905d2020-04-13 13:39:40 -050034CACHED_CONFIGUREVARS += "mc_cv_have_zipinfo=yes"
Brad Bishop19323692019-04-05 15:28:33 -040035
Patrick Williams213cb262021-08-07 19:21:33 -050036do_install:append () {
Brad Bishop19323692019-04-05 15:28:33 -040037 sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
38
39 rm ${D}${libexecdir}/mc/extfs.d/s3+ ${D}${libexecdir}/mc/extfs.d/uc1541
40}
41
42PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers ${BPN}-fish"
43
Patrick Williams213cb262021-08-07 19:21:33 -050044SUMMARY:${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
45FILES:${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
Brad Bishop19323692019-04-05 15:28:33 -040046 ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \
47 ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \
48 ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \
49 ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \
50 ${libexecdir}/mc/extfs.d/uzip"
Patrick Williams213cb262021-08-07 19:21:33 -050051RDEPENDS:${BPN}-helpers-perl = "perl"
Brad Bishop19323692019-04-05 15:28:33 -040052
Patrick Williams213cb262021-08-07 19:21:33 -050053SUMMARY:${BPN}-helpers = "Midnight Commander shell helper scripts"
54FILES:${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
Brad Bishop19323692019-04-05 15:28:33 -040055
Patrick Williams213cb262021-08-07 19:21:33 -050056SUMMARY:${BPN}-fish = "Midnight Commander Fish scripts"
57FILES:${BPN}-fish = "${libexecdir}/mc/fish"