blob: b43a41fb8db1f4cc299e10adc1fd8ba91c384b26 [file] [log] [blame]
Patrick Williams8b8bc412016-08-17 15:02:23 -05001SUMMARY = "A commandline OMX player for the Raspberry Pi"
2DESCRIPTION = "This player was developed as a testbed for the XBMC \
3Raspberry PI implementation and is quite handy to use standalone"
4HOMEPAGE = "https://github.com/popcornmix/omxplayer"
5SECTION = "console/utils"
6
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007LICENSE = "GPL-2.0-only"
Brad Bishop26bdd442019-08-16 17:08:17 -04008LIC_FILES_CHKSUM = "file://COPYING;md5=00a27da7ac0f9bcd17320ec29ef4bbf6"
Patrick Williams8b8bc412016-08-17 15:02:23 -05009
Patrick Williamsde0582f2022-04-08 10:23:27 -050010DEPENDS = "alsa-lib libpcre virtual/egl boost freetype dbus openssl libssh virtual/libomxil coreutils-native curl-native userland"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050012PR = "r6"
Patrick Williams8b8bc412016-08-17 15:02:23 -050013
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050014SRCREV_default = "1f1d0ccd65d3a1caa86dc79d2863a8f067c8e3f8"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015
16# omxplayer builds its own copy of ffmpeg from source instead of using the
17# system's ffmpeg library. This isn't ideal but it's ok for now. We do however
18# want to keep control of the exact version of ffmpeg used instead of just
19# fetching the latest commit on a release branch (which is what the checkout job
20# in Makefile.ffmpeg in the omxplayer source tree does).
21#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022# This SRCREV corresponds to the v4.0.3 release of ffmpeg.
23SRCREV_ffmpeg = "fcbd117df3077bad495e99e20f01cf93737bce76"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024
Andrew Geissler595f6302022-01-24 19:11:47 +000025SRC_URI = "git://github.com/popcornmix/omxplayer.git;protocol=https;branch=master \
26 git://github.com/FFmpeg/FFmpeg;branch=release/4.0;protocol=https;depth=1;name=ffmpeg;destsuffix=git/ffmpeg \
Patrick Williams8b8bc412016-08-17 15:02:23 -050027 file://0002-Libraries-and-headers-from-ffmpeg-are-installed-in-u.patch \
28 file://0003-Remove-strip-step-in-Makefile.patch \
29 file://0004-Add-FFMPEG_EXTRA_CFLAGS-and-FFMPEG_EXTRA_LDFLAGS.patch \
30 file://fix-tar-command-with-DIST.patch \
31 file://use-native-pkg-config.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050032 file://0005-Don-t-require-internet-connection-during-build.patch \
33 file://0006-Prevent-ffmpeg-configure-compile-race-condition.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080034 file://0001-Specify-cc-cxx-and-ld-variables-from-environment.patch \
35 file://cross-crompile-ffmpeg.patch \
Brad Bishopf3fd2882019-06-21 08:06:37 -040036 file://0007-Remove-Makefile-hardcoded-arch-tune.patch \
Patrick Williams8b8bc412016-08-17 15:02:23 -050037 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038
Patrick Williams213cb262021-08-07 19:21:33 -050039SRC_URI:append = "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", " file://0001-Fix-build-with-vc4-driver.patch ", "", d)}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080040
Patrick Williams8b8bc412016-08-17 15:02:23 -050041S = "${WORKDIR}/git"
42
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080043COMPATIBLE_MACHINE = "^rpi$"
Patrick Williams213cb262021-08-07 19:21:33 -050044COMPATIBLE_HOST:aarch64 = "null"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080045
46def cpu(d):
47 for arg in (d.getVar('TUNE_CCARGS') or '').split():
48 if arg.startswith('-mcpu='):
49 return arg[6:]
50 return 'generic'
51
52export CPU = "${@cpu(d)}"
Patrick Williams8b8bc412016-08-17 15:02:23 -050053
54inherit autotools-brokensep pkgconfig
55
Brad Bishop316dfdd2018-06-25 12:45:53 -040056# This isn't used directly by omxplayer, but applied to Makefile.ffmpeg which
57# runs the ffmpeg configuration
58PACKAGECONFIG ??= ""
59PACKAGECONFIG[samba] = "--enable-libsmbclient,--disable-libsmbclient,samba"
60
Patrick Williams8b8bc412016-08-17 15:02:23 -050061# Needed in ffmpeg configure
62export TEMPDIR = "${S}/tmp"
63
64# Needed in Makefile.ffmpeg
65export HOST = "${HOST_SYS}"
66export WORK = "${S}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050067export FFMPEG_EXTRA_CFLAGS = "${TUNE_CCARGS} ${TOOLCHAIN_OPTIONS}"
68export FFMPEG_EXTRA_LDFLAGS = "${TUNE_CCARGS} ${TOOLCHAIN_OPTIONS}"
Patrick Williams8b8bc412016-08-17 15:02:23 -050069
70# Needed in top Makefile
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080071
Patrick Williams8b8bc412016-08-17 15:02:23 -050072export LDFLAGS = "-L${S}/ffmpeg_compiled/usr/lib \
73 -L${STAGING_DIR_HOST}/lib \
74 -L${STAGING_DIR_HOST}/usr/lib \
75 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080076export INCLUDES = "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", " -D__GBM__", "", d)} \
77 -isystem${STAGING_DIR_HOST}/usr/include/interface/vcos/pthreads \
Patrick Williams8b8bc412016-08-17 15:02:23 -050078 -isystem${STAGING_DIR_HOST}/usr/include/freetype2 \
79 -isystem${STAGING_DIR_HOST}/usr/include/interface/vmcs_host/linux \
80 -isystem${STAGING_DIR_HOST}/usr/include/dbus-1.0 \
81 -isystem${STAGING_DIR_HOST}/usr/lib/dbus-1.0/include \
82 "
83export DIST = "${D}"
84
85do_compile() {
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050086 bbwarn "omxplayer is being deprecated and resources are directed at improving vlc."
87
Patrick Williams8b8bc412016-08-17 15:02:23 -050088 # Needed for compiler test in ffmpeg's configure
89 mkdir -p tmp
90
Brad Bishop316dfdd2018-06-25 12:45:53 -040091 sed -i 's/--enable-libsmbclient/${@bb.utils.contains("PACKAGECONFIG", "samba", "--enable-libsmbclient", "--disable-libsmbclient", d)}/g' Makefile.ffmpeg
92
Brad Bishopd7bf8c12018-02-25 22:55:05 -050093 oe_runmake -f Makefile.ffmpeg
94 oe_runmake -f Makefile.ffmpeg install
Patrick Williams8b8bc412016-08-17 15:02:23 -050095 oe_runmake
96}
97
98do_install() {
99 oe_runmake STRIP='echo skipping strip' dist
100 mkdir -p ${D}${datadir}/fonts/truetype/freefont/
101 install ${S}/fonts/* ${D}${datadir}/fonts/truetype/freefont/
102}
103
Patrick Williams213cb262021-08-07 19:21:33 -0500104FILES:${PN} = "${bindir}/omxplayer* \
Patrick Williams8b8bc412016-08-17 15:02:23 -0500105 ${libdir}/omxplayer/lib*${SOLIBS} \
106 ${datadir}/fonts"
107
Patrick Williams213cb262021-08-07 19:21:33 -0500108FILES:${PN}-dev += "${libdir}/omxplayer/*.so"
Patrick Williams8b8bc412016-08-17 15:02:23 -0500109
Patrick Williams213cb262021-08-07 19:21:33 -0500110RDEPENDS:${PN} += "bash procps userland"