blob: fa46cb6b5ab548baf71c186a5060ab68a0e21986 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Linux Kernel Runtime Guard"
2DESCRIPTION="LKRG performs runtime integrity checking of the Linux \
3kernel and detection of security vulnerability exploits against the kernel."
4SECTION = "security"
5HOMEPAGE = "https://www.openwall.com/lkrg/"
Patrick Williamsde0582f2022-04-08 10:23:27 -05006LICENSE = "GPL-2.0-only"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05008LIC_FILES_CHKSUM = "file://LICENSE;md5=3f3e5dd56319d33a1944d635c1c86c6f"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00009
10DEPENDS = "virtual/kernel elfutils"
11
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050012SRC_URI = "git://github.com/lkrg-org/lkrg.git;protocol=https;branch=main"
Andrew Geissler615f2f12022-07-15 14:00:58 -050013
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050014SRCREV = "c58cb52145b8e8ccc6bd19079f5c835933281cdc"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000015
Patrick Williamsde0582f2022-04-08 10:23:27 -050016S = "${WORKDIR}/git"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000017
18inherit module kernel-module-split
19
20MAKE_TARGETS = "modules"
21
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050022MODULE_NAME = "lkrg"
23
24do_configure:append () {
25 sed -i -e 's/^all/modules/' ${S}/Makefile
26 sed -i -e 's/^install/modules_install/' ${S}/Makefile
27 sed -i -e 's/KERNEL/KERNEL_SRC/g' ${S}/Makefile
28}
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000029
30module_do_install() {
31 install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}
32 install -m 0644 ${MODULE_NAME}.ko \
33 ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
34}
35
36RPROVIDES:${PN} += "kernel-module-lkrg"
37
38COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"