blob: 02a9f950cccbcd1c8403eb34e8b68b0ed84f1fbf [file] [log] [blame]
Tom Joseph7b827742017-01-16 16:43:05 +05301SUMMARY = "Phosphor Network IPMI Daemon"
2DESCRIPTION = "Daemon to support IPMI protocol over network"
3HOMEPAGE = "https://github.com/openbmc/phosphor-net-ipmid"
4PR = "r1"
Patrick Ventureafba95a2018-10-01 20:54:34 -07005PV = "1.0+git${SRCPV}"
Brad Bishop75f03872018-11-03 09:41:57 -07006LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Tom Joseph7b827742017-01-16 16:43:05 +05308
George Liu9d1e1c22022-08-08 10:39:05 +08009inherit meson pkgconfig
Vernon Mauery33136592019-03-22 12:25:14 -070010inherit systemd
Tom Joseph7b827742017-01-16 16:43:05 +053011
Vernon Mauery3fcd42e2019-04-12 14:06:06 -070012DEPENDS += "cli11"
Tom Joseph7b827742017-01-16 16:43:05 +053013DEPENDS += "phosphor-mapper"
14DEPENDS += "systemd"
15DEPENDS += "phosphor-ipmi-host"
Tom Joseph7b827742017-01-16 16:43:05 +053016
Patrick Williams12fc9392021-08-06 09:16:53 -050017RRECOMMENDS:${PN} = "pam-ipmi"
Brad Bishopea413432020-08-10 20:18:26 -040018
Patrick Williamsbb99d222022-01-24 15:55:09 -060019SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid;branch=master;protocol=https"
Andrew Geisslere462eb52022-08-15 15:11:26 -050020SRCREV = "ec5ddaf5e5d4a7b6ecb6485957db26e76bd1a226"
Tom Joseph7b827742017-01-16 16:43:05 +053021
22S = "${WORKDIR}/git"
23
George Liu9d1e1c22022-08-08 10:39:05 +080024EXTRA_OEMESON = " \
25 -Dtests=disabled \
26 "
27
Patrick Williams12fc9392021-08-06 09:16:53 -050028FILES:${PN} += " \
Vernon Mauery33136592019-03-22 12:25:14 -070029 ${systemd_system_unitdir}/${PN}@.service \
30 ${systemd_system_unitdir}/${PN}@.socket \
Tom Joseph62b03f22017-01-27 14:11:58 +053031 "
Vernon Mauery33136592019-03-22 12:25:14 -070032
33# If RMCPP_IFACE is not set by bbappend, set it to default
34DEFAULT_RMCPP_IFACE = "eth0"
35RMCPP_IFACE ?= "${DEFAULT_RMCPP_IFACE}"
36
37# install parameterized service and socket files
Patrick Williams12fc9392021-08-06 09:16:53 -050038SYSTEMD_SERVICE:${PN} = " \
Vernon Mauery33136592019-03-22 12:25:14 -070039 ${PN}@${RMCPP_IFACE}.service \
40 ${PN}@${RMCPP_IFACE}.socket \
41 "
42
43# To add another RMCPP interface, add similar lines to the
44# following lines in a bbappend:
45#
46# ALT_RMCPP_IFACE = "eth1"
Patrick Williams12fc9392021-08-06 09:16:53 -050047# SYSTEMD_SERVICE:${PN} += " \
Vernon Mauery33136592019-03-22 12:25:14 -070048# ${PN}@${ALT_RMCPP_IFACE}.service \
49# ${PN}@${ALT_RMCPP_IFACE}.socket \
50# "
51
52# Also, be sure to enable a corresponding entry in the channel
53# config file with the same 'name' as the interfaces above
54# Override the default phosphor-ipmi-config.bb with a bbappend
55