blob: 1874252c87bf7cb4d9f08e64075a6dc838da5ba8 [file] [log] [blame]
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -05001SUMMARY = "PLDM Stack"
2DESCRIPTION = "Implementation of the PLDM specifications"
Tom Josephf6785aa2021-06-15 07:12:34 -07003DEPENDS += "function2"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -05004DEPENDS += "systemd"
Matt Spinlere2375b52020-01-20 14:09:47 -06005DEPENDS += "sdeventplus"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -05006DEPENDS += "phosphor-dbus-interfaces"
7DEPENDS += "nlohmann-json"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -05008DEPENDS += "cli11"
Manojkiran Edac5934752022-09-27 13:59:35 -05009DEPENDS += "libpldm"
Ed Tanous9936f862022-09-19 09:13:20 -070010PV = "1.0+git${SRCPV}"
11PR = "r1"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050012
13S = "${WORKDIR}/git"
Patrick Williams12fc9392021-08-06 09:16:53 -050014SYSTEMD_SERVICE:${PN} += "pldmd.service"
15SYSTEMD_SERVICE:${PN} += "pldmSoftPowerOff.service"
Deepak Kodihallia7482012020-06-22 05:25:35 -050016
Ed Tanous9936f862022-09-19 09:13:20 -070017inherit meson pkgconfig
18inherit systemd
19
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050020EXTRA_OEMESON = " \
21 -Dtests=disabled \
22 -Doem-ibm=disabled \
23 "
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050024
Ed Tanous9936f862022-09-19 09:13:20 -070025pkg_prerm:${PN} () {
26 LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
27 rm $LINK
28 LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
29 rm $LINK
30}
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050031# Install pldmSoftPowerOff.service in correct targets
Patrick Williams12fc9392021-08-06 09:16:53 -050032pkg_postinst:${PN} () {
Manojkiran Eda842eb7f2021-09-15 18:47:42 +053033 mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants
34 LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050035 TARGET="../pldmSoftPowerOff.service"
36 ln -s $TARGET $LINK
Manojkiran Eda842eb7f2021-09-15 18:47:42 +053037 mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants
38 LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050039 TARGET="../pldmSoftPowerOff.service"
40 ln -s $TARGET $LINK
41}
42
Ed Tanous9936f862022-09-19 09:13:20 -070043require pldm.inc