blob: 8072068463c5f6cf8127e601680eb564541a69f7 [file] [log] [blame]
Adriana Kobylakb96c7502021-08-06 16:25:30 +00001EXTRA_OEMESON:append:witherspoon = " -Dwarm-reboot=disabled"
Andrew Geissler65393532021-01-28 13:17:12 -06002
3# The scheduled-host-transition package provides support to
4# schedule power on and off operations for the host at some
5# time in the future. IBM systems will utilize this feature
Adriana Kobylakb96c7502021-08-06 16:25:30 +00006RRECOMMENDS:${PN}-host += "${PN}-scheduled-host-transition"
Andrew Geisslerb2644f82021-02-10 16:11:58 -06007
8# IBM systems track the state of the hypervisor so bring
9# in the needed package when the host state package is
10# included
Adriana Kobylakb96c7502021-08-06 16:25:30 +000011RRECOMMENDS:${PN}-host += "${PN}-hypervisor"
Andrew Geissler192e2862022-02-08 14:23:21 -060012
Andrew Geisslerf0762072022-04-27 18:01:49 +000013# IBM p10 machines want the optional secure-check
14# feature enabled. This will verify all security
15# settings in manufacturing mode.
16RRECOMMENDS:${PN}-host:p10bmc += "${PN}-secure-check"
17
Andrew Geissler192e2862022-02-08 14:23:21 -060018# IBM systems want the chassis package to not allow a
19# system power on if chassis power is in a bad state
20RRECOMMENDS:${PN}-chassis = "${PN}-chassis-check-power-status"
21
Andrew Geissler80a13f82022-03-02 22:30:35 +000022# Override critical services to monitor with IBM file
23FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
24FILES:${PN}-bmc:append = " ${sysconfdir}/phosphor-service-monitor-default.json"
25SRC_URI:append = " file://phosphor-service-monitor-default.json"
26do_install:append() {
27 install -d ${D}${sysconfdir}/phosphor-systemd-target-monitor
28 install -m 0644 ${WORKDIR}/phosphor-service-monitor-default.json \
29 ${D}${sysconfdir}/phosphor-systemd-target-monitor/
30}