Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU cpio is a program to manage archives of files" |
| 2 | DESCRIPTION = "GNU cpio is a tool for creating and extracting archives, or copying files from one place to \ |
| 3 | another. It handles a number of cpio formats as well as reading and writing tar files." |
| 4 | HOMEPAGE = "http://www.gnu.org/software/cpio/" |
| 5 | SECTION = "base" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 6 | LICENSE = "GPL-3.0-only" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949" |
| 8 | |
| 9 | SRC_URI = "${GNU_MIRROR}/cpio/cpio-${PV}.tar.gz \ |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 10 | file://0001-configure-Include-needed-header-for-major-minor-macr.patch \ |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 11 | file://run-ptest \ |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 12 | file://test.sh \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | " |
| 14 | |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "145a340fd9d55f0b84779a44a12d5f79d77c99663967f8cfa168d7905ca52454" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 17 | inherit autotools gettext texinfo ptest |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 19 | # Issue applies to use of cpio in SUSE/OBS, doesn't apply to us |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 20 | CVE_CHECK_IGNORE += "CVE-2010-4226" |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 21 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}" |
| 23 | |
| 24 | do_install () { |
| 25 | autotools_do_install |
| 26 | if [ "${base_bindir}" != "${bindir}" ]; then |
| 27 | install -d ${D}${base_bindir}/ |
| 28 | mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio" |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 29 | if [ "${sbindir}" != "${bindir}" ]; then |
| 30 | rmdir ${D}${bindir}/ |
| 31 | fi |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 32 | fi |
| 33 | |
| 34 | # Avoid conflicts with the version from tar |
| 35 | mv "${D}${mandir}/man8/rmt.8" "${D}${mandir}/man8/rmt-cpio.8" |
| 36 | } |
| 37 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 38 | do_compile_ptest() { |
| 39 | oe_runmake -C ${B}/gnu/ check |
| 40 | oe_runmake -C ${B}/lib/ check |
| 41 | oe_runmake -C ${B}/rmt/ check |
| 42 | oe_runmake -C ${B}/src/ check |
| 43 | oe_runmake -C ${B}/tests/ genfile |
| 44 | } |
| 45 | |
| 46 | do_install_ptest() { |
| 47 | install -d ${D}${PTEST_PATH}/tests/ |
| 48 | sed -i "/abs_/d" ${B}/tests/atconfig |
| 49 | install --mode=755 ${B}/tests/atconfig ${D}${PTEST_PATH}/tests/ |
| 50 | sed -i "s%${B}/tests:%%g" ${B}/tests/atlocal |
| 51 | sed -i "s%${B}/src:%%g" ${B}/tests/atlocal |
| 52 | install --mode=755 ${B}/tests/atlocal ${D}${PTEST_PATH}/tests/ |
| 53 | install --mode=755 ${B}/tests/genfile ${D}${PTEST_PATH}/tests/ |
| 54 | install --mode=755 ${S}/tests/testsuite ${D}${PTEST_PATH}/tests/ |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 55 | install --mode=755 ${WORKDIR}/test.sh ${D}${PTEST_PATH}/test.sh |
| 56 | sed -i "s#@PTEST_PATH@#${PTEST_PATH}#g" ${D}${PTEST_PATH}/test.sh |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 57 | } |
| 58 | |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 59 | # ptest.bbclass currently chowns the ptest directory explicitly, so we need to |
| 60 | # change permission after that has happened so the ptest user can write a |
| 61 | # temporary directory. |
| 62 | do_install_ptest_base:append() { |
| 63 | chgrp -R ptest ${D}${PTEST_PATH}/ |
| 64 | chmod -R g+w ${D}${PTEST_PATH}/ |
| 65 | } |
| 66 | |
| 67 | # The tests need to run as a non-root user, so pull in the ptest user |
| 68 | DEPENDS:append:class-target = "${@bb.utils.contains('PTEST_ENABLED', '1', ' ptest-runner', '', d)}" |
| 69 | PACKAGE_WRITE_DEPS += "ptest-runner" |
| 70 | |
| 71 | RDEPENDS:${PN}-ptest += "ptest-runner" |
| 72 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 73 | PACKAGES =+ "${PN}-rmt" |
| 74 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 75 | FILES:${PN}-rmt = "${sbindir}/rmt*" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 76 | |
| 77 | inherit update-alternatives |
| 78 | |
| 79 | ALTERNATIVE_PRIORITY = "100" |
| 80 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 81 | ALTERNATIVE:${PN} = "cpio" |
| 82 | ALTERNATIVE:${PN}-rmt = "rmt" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 83 | |
| 84 | ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio" |
| 85 | |
| 86 | ALTERNATIVE_PRIORITY[rmt] = "50" |
| 87 | ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt" |
| 88 | |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 89 | BBCLASSEXTEND = "native nativesdk" |