Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU cpio is a program to manage archives of files" |
| 2 | DESCRIPTION = "GNU cpio is a tool for creating and extracting archives, or copying files from one place to \ |
| 3 | another. It handles a number of cpio formats as well as reading and writing tar files." |
| 4 | HOMEPAGE = "http://www.gnu.org/software/cpio/" |
| 5 | SECTION = "base" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 6 | LICENSE = "GPL-3.0-only" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949" |
| 8 | |
| 9 | SRC_URI = "${GNU_MIRROR}/cpio/cpio-${PV}.tar.gz \ |
| 10 | file://0001-Unset-need_charset_alias-when-building-for-musl.patch \ |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 11 | file://0002-src-global.c-Remove-superfluous-declaration-of-progr.patch \ |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 12 | file://0001-obstack-Fix-a-clang-warning.patch \ |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 13 | file://CVE-2021-38185.patch \ |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 14 | file://0001-Use-__alignof__-with-clang.patch \ |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame^] | 15 | file://run-ptest \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | " |
| 17 | |
| 18 | SRC_URI[md5sum] = "389c5452d667c23b5eceb206f5000810" |
| 19 | SRC_URI[sha256sum] = "e87470d9c984317f658567c03bfefb6b0c829ff17dbf6b0de48d71a4c8f3db88" |
| 20 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame^] | 21 | inherit autotools gettext texinfo ptest |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 23 | # Issue applies to use of cpio in SUSE/OBS, doesn't apply to us |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 24 | CVE_CHECK_IGNORE += "CVE-2010-4226" |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 25 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}" |
| 27 | |
| 28 | do_install () { |
| 29 | autotools_do_install |
| 30 | if [ "${base_bindir}" != "${bindir}" ]; then |
| 31 | install -d ${D}${base_bindir}/ |
| 32 | mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio" |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 33 | if [ "${sbindir}" != "${bindir}" ]; then |
| 34 | rmdir ${D}${bindir}/ |
| 35 | fi |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 36 | fi |
| 37 | |
| 38 | # Avoid conflicts with the version from tar |
| 39 | mv "${D}${mandir}/man8/rmt.8" "${D}${mandir}/man8/rmt-cpio.8" |
| 40 | } |
| 41 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame^] | 42 | do_compile_ptest() { |
| 43 | oe_runmake -C ${B}/gnu/ check |
| 44 | oe_runmake -C ${B}/lib/ check |
| 45 | oe_runmake -C ${B}/rmt/ check |
| 46 | oe_runmake -C ${B}/src/ check |
| 47 | oe_runmake -C ${B}/tests/ genfile |
| 48 | } |
| 49 | |
| 50 | do_install_ptest() { |
| 51 | install -d ${D}${PTEST_PATH}/tests/ |
| 52 | sed -i "/abs_/d" ${B}/tests/atconfig |
| 53 | install --mode=755 ${B}/tests/atconfig ${D}${PTEST_PATH}/tests/ |
| 54 | sed -i "s%${B}/tests:%%g" ${B}/tests/atlocal |
| 55 | sed -i "s%${B}/src:%%g" ${B}/tests/atlocal |
| 56 | install --mode=755 ${B}/tests/atlocal ${D}${PTEST_PATH}/tests/ |
| 57 | install --mode=755 ${B}/tests/genfile ${D}${PTEST_PATH}/tests/ |
| 58 | install --mode=755 ${S}/tests/testsuite ${D}${PTEST_PATH}/tests/ |
| 59 | } |
| 60 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 61 | PACKAGES =+ "${PN}-rmt" |
| 62 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 63 | FILES:${PN}-rmt = "${sbindir}/rmt*" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 64 | |
| 65 | inherit update-alternatives |
| 66 | |
| 67 | ALTERNATIVE_PRIORITY = "100" |
| 68 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 69 | ALTERNATIVE:${PN} = "cpio" |
| 70 | ALTERNATIVE:${PN}-rmt = "rmt" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 71 | |
| 72 | ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio" |
| 73 | |
| 74 | ALTERNATIVE_PRIORITY[rmt] = "50" |
| 75 | ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt" |
| 76 | |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 77 | BBCLASSEXTEND = "native nativesdk" |