blob: 7a3c8b308b93045c4d4d0a94f140517ddc42bd69 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GNU cpio is a program to manage archives of files"
2DESCRIPTION = "GNU cpio is a tool for creating and extracting archives, or copying files from one place to \
3another. It handles a number of cpio formats as well as reading and writing tar files."
4HOMEPAGE = "http://www.gnu.org/software/cpio/"
5SECTION = "base"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "GPL-3.0-only"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
8
9SRC_URI = "${GNU_MIRROR}/cpio/cpio-${PV}.tar.gz \
10 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
Andrew Geisslerc182c622020-05-15 14:13:32 -050011 file://0002-src-global.c-Remove-superfluous-declaration-of-progr.patch \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060012 file://0001-obstack-Fix-a-clang-warning.patch \
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050013 file://CVE-2021-38185.patch \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060014 file://0001-Use-__alignof__-with-clang.patch \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060015 file://run-ptest \
Andrew Geissler82c905d2020-04-13 13:39:40 -050016 "
17
18SRC_URI[md5sum] = "389c5452d667c23b5eceb206f5000810"
19SRC_URI[sha256sum] = "e87470d9c984317f658567c03bfefb6b0c829ff17dbf6b0de48d71a4c8f3db88"
20
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060021inherit autotools gettext texinfo ptest
Andrew Geissler82c905d2020-04-13 13:39:40 -050022
William A. Kennington IIIac69b482021-06-02 12:28:27 -070023# Issue applies to use of cpio in SUSE/OBS, doesn't apply to us
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000024CVE_CHECK_IGNORE += "CVE-2010-4226"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070025
Andrew Geissler82c905d2020-04-13 13:39:40 -050026EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}"
27
28do_install () {
29 autotools_do_install
30 if [ "${base_bindir}" != "${bindir}" ]; then
31 install -d ${D}${base_bindir}/
32 mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio"
Andrew Geissler475cb722020-07-10 16:00:51 -050033 if [ "${sbindir}" != "${bindir}" ]; then
34 rmdir ${D}${bindir}/
35 fi
Andrew Geissler82c905d2020-04-13 13:39:40 -050036 fi
37
38 # Avoid conflicts with the version from tar
39 mv "${D}${mandir}/man8/rmt.8" "${D}${mandir}/man8/rmt-cpio.8"
40}
41
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060042do_compile_ptest() {
43 oe_runmake -C ${B}/gnu/ check
44 oe_runmake -C ${B}/lib/ check
45 oe_runmake -C ${B}/rmt/ check
46 oe_runmake -C ${B}/src/ check
47 oe_runmake -C ${B}/tests/ genfile
48}
49
50do_install_ptest() {
51 install -d ${D}${PTEST_PATH}/tests/
52 sed -i "/abs_/d" ${B}/tests/atconfig
53 install --mode=755 ${B}/tests/atconfig ${D}${PTEST_PATH}/tests/
54 sed -i "s%${B}/tests:%%g" ${B}/tests/atlocal
55 sed -i "s%${B}/src:%%g" ${B}/tests/atlocal
56 install --mode=755 ${B}/tests/atlocal ${D}${PTEST_PATH}/tests/
57 install --mode=755 ${B}/tests/genfile ${D}${PTEST_PATH}/tests/
58 install --mode=755 ${S}/tests/testsuite ${D}${PTEST_PATH}/tests/
59}
60
Andrew Geissler82c905d2020-04-13 13:39:40 -050061PACKAGES =+ "${PN}-rmt"
62
Patrick Williams213cb262021-08-07 19:21:33 -050063FILES:${PN}-rmt = "${sbindir}/rmt*"
Andrew Geissler82c905d2020-04-13 13:39:40 -050064
65inherit update-alternatives
66
67ALTERNATIVE_PRIORITY = "100"
68
Patrick Williams213cb262021-08-07 19:21:33 -050069ALTERNATIVE:${PN} = "cpio"
70ALTERNATIVE:${PN}-rmt = "rmt"
Andrew Geissler82c905d2020-04-13 13:39:40 -050071
72ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
73
74ALTERNATIVE_PRIORITY[rmt] = "50"
75ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt"
76
Andrew Geissler475cb722020-07-10 16:00:51 -050077BBCLASSEXTEND = "native nativesdk"