blob: d3d1cfde60c42f7c480430c9f81185ac38b2a571 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "The Bitstream Vera fonts - TTF Edition"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05002HOMEPAGE = "https://www.gnome.org/fonts/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003DESCRIPTION = "The Bitstream Vera fonts include four monospace and sans \
4faces (normal, oblique, bold, bold oblique) and two serif faces (normal \
5and bold). In addition Fontconfig/Xft2 can artificially oblique the \
6serif faces for you: this loses hinting and distorts the faces slightly, \
7but is visibly different than normal and bold, and reasonably pleasing."
8SECTION = "x11/fonts"
9LICENSE = "BitstreamVera"
10LIC_FILES_CHKSUM = "file://COPYRIGHT.TXT;md5=27d7484b1e18d0ee4ce538644a3f04be"
Andrew Geissler90fd73c2021-03-05 15:25:55 -060011PR = "r8"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012
Andrew Geissler635e0e42020-08-21 15:58:33 -050013inherit allarch fontcache
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014
15FONT_PACKAGES = "${PN}"
16
Brad Bishop316dfdd2018-06-25 12:45:53 -040017SRC_URI = "${GNOME_MIRROR}/ttf-bitstream-vera/1.10/ttf-bitstream-vera-${PV}.tar.bz2"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018SRC_URI[md5sum] = "bb22bd5b4675f5dbe17c6963d8c00ed6"
19SRC_URI[sha256sum] = "db5b27df7bbb318036ebdb75acd3e98f1bd6eb6608fb70a67d478cd243d178dc"
Brad Bishop316dfdd2018-06-25 12:45:53 -040020
21do_install () {
22 install -d ${D}${datadir}/fonts/ttf
23 for i in *.ttf; do
24 install -m 644 $i ${D}${datadir}/fonts/ttf
25 done
26
27 install -d ${D}${docdir}/${BPN}
28 for i in *.TXT; do
29 install -m 644 $i ${D}${docdir}/${BPN}
30 done
31}
32
Patrick Williams213cb262021-08-07 19:21:33 -050033FILES:${PN} = "${datadir}/fonts"