blob: b0666043cc2a59299bb6f238ccb12696d43f1a57 [file] [log] [blame]
Brad Bishop83254dc2015-10-27 17:12:45 -04001SUMMARY = "Phosphor DBUS Object Manager"
2DESCRIPTION = "Phosphor DBUS object manager."
3HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Matthew Barth11381c42016-10-05 16:20:54 -05008inherit autotools pkgconfig
Matthew Barth730ecb82016-11-16 10:17:02 -06009inherit obmc-phosphor-python-autotools
Brad Bishop83254dc2015-10-27 17:12:45 -040010inherit obmc-phosphor-dbus-service
11inherit obmc-phosphor-systemd
Brad Bishop83254dc2015-10-27 17:12:45 -040012
Brad Bishop5f077512016-08-07 23:18:32 -040013DEPENDS += "systemd"
Matthew Barth11381c42016-10-05 16:20:54 -050014DEPENDS += "autoconf-archive-native"
Rick Altherr68aa1402016-08-01 14:20:50 -070015
Brad Bishop59fc7e32016-11-02 15:21:22 -040016DBUS_SERVICE_${PN} += "xyz.openbmc_project.ObjectMapper.service"
Adriana Kobylakfcaf72e2017-04-11 11:06:59 -050017SYSTEMD_SERVICE_${PN} += " \
18 mapper-wait@.service \
19 mapper-subtree-remove@.service \
20 "
Matthew Barth11381c42016-10-05 16:20:54 -050021RDEPENDS_libmapper += "libsystemd"
Brad Bishop83254dc2015-10-27 17:12:45 -040022RDEPENDS_${PN} += " \
23 python-xml \
24 python-dbus \
25 python-pygobject \
Patrick Williams73f46432017-03-03 12:52:30 -060026 pyphosphor-dbus \
Brad Bishop83254dc2015-10-27 17:12:45 -040027 "
Chris Austenb70cb7e2015-12-02 22:32:06 -060028SRC_URI += "git://github.com/openbmc/phosphor-objmgr"
Brad Bishop83254dc2015-10-27 17:12:45 -040029
Patrick Williams7007baa2017-05-19 09:40:04 -050030SRCREV = "b2f2681fc8289f1089fb616b1156802251f4721f"
Brad Bishop83254dc2015-10-27 17:12:45 -040031
32S = "${WORKDIR}/git"
Brad Bishopea4022a2016-07-26 15:52:01 -040033
Brad Bishopea4022a2016-07-26 15:52:01 -040034python populate_packages_prepend () {
35 mapperlibdir = d.getVar("libdir", True)
36 do_split_packages(d, mapperlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Phosphor mapper %s library', extra_depends='', allow_links=True)
37}
38PACKAGES_DYNAMIC += "^libmapper.*"
39FILES_${PN}_remove = "${libdir}/lib*.so.* ${libdir}/*"