Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "ModemManager is a daemon controlling broadband devices/connections" |
| 2 | DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections" |
| 3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/" |
| 4 | LICENSE = "GPL-2.0 & LGPL-2.1" |
| 5 | LIC_FILES_CHKSUM = " \ |
| 6 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 7 | file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \ |
| 8 | " |
| 9 | |
| 10 | inherit gnomebase gettext systemd vala gobject-introspection bash-completion |
| 11 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 12 | DEPENDS = "glib-2.0 libgudev intltool-native libxslt-native" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | |
| 14 | SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz \ |
| 15 | " |
Brad Bishop | 36a3e3e | 2019-10-02 13:29:27 -0400 | [diff] [blame^] | 16 | |
| 17 | SRC_URI[md5sum] = "dad80b3b4f27c1d6eae7e019542338be" |
| 18 | SRC_URI[sha256sum] = "bbcf6da35da3d72f688675bde91dfed6485845c3fedd1805ae914b71d1b783f2" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/ModemManager-${PV}" |
| 21 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | PACKAGECONFIG ??= "mbim qmi \ |
| 23 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd polkit', d)} \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | " |
| 25 | |
| 26 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,," |
| 27 | PACKAGECONFIG[polkit] = "--with-polkit=yes,--with-polkit=no,polkit" |
| 28 | # Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol. |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 29 | PACKAGECONFIG[mbim] = "--with-mbim,--without-mbim,libmbim" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 30 | # Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol. |
| 31 | PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi" |
| 32 | |
| 33 | EXTRA_OECONF = " \ |
| 34 | --with-udev-base-dir=${nonarch_base_libdir}/udev \ |
| 35 | " |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 36 | EXTRA_OECONF_append_toolchain-clang = " --enable-more-warnings=no" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 37 | |
| 38 | FILES_${PN} += " \ |
| 39 | ${datadir}/icons \ |
| 40 | ${datadir}/polkit-1 \ |
| 41 | ${datadir}/dbus-1 \ |
Brad Bishop | 36a3e3e | 2019-10-02 13:29:27 -0400 | [diff] [blame^] | 42 | ${datadir}/ModemManager \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 43 | ${libdir}/ModemManager \ |
| 44 | ${systemd_unitdir}/system \ |
| 45 | " |
| 46 | |
| 47 | FILES_${PN}-dev += " \ |
| 48 | ${libdir}/ModemManager/*.la \ |
| 49 | " |
| 50 | |
| 51 | FILES_${PN}-staticdev += " \ |
| 52 | ${libdir}/ModemManager/*.a \ |
| 53 | " |
| 54 | |
| 55 | FILES_${PN}-dbg += "${libdir}/ModemManager/.debug" |
| 56 | |
| 57 | SYSTEMD_SERVICE_${PN} = "ModemManager.service" |