blob: 1f108eb466c8b7f9fdc4cfd970045f69c613bfa7 [file] [log] [blame]
Brad Bishop593bd472017-01-12 22:12:01 -05001SUMMARY = "Phosphor Inventory Manager"
2DESCRIPTION = "Phosphor Inventory Manager is an inventory object \
3lifecycle management application, suitable for use on a wide variety \
4of OpenBMC platforms."
5PR = "r1"
Patrick Ventureaad74492018-10-17 07:48:17 -07006PV = "1.0+git${SRCPV}"
Brad Bishop593bd472017-01-12 22:12:01 -05007
8inherit autotools \
9 pkgconfig \
Andrew Geissler7f303982020-04-06 01:41:13 +000010 python3native \
Marri Devender Raoebb0c2e2017-06-08 23:53:04 -050011 phosphor-dbus-yaml \
Brad Bishopadb7ebe2017-01-28 15:28:17 -050012 phosphor-inventory-manager \
Brad Bishop593bd472017-01-12 22:12:01 -050013 obmc-phosphor-dbus-service
14
15require phosphor-inventory-manager.inc
16
17DEPENDS += " \
Brad Bishop1675a602019-05-22 19:21:40 -040018 phosphor-inventory-manager-assettag \
Brad Bishop6c2ed922017-02-13 22:51:36 -050019 phosphor-dbus-interfaces \
Brad Bishop8bdfe152017-02-15 14:11:50 -050020 phosphor-logging \
Brad Bishop593bd472017-01-12 22:12:01 -050021 sdbusplus \
Patrick Williams2bebd122020-03-31 16:43:15 -050022 ${PYTHON_PN}-sdbus++-native \
Brad Bishop593bd472017-01-12 22:12:01 -050023 autoconf-archive-native \
Brad Bishopcc51cd92018-10-18 17:07:53 -040024 libcereal \
Andrew Geissler89d17812020-03-05 09:27:35 -060025 ${PYTHON_PN}-native \
26 ${PYTHON_PN}-pyyaml-native \
27 ${PYTHON_PN}-mako-native \
Brad Bishop593bd472017-01-12 22:12:01 -050028 "
Brad Bishop593bd472017-01-12 22:12:01 -050029
Brad Bishopa885ed42017-02-23 10:44:48 -050030OBMC_INVENTORY_PATH="${OBMC_DBUS_PATH_ROOT}/inventory"
Brad Bishop593bd472017-01-12 22:12:01 -050031OBMC_INVENTORY_MGR_IFACE="${OBMC_DBUS_IFACE_ROOT}.Inventory.Manager"
32
33DBUS_SERVICE_${PN} = "${OBMC_INVENTORY_MGR_IFACE}.service"
34
35S = "${WORKDIR}/git"
36
37EXTRA_OECONF = " \
Brad Bishop1675a602019-05-22 19:21:40 -040038 YAML_PATH=${STAGING_DIR_HOST}${base_datadir} \
Brad Bishop593bd472017-01-12 22:12:01 -050039 BUSNAME=${OBMC_INVENTORY_MGR_IFACE} \
40 INVENTORY_ROOT=${OBMC_INVENTORY_PATH} \
41 IFACE=${OBMC_INVENTORY_MGR_IFACE} \
Patrick Williamsc6f2c882020-06-10 06:52:05 -050042 IFACES_PATH=${STAGING_DIR_TARGET}${yaml_dir} \
Brad Bishop593bd472017-01-12 22:12:01 -050043 "
Matt Spinler6bc9cd42019-03-11 16:24:03 -050044
45PACKAGECONFIG ??= ""
46PACKAGECONFIG[associations] = "--enable-associations, --disable-associations,nlohmann-json,"