blob: 26fbcd1f6ba6e93a15a1262e7f3da771e012841b [file] [log] [blame]
Brad Bishope94b9152016-08-08 20:21:44 -04001SUMMARY = "Phosphor Systemd targets"
Gunnar Millsfb51a9a2018-01-09 16:40:15 -06002DESCRIPTION = "Provides well known Systemd synchronization points for OpenBMC."
Brad Bishope94b9152016-08-08 20:21:44 -04003HOMEPAGE = "http://github.com/openbmc"
4PR = "r1"
5
6inherit obmc-phosphor-systemd
7inherit obmc-phosphor-license
8inherit allarch
9
Josh D. Kinga283e072017-04-06 15:56:37 -050010# Chassis power synchronization targets
Andrew Geissler997ed662017-03-05 20:36:50 -060011# - start-pre: Services to run before we start power on process
12# - start: Services to run to do the chassis power on
13# - on: Services to run once power is on
14# - stop-pre,stop,off: Same as above but applied to powering off
15# - reset-on: Services to check if chassis power is on after bmc reset
Josh D. Kinga283e072017-04-06 15:56:37 -050016CHASSIS_SYNCH_TARGETS = "start-pre start on stop-pre stop off reset-on"
Andrew Geissler997ed662017-03-05 20:36:50 -060017
Josh D. Kinga283e072017-04-06 15:56:37 -050018# Chassis action power targets
Andrew Geissler997ed662017-03-05 20:36:50 -060019# - on: Services to run to power on the chassis
20# - off: Services to run to power off the chassis
Matthew Barth1851aa62018-01-10 09:16:28 -060021# - powered-off: Services to run once chassis power is off
Andrew Geissler997ed662017-03-05 20:36:50 -060022# - reset: Services to check chassis power state and update chassis "on" target
Andrew Geissler4a0f3322017-07-20 10:28:34 -050023# - hard-off: Services to force an immediate power off of the chassis
Matthew Barth1851aa62018-01-10 09:16:28 -060024CHASSIS_ACTION_TARGETS = "poweron poweroff powered-off powerreset hard-poweroff"
Andrew Geissler997ed662017-03-05 20:36:50 -060025
26# Track all host synchronization point targets
Josh D. Kinga283e072017-04-06 15:56:37 -050027# - start-pre: Services to run before we start host boot
28# - starting: Services to run to do the host boot
29# - started: Services to run once the host is booted
30# - stop-pre,stopping,stopped: Same as above but applied to shutting down the host
31# - reset-running: Services to check if host is running after bmc reset
32HOST_SYNCH_TARGETS = "start-pre starting started stop-pre stopping stopped reset-running"
Andrew Geissler997ed662017-03-05 20:36:50 -060033
Andrew Geissler9ccc3662017-01-04 11:11:00 -060034# Track all host action targets
Josh D. King3c7a8ef2017-04-11 09:48:10 -050035# - start: Service to run to start the host
36# - stop: Services to run to shutdown the host
37# - quiesce: Target to enter on host boot failure
38# - shutdown: Tell host to shutdown, then stop system
Josh D. Kinga283e072017-04-06 15:56:37 -050039# - reset: Services to check if host is running and update host "start" target
Vishwanatha Subbanna49c4e502017-04-04 16:41:02 +053040# - crash: Target to run when host crashes. it is very much similar to
41# quiesce target but the only delta is that this target contains
42# multiple services and one of them is the quiesce target.
Vishwanatha Subbannafad09562017-06-12 14:48:29 +053043# - timeout: Target to run when host watchdog times out
Andrew Geisslercd2b9462017-07-26 17:53:04 -050044# - reboot: Reboot the host
45HOST_ACTION_TARGETS = "start stop quiesce reset shutdown crash timeout reboot"
Brad Bishope94b9152016-08-08 20:21:44 -040046
Josh D. Kinga283e072017-04-06 15:56:37 -050047CHASSIS_SYNCH_FMT = "obmc-power-{0}@.target"
Andrew Geissler4a0f3322017-07-20 10:28:34 -050048CHASSIS_ACTION_FMT = "obmc-chassis-{0}@.target"
Andrew Geissler9ccc3662017-01-04 11:11:00 -060049HOST_SYNCH_FMT = "obmc-host-{0}@.target"
Josh D. Kinga283e072017-04-06 15:56:37 -050050HOST_ACTION_FMT = "obmc-host-{0}@.target"
Brad Bishope94b9152016-08-08 20:21:44 -040051
Josh D. Kinga283e072017-04-06 15:56:37 -050052CHASSIS_LINK_SYNCH_FMT = "${CHASSIS_SYNCH_FMT}:obmc-power-{0}@{1}.target"
Andrew Geissler4a0f3322017-07-20 10:28:34 -050053CHASSIS_LINK_ACTION_FMT = "${CHASSIS_ACTION_FMT}:obmc-chassis-{0}@{1}.target"
Andrew Geissler9ccc3662017-01-04 11:11:00 -060054HOST_LINK_SYNCH_FMT = "${HOST_SYNCH_FMT}:obmc-host-{0}@{1}.target"
Josh D. Kinga283e072017-04-06 15:56:37 -050055HOST_LINK_ACTION_FMT = "${HOST_ACTION_FMT}:obmc-host-{0}@{1}.target"
Matt Spinler393c9b12017-05-16 11:57:20 -050056FAN_LINK_FMT = "obmc-fan-control-ready@.target:obmc-fan-control-ready@{0}.target"
Brad Bishope94b9152016-08-08 20:21:44 -040057
Vishwanatha Subbannafad09562017-06-12 14:48:29 +053058# Targets to be executed on checkstop and watchdog timeout
59HOST_ERROR_TARGETS = "crash timeout"
60
Vishwanatha Subbanna49c4e502017-04-04 16:41:02 +053061QUIESCE_TMPL = "obmc-host-quiesce@.target"
Vishwanatha Subbannafad09562017-06-12 14:48:29 +053062CRASH_TIMEOUT_TGTFMT = "obmc-host-{0}@{1}.target"
63QUIESCE_INSTFMT = "obmc-host-quiesce@{1}.target"
64QUIESCE_FMT = "../${QUIESCE_TMPL}:${CRASH_TIMEOUT_TGTFMT}.wants/${QUIESCE_INSTFMT}"
Vishwanatha Subbanna49c4e502017-04-04 16:41:02 +053065
Brad Bishope94b9152016-08-08 20:21:44 -040066SYSTEMD_SERVICE_${PN} += " \
67 obmc-mapper.target \
Brad Bishopd969da32016-08-30 00:21:14 -040068 obmc-webserver-pre.target \
Brad Bishope94b9152016-08-08 20:21:44 -040069 obmc-fans-ready.target \
70 obmc-fan-control.target \
Matt Spinler393c9b12017-05-16 11:57:20 -050071 obmc-fan-control-ready@.target \
Matt Spinler4c2af632017-06-08 12:20:07 -050072 obmc-fan-watchdog-takeover.target \
Brad Bishope94b9152016-08-08 20:21:44 -040073 obmc-standby.target \
74 "
75
Josh D. Kinga283e072017-04-06 15:56:37 -050076SYSTEMD_SERVICE_${PN} += "${@compose_list(d, 'CHASSIS_SYNCH_FMT', 'CHASSIS_SYNCH_TARGETS')}"
77SYSTEMD_SERVICE_${PN} += "${@compose_list(d, 'CHASSIS_ACTION_FMT', 'CHASSIS_ACTION_TARGETS')}"
Andrew Geissler9ccc3662017-01-04 11:11:00 -060078SYSTEMD_SERVICE_${PN} += "${@compose_list(d, 'HOST_SYNCH_FMT', 'HOST_SYNCH_TARGETS')}"
79SYSTEMD_SERVICE_${PN} += "${@compose_list(d, 'HOST_ACTION_FMT', 'HOST_ACTION_TARGETS')}"
Brad Bishope94b9152016-08-08 20:21:44 -040080
Josh D. Kinga283e072017-04-06 15:56:37 -050081SYSTEMD_LINK_${PN} += "${@compose_list(d, 'CHASSIS_LINK_SYNCH_FMT', 'CHASSIS_SYNCH_TARGETS', 'OBMC_CHASSIS_INSTANCES')}"
82SYSTEMD_LINK_${PN} += "${@compose_list(d, 'CHASSIS_LINK_ACTION_FMT', 'CHASSIS_ACTION_TARGETS', 'OBMC_CHASSIS_INSTANCES')}"
Andrew Geissler9ccc3662017-01-04 11:11:00 -060083SYSTEMD_LINK_${PN} += "${@compose_list(d, 'HOST_LINK_SYNCH_FMT', 'HOST_SYNCH_TARGETS', 'OBMC_HOST_INSTANCES')}"
84SYSTEMD_LINK_${PN} += "${@compose_list(d, 'HOST_LINK_ACTION_FMT', 'HOST_ACTION_TARGETS', 'OBMC_HOST_INSTANCES')}"
Matt Spinler393c9b12017-05-16 11:57:20 -050085SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FAN_LINK_FMT', 'OBMC_CHASSIS_INSTANCES')}"
Vishwanatha Subbannafad09562017-06-12 14:48:29 +053086SYSTEMD_LINK_${PN} += "${@compose_list(d, 'QUIESCE_FMT', 'HOST_ERROR_TARGETS', 'OBMC_HOST_INSTANCES')}"