Hariharasubramanian R | 5c3fd8a | 2016-02-10 13:48:33 -0600 | [diff] [blame] | 1 | SUMMARY = "User DBUS object" |
| 2 | DESCRIPTION = "User DBUS object" |
| 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-networkd" |
| 4 | PR = "r1" |
| 5 | |
Brad Bishop | a6a1ae0 | 2016-09-06 21:28:21 -0400 | [diff] [blame] | 6 | inherit allarch |
Hariharasubramanian R | 5c3fd8a | 2016-02-10 13:48:33 -0600 | [diff] [blame] | 7 | inherit obmc-phosphor-license |
Brad Bishop | a6a1ae0 | 2016-09-06 21:28:21 -0400 | [diff] [blame] | 8 | inherit obmc-phosphor-dbus-service |
Hariharasubramanian R | 5c3fd8a | 2016-02-10 13:48:33 -0600 | [diff] [blame] | 9 | |
Brad Bishop | a715681 | 2016-09-06 22:02:03 -0400 | [diff] [blame] | 10 | PROVIDES += "virtual/obmc-user-mgmt" |
| 11 | RPROVIDES_${PN} += "virtual-obmc-user-mgmt" |
| 12 | |
Hariharasubramanian R | 5c3fd8a | 2016-02-10 13:48:33 -0600 | [diff] [blame] | 13 | RDEPENDS_${PN} += "python-dbus python-pygobject python-pexpect" |
| 14 | |
| 15 | SRC_URI += "git://github.com/openbmc/phosphor-networkd" |
| 16 | |
Patrick Williams | 2601d72 | 2016-09-12 13:50:07 -0500 | [diff] [blame] | 17 | SRCREV = "15d498e2568b6e104de75e7423caab0c9a487485" |
Hariharasubramanian R | 5c3fd8a | 2016-02-10 13:48:33 -0600 | [diff] [blame] | 18 | |
| 19 | S = "${WORKDIR}/git" |
Adriana Kobylak | f1cd2b5 | 2016-02-11 16:31:21 -0600 | [diff] [blame] | 20 | INSTALL_NAME = "userman.py" |
Hariharasubramanian R | 5c3fd8a | 2016-02-10 13:48:33 -0600 | [diff] [blame] | 21 | |
Brad Bishop | a6a1ae0 | 2016-09-06 21:28:21 -0400 | [diff] [blame] | 22 | DBUS_SERVICE_${PN} += "org.openbmc.UserManager.service" |
| 23 | |
Patrick Williams | af6d09d | 2016-08-15 15:52:09 -0500 | [diff] [blame] | 24 | # Since base_do_compile finds a makefile (from networkd) it tries to |
| 25 | # compile. Short-circuit that because we just need to copy a python |
| 26 | # file in this package. |
| 27 | do_compile() { |
| 28 | : |
| 29 | } |
| 30 | |
Brad Bishop | a6a1ae0 | 2016-09-06 21:28:21 -0400 | [diff] [blame] | 31 | do_install_append() { |
Adriana Kobylak | f1cd2b5 | 2016-02-11 16:31:21 -0600 | [diff] [blame] | 32 | echo "***installing $INSTALL_NAME" |
Hariharasubramanian R | 5c3fd8a | 2016-02-10 13:48:33 -0600 | [diff] [blame] | 33 | install -d ${D}/${sbindir} |
Adriana Kobylak | f1cd2b5 | 2016-02-11 16:31:21 -0600 | [diff] [blame] | 34 | install ${S}/${INSTALL_NAME} ${D}/${sbindir}/obmc-phosphor-userd |
Hariharasubramanian R | 5c3fd8a | 2016-02-10 13:48:33 -0600 | [diff] [blame] | 35 | } |
| 36 | |