blob: 41164a5dd4cfc1527f5f4cbdf16e6dab34451ffb [file] [log] [blame]
Brad Bishop667938f2017-01-12 21:44:51 -05001SUMMARY = "OpenBMC - Applications"
Brad Bishop93fb5352015-09-09 03:59:20 +00002PR = "r1"
3
4inherit packagegroup
Brad Bishop93fb5352015-09-09 03:59:20 +00005
Brad Bishop93fb5352015-09-09 03:59:20 +00006PROVIDES = "${PACKAGES}"
7PACKAGES = " \
Brad Bishop46631702017-03-01 16:16:06 -05008 ${PN}-bmc-state-mgmt \
9 ${PN}-chassis-state-mgmt \
Brad Bishop6165ec32016-09-06 22:44:21 -040010 ${PN}-extras \
Brad Bishop113fe562020-08-10 20:20:47 -040011 ${PN}-devtools \
Brad Bishop11909e02017-05-01 11:54:34 -040012 ${PN}-fan-control \
Brad Bishop46631702017-03-01 16:16:06 -050013 ${PN}-host-state-mgmt \
Brad Bishop45f8b572017-02-01 21:04:14 -050014 ${PN}-inventory \
15 ${PN}-leds \
Brad Bishop09486912018-03-23 13:07:46 -040016 ${PN}-logging \
Adriana Kobylaka4c5db02018-10-16 11:02:54 -050017 ${PN}-remote-logging \
Brad Bishop45f8b572017-02-01 21:04:14 -050018 ${PN}-sensors \
Gunnar Millsc868f922017-02-15 16:01:45 -060019 ${PN}-software \
Andrew Geisslera94faf42017-05-08 15:58:01 -050020 ${PN}-host-check-mgmt \
Jayanth Othayoth9963d172017-05-08 09:25:05 -050021 ${PN}-debug-collector \
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -050022 ${PN}-settings \
Ratan Guptab6de45c2017-07-06 21:09:14 +053023 ${PN}-network \
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +053024 ${PN}-user-mgmt \
Brad Bishop93fb5352015-09-09 03:59:20 +000025 "
26
Brad Bishop46631702017-03-01 16:16:06 -050027SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
28RDEPENDS_${PN}-bmc-state-mgmt = " \
29 ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \
Andrew Geisslere36b7272019-08-14 10:01:10 -050030 phosphor-state-manager-systemd-target-monitor \
Brad Bishop46631702017-03-01 16:16:06 -050031 "
32
33SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management"
34RDEPENDS_${PN}-chassis-state-mgmt = " \
35 ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
Anthony Wilson3492fb92019-03-30 08:11:32 -070036 obmc-phosphor-power \
Brad Bishop46631702017-03-01 16:16:06 -050037 "
38
Brad Bishop6165ec32016-09-06 22:44:21 -040039SUMMARY_${PN}-extras = "Extra features"
40RDEPENDS_${PN}-extras = " \
Ed Tanous7bfe2962018-09-18 08:46:34 -070041 bmcweb \
Ed Tanous80c1e1a2019-06-12 14:35:33 -070042 phosphor-bmcweb-cert-config \
Marri Devender Rao1f2e5dc2019-06-13 06:50:49 -050043 phosphor-nslcd-cert-config \
44 phosphor-nslcd-authority-cert-config \
Eddie James6ace8c02019-04-10 15:13:03 +000045 obmc-ikvm \
Brad Bishopf1cc41b2017-05-31 14:08:33 -040046 phosphor-dbus-monitor \
Andrew Geissler65430332018-07-19 11:44:03 -070047 phosphor-systemd-policy \
Brad Bishop70436da2015-09-16 14:49:27 -040048 "
49
Brad Bishop113fe562020-08-10 20:20:47 -040050SUMMARY_${PN}-devtools = "Development tools"
51RDEPENDS_${PN}-devtools = " \
52 bash \
53 i2c-tools \
James Feist76d4c462019-05-30 11:58:40 -070054 libgpiod-tools \
Brad Bishop113fe562020-08-10 20:20:47 -040055 lrzsz \
56 rsync \
Adriana Kobylak0bce5322017-11-09 10:39:02 -060057 "
58
Brad Bishop11909e02017-05-01 11:54:34 -040059# Use the fan control package group for applications
60# implementing fan control or system fan policy only.
61# Applications that create inventory or sensors should
62# be added those respective package groups instead.
63SUMMARY_${PN}-fan-control = "Fan control"
64RDEPENDS_${PN}-fan-control = " \
Matt Spinlerbd9fdd92017-04-19 08:23:50 -050065 ${VIRTUAL-RUNTIME_obmc-fan-control} \
Matt Spinler39652c82017-05-01 14:29:20 -050066 phosphor-fan-monitor \
Brad Bishop11909e02017-05-01 11:54:34 -040067 "
68
Brad Bishop46631702017-03-01 16:16:06 -050069SUMMARY_${PN}-host-state-mgmt = "Host state management"
70RDEPENDS_${PN}-host-state-mgmt = " \
71 ${VIRTUAL-RUNTIME_obmc-host-state-manager} \
Michael Tritz1f792e02017-03-31 12:04:32 -050072 ${VIRTUAL-RUNTIME_obmc-discover-system-state} \
Brad Bishop46631702017-03-01 16:16:06 -050073 "
74
Brad Bishop45f8b572017-02-01 21:04:14 -050075SUMMARY_${PN}-inventory = "Inventory applications"
76RDEPENDS_${PN}-inventory = " \
77 ${VIRTUAL-RUNTIME_obmc-inventory-manager} \
Matthew Barth91460422017-02-24 13:14:43 -060078 ${VIRTUAL-RUNTIME_obmc-fan-presence} \
Brad Bishop45f8b572017-02-01 21:04:14 -050079 "
80
81SUMMARY_${PN}-leds = "LED applications"
82RDEPENDS_${PN}-leds = " \
Brad Bishopc1d30c52017-02-27 11:59:49 -050083 ${VIRTUAL-RUNTIME_obmc-leds-manager} \
84 ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \
Dhruvaraj Subhashchandrane1266ad2017-04-27 05:29:56 -050085 ${VIRTUAL-RUNTIME_obmc-led-monitor} \
Brad Bishop45f8b572017-02-01 21:04:14 -050086 "
87
Brad Bishop09486912018-03-23 13:07:46 -040088SUMMARY_${PN}-logging = "Logging applications"
89RDEPENDS_${PN}-logging = " \
90 phosphor-logging \
Adriana Kobylaka4c5db02018-10-16 11:02:54 -050091 "
92
93SUMMARY_${PN}-remote-logging = "Remote logging applications"
94RDEPENDS_${PN}-remote-logging = " \
Deepak Kodihallia549e752018-08-21 06:40:53 -050095 rsyslog \
Deepak Kodihallif99f3c82018-08-28 11:39:41 -050096 phosphor-rsyslog-config \
Brad Bishop09486912018-03-23 13:07:46 -040097 "
98
Brad Bishop45f8b572017-02-01 21:04:14 -050099SUMMARY_${PN}-sensors = "Sensor applications"
100RDEPENDS_${PN}-sensors = " \
101 ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \
102 "
Gunnar Millsc868f922017-02-15 16:01:45 -0600103
Lei YU005193d2019-05-06 14:35:27 +0800104${PN}-software-extras = ""
Brad Bishop811eeec2018-03-09 00:04:00 -0500105
Eddie James1a623ef2018-02-09 11:59:18 -0600106${PN}-software-extras_df-obmc-ubi-fs = " \
Adriana Kobylak3aeee112018-06-04 13:06:52 -0500107 phosphor-software-manager-updater-ubi \
Eddie James1a623ef2018-02-09 11:59:18 -0600108 "
Brad Bishop811eeec2018-03-09 00:04:00 -0500109
Adriana Kobylak7df4aa02020-06-04 14:03:03 -0500110${PN}-software-extras_df-phosphor-mmc = " \
111 phosphor-software-manager-updater-mmc \
112 "
113
Gunnar Millsc868f922017-02-15 16:01:45 -0600114SUMMARY_${PN}-software = "Software applications"
115RDEPENDS_${PN}-software = " \
Deepak Kodihalli60d1de52017-04-13 23:23:42 -0500116 ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \
Gunnar Mills30131f72017-05-15 15:40:58 -0500117 ${VIRTUAL-RUNTIME_obmc-bmc-updater} \
Andrew Geissler1f957522018-02-09 12:50:57 -0800118 ${VIRTUAL-RUNTIME_obmc-bmc-version} \
Brad Bishop811eeec2018-03-09 00:04:00 -0500119 ${${PN}-software-extras} \
Andrew Geissler1f957522018-02-09 12:50:57 -0800120 "
121
Jayanth Othayoth9963d172017-05-08 09:25:05 -0500122SUMMARY_${PN}-debug-collector = "BMC debug collector"
123RDEPENDS_${PN}-debug-collector = " \
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -0500124 ${VIRTUAL-RUNTIME_obmc-dump-manager} \
125 ${VIRTUAL-RUNTIME_obmc-dump-monitor} \
Jayanth Othayothd2592492017-07-29 22:28:44 -0500126 phosphor-debug-collector-dreport \
Marri Devender Rao33603922017-10-11 02:22:46 -0500127 phosphor-debug-collector-scripts \
Vishwanatha Subbanna14609cb2017-05-12 23:31:55 +0530128 "
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -0500129
130SUMMARY_${PN}-settings = "Settings applications"
131RDEPENDS_${PN}-settings = " \
Brad Bishopa71cf482020-03-19 16:14:54 -0400132 phosphor-settings-manager \
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -0500133 "
Ratan Guptab6de45c2017-07-06 21:09:14 +0530134
135SUMMARY_${PN}-network = "BMC Network Manager"
136RDEPENDS_${PN}-network = " \
137 ${VIRTUAL-RUNTIME_obmc-network-manager} \
138 "
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +0530139
140SUMMARY_${PN}-user-mgmt = "User management applications"
141RDEPENDS_${PN}-user-mgmt = " \
142 ${VIRTUAL-RUNTIME_obmc-user-mgmt} \
Ratan Gupta4835bb32018-09-03 08:41:52 +0530143 ${@bb.utils.contains('DISTRO_FEATURES', 'ldap', 'nss-pam-ldapd', '', d)} \
Nagaraju Goruganti6d7f6402018-09-03 21:56:42 -0500144 ${@bb.utils.contains('DISTRO_FEATURES', 'ldap', 'phosphor-ldap', '', d)} \
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +0530145 "