blob: 0fda3daec9875903d1f618a52eae898f41864c16 [file] [log] [blame]
Brad Bishopea02e472017-05-12 13:02:56 -04001SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3 supporting tools for OpenBMC."
Adriana Kobylak172fe102016-10-19 14:58:25 -05004HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
5PR = "r1"
6
7inherit autotools pkgconfig
8inherit pythonnative
9inherit obmc-phosphor-license
10inherit obmc-phosphor-dbus-service
Adriana Kobylakf40e1d82017-02-09 13:43:22 -060011inherit phosphor-dbus-interfaces
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050012inherit phosphor-logging
Adriana Kobylak172fe102016-10-19 14:58:25 -050013
14DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
15
16DEPENDS += "autoconf-archive-native"
17DEPENDS += "systemd"
18DEPENDS += "python-mako-native"
19DEPENDS += "python-pyyaml-native"
Patrick Williams57b17812016-12-09 08:56:38 -060020DEPENDS += "sdbusplus sdbusplus-native"
Deepak Kodihallic8d92052017-03-23 03:52:28 -050021DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050022DEPENDS += "virtual/phosphor-logging-callouts"
Adriana Kobylak78784092017-02-09 15:06:41 -060023RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
Adriana Kobylak172fe102016-10-19 14:58:25 -050024PROVIDES += "virtual/obmc-logging-mgmt"
25RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"
26
Michael Tritzccc0d0f2017-03-13 14:54:24 -050027PACKAGE_BEFORE_PN = "${PN}-test"
28FILES_${PN}-test = "${bindir}/*-test"
29
Adriana Kobylak172fe102016-10-19 14:58:25 -050030SRC_URI += "git://github.com/openbmc/phosphor-logging"
Patrick Williams80eb87a2017-05-29 20:40:05 -050031SRCREV = "1eb58922d3ca4fa61916accfd20fe0c28ac06430"
Adriana Kobylak172fe102016-10-19 14:58:25 -050032
33S = "${WORKDIR}/git"
34
Deepak Kodihalli2551ece2017-03-28 07:47:51 -050035PACKAGECONFIG ??= "metadata-processing"
36PACKAGECONFIG[metadata-processing] = " \
37 --enable-metadata-processing, \
38 --disable-metadata-processing, , \
39 "
40
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050041EXTRA_OECONF = " \
42 YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
43 CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
44 "