Brad Bishop | ea02e47 | 2017-05-12 13:02:56 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC event and error logging" |
| 2 | DESCRIPTION = "An error and event log daemon application, and \ |
| 3 | supporting tools for OpenBMC." |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 4 | HOMEPAGE = "https://github.com/openbmc/phosphor-logging" |
| 5 | PR = "r1" |
| 6 | |
| 7 | inherit autotools pkgconfig |
| 8 | inherit pythonnative |
| 9 | inherit obmc-phosphor-license |
| 10 | inherit obmc-phosphor-dbus-service |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 11 | inherit phosphor-logging |
Marri Devender Rao | 56eae0a | 2017-06-06 08:39:39 -0500 | [diff] [blame] | 12 | inherit phosphor-dbus-yaml |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 13 | |
| 14 | DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service" |
| 15 | |
| 16 | DEPENDS += "autoconf-archive-native" |
| 17 | DEPENDS += "systemd" |
| 18 | DEPENDS += "python-mako-native" |
| 19 | DEPENDS += "python-pyyaml-native" |
Patrick Williams | 57b1781 | 2016-12-09 08:56:38 -0600 | [diff] [blame] | 20 | DEPENDS += "sdbusplus sdbusplus-native" |
Deepak Kodihalli | c8d9205 | 2017-03-23 03:52:28 -0500 | [diff] [blame] | 21 | DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native" |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 22 | DEPENDS += "virtual/phosphor-logging-callouts" |
Marri Devender Rao | f2ea35d | 2017-05-14 09:01:35 -0500 | [diff] [blame] | 23 | DEPENDS += "phosphor-logging-error-logs-native" |
Deepak Kodihalli | 4516050 | 2017-06-13 12:52:19 -0500 | [diff] [blame] | 24 | DEPENDS += "cereal" |
Adriana Kobylak | 7878409 | 2017-02-09 15:06:41 -0600 | [diff] [blame] | 25 | RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 26 | PROVIDES += "virtual/obmc-logging-mgmt" |
| 27 | RPROVIDES_${PN} += "virtual-obmc-logging-mgmt" |
| 28 | |
Michael Tritz | ccc0d0f | 2017-03-13 14:54:24 -0500 | [diff] [blame] | 29 | PACKAGE_BEFORE_PN = "${PN}-test" |
| 30 | FILES_${PN}-test = "${bindir}/*-test" |
| 31 | |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 32 | SRC_URI += "git://github.com/openbmc/phosphor-logging" |
Patrick Williams | c808b1f | 2017-07-25 14:10:06 -0500 | [diff] [blame] | 33 | SRCREV = "7a33ee4087e5d3c60da7ebbd33a0bf95f3ad6824" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 34 | |
| 35 | S = "${WORKDIR}/git" |
| 36 | |
Deepak Kodihalli | 2551ece | 2017-03-28 07:47:51 -0500 | [diff] [blame] | 37 | PACKAGECONFIG ??= "metadata-processing" |
| 38 | PACKAGECONFIG[metadata-processing] = " \ |
| 39 | --enable-metadata-processing, \ |
| 40 | --disable-metadata-processing, , \ |
| 41 | " |
| 42 | |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 43 | EXTRA_OECONF = " \ |
| 44 | YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \ |
| 45 | CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \ |
| 46 | " |