blob: 09f570910f7bb1e3e82f7db9422ecdc5f533052a [file] [log] [blame]
Brad Bishopea02e472017-05-12 13:02:56 -04001SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3 supporting tools for OpenBMC."
Adriana Kobylak172fe102016-10-19 14:58:25 -05004HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
5PR = "r1"
6
7inherit autotools pkgconfig
8inherit pythonnative
9inherit obmc-phosphor-license
10inherit obmc-phosphor-dbus-service
Adriana Kobylakf40e1d82017-02-09 13:43:22 -060011inherit phosphor-dbus-interfaces
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050012inherit phosphor-logging
Marri Devender Rao56eae0a2017-06-06 08:39:39 -050013inherit phosphor-dbus-yaml
Adriana Kobylak172fe102016-10-19 14:58:25 -050014
15DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
16
17DEPENDS += "autoconf-archive-native"
18DEPENDS += "systemd"
19DEPENDS += "python-mako-native"
20DEPENDS += "python-pyyaml-native"
Patrick Williams57b17812016-12-09 08:56:38 -060021DEPENDS += "sdbusplus sdbusplus-native"
Deepak Kodihallic8d92052017-03-23 03:52:28 -050022DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050023DEPENDS += "virtual/phosphor-logging-callouts"
Marri Devender Raof2ea35d2017-05-14 09:01:35 -050024DEPENDS += "phosphor-logging-error-logs-native"
Adriana Kobylak78784092017-02-09 15:06:41 -060025RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
Adriana Kobylak172fe102016-10-19 14:58:25 -050026PROVIDES += "virtual/obmc-logging-mgmt"
27RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"
28
Michael Tritzccc0d0f2017-03-13 14:54:24 -050029PACKAGE_BEFORE_PN = "${PN}-test"
30FILES_${PN}-test = "${bindir}/*-test"
31
Adriana Kobylak172fe102016-10-19 14:58:25 -050032SRC_URI += "git://github.com/openbmc/phosphor-logging"
Patrick Williams870a2f42017-06-03 21:00:05 -050033SRCREV = "4952aa6b52cad69e67db53a7398f15920e7929b3"
Adriana Kobylak172fe102016-10-19 14:58:25 -050034
35S = "${WORKDIR}/git"
36
Deepak Kodihalli2551ece2017-03-28 07:47:51 -050037PACKAGECONFIG ??= "metadata-processing"
38PACKAGECONFIG[metadata-processing] = " \
39 --enable-metadata-processing, \
40 --disable-metadata-processing, , \
41 "
42
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050043EXTRA_OECONF = " \
44 YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
45 CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
46 "