blob: 574d03b773bcbdf8a15fe419353f55fc3eb99631 [file] [log] [blame]
vishwabmc1bf499d2015-10-09 15:51:50 +05301SUMMARY = "Phosphor OpenBMC IPMI daemon"
2DESCRIPTION = "Phosphor OpenBMC IPMI router and plugin libraries"
vishwabmc1bf499d2015-10-09 15:51:50 +05303PR = "r1"
Patrick Venturef30b8842018-10-21 08:27:22 -07004PV = "1.0+git${SRCPV}"
Patrick Venture64329372018-11-03 09:42:59 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
vishwabmc1bf499d2015-10-09 15:51:50 +05307
Brad Bishop7ee71462016-08-19 09:02:54 -05008RRECOMMENDS_${PN} += "packagegroup-obmc-ipmid-providers-libs"
Chris Austen213cd2a2015-10-24 19:34:11 -05009
Matthew Barth302592f2016-08-16 16:51:35 -050010inherit autotools pkgconfig
Patrick Ventured3dd0942017-12-22 14:36:07 -080011inherit obmc-phosphor-ipmiprovider-symlink
Patrick Williamsf7714062015-10-15 15:20:20 -050012inherit obmc-phosphor-sdbus-service
Patrick Ventured3dd0942017-12-22 14:36:07 -080013inherit obmc-phosphor-systemd
Ratan Guptab92d0ec2017-03-06 17:05:11 +053014inherit phosphor-ipmi-host
15inherit pythonnative
vishwabmc1bf499d2015-10-09 15:51:50 +053016
Brad Bishop7f2ade02018-01-26 22:11:36 -050017def ipmi_whitelists(d):
18 whitelists = d.getVar(
19 'VIRTUAL-RUNTIME_phosphor-ipmi-providers', True) or ''
20 whitelists = whitelists.split()
21 whitelists = [ '{}-whitelist-native'.format(x) for x in whitelists ]
22 return ' '.join(whitelists)
23
Patrick Ventured3dd0942017-12-22 14:36:07 -080024DEPENDS += "autoconf-archive-native"
David Cobbley1dc78fb2017-11-21 16:17:40 -080025DEPENDS += "nlohmann-json"
Patrick Ventured3dd0942017-12-22 14:36:07 -080026DEPENDS += "obmc-targets"
Brad Bishop7f2ade02018-01-26 22:11:36 -050027DEPENDS += "${@ipmi_whitelists(d)}"
Patrick Ventured3dd0942017-12-22 14:36:07 -080028DEPENDS += "phosphor-dbus-interfaces"
Adriana Kobylak17885c22017-02-17 08:21:42 -060029DEPENDS += "phosphor-logging"
Brad Bishop1122eb02016-10-05 20:10:23 -040030DEPENDS += "phosphor-mapper"
Ratan Gupta8dc22a92017-03-20 18:20:47 +053031DEPENDS += "sdbusplus"
Patrick Ventured3dd0942017-12-22 14:36:07 -080032DEPENDS += "sdbus++-native"
Tom Josephc32034f2019-02-04 03:54:06 -060033DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
Marri Devender Rao5a0088c2017-07-26 02:11:32 -050034DEPENDS += "virtual/phosphor-ipmi-fru-merge-config"
Patrick Ventured3dd0942017-12-22 14:36:07 -080035DEPENDS += "virtual/phosphor-ipmi-sensor-inventory"
Patrick Ventureafdf9842018-01-18 18:01:29 -080036DEPENDS += "virtual/phosphor-ipmi-channel-config"
Jaghathiswari Rankappagounder Natarajan47f26212019-02-07 12:19:57 -080037DEPENDS += "virtual/phosphor-ipmi-entity-config"
Andrew Geisslera561ec92018-09-25 19:50:20 +000038DEPENDS += "boost"
Patrick Venture12a94a82018-11-07 17:48:53 -080039DEPENDS += "sdeventplus"
Ratan Guptab92d0ec2017-03-06 17:05:11 +053040
Andrew Jeffery381e1e92018-04-06 14:13:14 +093041VIRTUAL-RUNTIME_ipmi-config ?= "phosphor-ipmi-config"
42
Adriana Kobylak17885c22017-02-17 08:21:42 -060043RDEPENDS_${PN}-dev += "phosphor-logging"
Brad Bishop1122eb02016-10-05 20:10:23 -040044RDEPENDS_${PN}-dev += "phosphor-mapper-dev"
Milton D. Miller II611e3ff2016-03-04 15:29:29 -060045RDEPENDS_${PN} += "clear-once"
Brad Bishop9a701b42016-07-26 15:52:01 -040046RDEPENDS_${PN} += "libmapper"
Patrick Ventured3dd0942017-12-22 14:36:07 -080047RDEPENDS_${PN} += "network"
48RDEPENDS_${PN} += "phosphor-dbus-interfaces"
49RDEPENDS_${PN} += "phosphor-mapper"
Vishwanatha Subbanna78bc5422016-11-10 21:52:46 +053050RDEPENDS_${PN} += "phosphor-time-manager"
Patrick Ventured3dd0942017-12-22 14:36:07 -080051RDEPENDS_${PN} += "sdbusplus"
Andrew Jeffery381e1e92018-04-06 14:13:14 +093052RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_ipmi-config}"
Vishwanatha Subbanna55c545a2017-06-12 13:09:10 +053053RDEPENDS_${PN} += "virtual/obmc-watchdog"
Ratan Gupta8dc22a92017-03-20 18:20:47 +053054
Richard Marian Thomaiyarfe5b8d22018-08-20 20:14:16 +053055inherit useradd
56
57USERADD_PACKAGES = "${PN}"
58# add ipmi group
59GROUPADD_PARAM_${PN} = "ipmi"
Richard Marian Thomaiyar41882fb2018-12-14 09:04:40 +053060# Add root user to ipmi group
61GROUPMEMS_PARAM_${PN} = "-g ipmi -a root"
Richard Marian Thomaiyarfe5b8d22018-08-20 20:14:16 +053062
Vishwanatha Subbanna35318402017-03-31 14:41:11 +053063SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service phosphor-ipmi-host.service"
64
Andrew Geissler78e04542018-02-05 12:02:35 -080065RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_obmc-settings-mgmt}"
66
vishwabmc1bf499d2015-10-09 15:51:50 +053067
Marri Devender Rao52a9f2d2017-06-08 00:47:54 -050068require ${PN}.inc
Chris Austen213cd2a2015-10-24 19:34:11 -050069
Tom Josephf07ae012017-02-20 12:01:43 +053070# Setup IPMI Whitelist Conf files
71WHITELIST_CONF = " \
Patrick Williamsf11f0152017-02-24 13:04:06 -060072 ${STAGING_DATADIR_NATIVE}/phosphor-ipmi-host/*.conf \
Tom Josephf07ae012017-02-20 12:01:43 +053073 ${S}/host-ipmid-whitelist.conf \
74 "
75EXTRA_OECONF = " \
76 WHITELIST_CONF="${WHITELIST_CONF}" \
Ratan Guptab92d0ec2017-03-06 17:05:11 +053077 SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor.yaml \
Tom Josephc32034f2019-02-04 03:54:06 -060078 INVSENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/invsensor.yaml \
Marri Devender Rao5a0088c2017-07-26 02:11:32 -050079 FRU_YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/fru_config.yaml \
Patrick Ventureafdf9842018-01-18 18:01:29 -080080 CHANNEL_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/channel.yaml \
Jaghathiswari Rankappagounder Natarajan47f26212019-02-07 12:19:57 -080081 ENTITY_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/entity.yaml \
Marri Devender Rao9f32d172018-01-18 11:21:19 -060082 POWER_READING_SENSOR=${datadir}/ipmi-providers/power_reading.json\
Tom Josephf07ae012017-02-20 12:01:43 +053083 "
84
vishwabmc1bf499d2015-10-09 15:51:50 +053085S = "${WORKDIR}/git"
86
Andrew Jeffery381e1e92018-04-06 14:13:14 +093087SRC_URI += "file://merge_yamls.py "
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -050088
Vernon Mauery595c7382018-07-30 15:49:09 -070089HOSTIPMI_PROVIDER_LIBRARY += "libipmi20.so"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053090HOSTIPMI_PROVIDER_LIBRARY += "libsysintfcmds.so"
William A. Kennington IIIc426a982018-12-19 14:53:22 -080091HOSTIPMI_PROVIDER_LIBRARY += "libusercmds.so"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053092
Vernon Mauery595c7382018-07-30 15:49:09 -070093NETIPMI_PROVIDER_LIBRARY += "libipmi20.so"
William A. Kennington IIIc426a982018-12-19 14:53:22 -080094NETIPMI_PROVIDER_LIBRARY += "libusercmds.so"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053095
Matthew Barth302592f2016-08-16 16:51:35 -050096FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Patrick Ventured3dd0942017-12-22 14:36:07 -080097FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053098FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
99FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Brad Bishop3b524cf2016-09-06 13:03:39 -0400100
Andrew Geisslerafc510f2017-01-04 11:11:50 -0600101# Soft Power Off
Andrew Geisslerd40db752017-05-11 16:16:27 -0500102# install the soft power off service in the host shutdown target
103SOFT_SVC = "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service"
104SOFT_TGTFMT = "obmc-host-shutdown@{0}.target"
105SOFT_FMT = "../${SOFT_SVC}:${SOFT_TGTFMT}.requires/${SOFT_SVC}"
106SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'SOFT_FMT', 'OBMC_HOST_INSTANCES')}"
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500107
108#Collect all hardcoded sensor yamls from different recipes and
109#merge all of them with sensor.yaml.
110python do_merge_sensors () {
111 import subprocess
112
113 # TODO: Perform the merge in a temporary directory?
114 workdir = d.getVar('WORKDIR', True)
115 nativedir = d.getVar('STAGING_DIR_NATIVE', True)
116 sensorsdir = d.getVar('sensor_datadir', True)
117 sensorsdir = sensorsdir[1:]
118 sensorsdir = os.path.join(nativedir, sensorsdir)
119 cmd = []
120 cmd.append(os.path.join(workdir, 'merge_yamls.py'))
121 cmd.append(os.path.join(sensorsdir, 'sensor.yaml'))
122
123 if os.stat(os.path.join(sensorsdir, 'sensor.yaml')).st_size == 0:
124 return
125 fetch = bb.fetch2.Fetch([], d)
Kun Yie6bd58c2017-10-09 23:17:08 -0700126 override_urls = [url for url in fetch.urls if url.endswith('.hardcoded.yaml')]
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500127 for url in override_urls:
128 bb.debug(2, 'Overriding with source: ' + url)
129 local_base = os.path.basename(fetch.localpath(url))
130 filename = os.path.join(workdir, local_base)
131 cmd.append(filename)
132
133 # Invoke the script and don't catch any resulting exception.
134 subprocess.check_call(cmd)
135}
Andrew Jeffery381e1e92018-04-06 14:13:14 +0930136
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500137# python-pyyaml-native is installed by do_configure, so put this task after
138addtask merge_sensors after do_configure before do_compile