Brad Bishop | ff7bf4b | 2017-01-17 09:14:15 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor IPMI Inventory Plugin" |
| 2 | DESCRIPTION = "A Phosphor IPMI plugin that updates inventory." |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 3 | PR = "r1" |
Patrick Venture | 6f1857e | 2018-10-01 20:56:22 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 5 | |
Matthew Barth | 2c455f0 | 2016-10-19 16:00:49 -0500 | [diff] [blame] | 6 | inherit autotools pkgconfig |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 7 | inherit obmc-phosphor-systemd |
Tom Joseph | 40b4e3f | 2017-02-01 19:47:27 +0530 | [diff] [blame] | 8 | inherit obmc-phosphor-ipmiprovider-symlink |
Brad Bishop | 2c5db6a | 2017-01-28 13:00:52 -0500 | [diff] [blame] | 9 | inherit phosphor-ipmi-fru |
| 10 | inherit pythonnative |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 11 | |
Brad Bishop | ee06461 | 2017-01-17 10:10:02 -0500 | [diff] [blame] | 12 | require ${PN}.inc |
| 13 | |
Brad Bishop | dd2e4fa | 2016-06-13 12:53:41 -0400 | [diff] [blame] | 14 | DEPENDS += " \ |
Brad Bishop | 2c5db6a | 2017-01-28 13:00:52 -0500 | [diff] [blame] | 15 | virtual/phosphor-ipmi-fru-hostfw-config\ |
| 16 | virtual/phosphor-ipmi-fru-inventory \ |
Deepak Kodihalli | 5b183e0 | 2017-02-20 04:55:20 -0600 | [diff] [blame] | 17 | virtual/phosphor-ipmi-fru-properties \ |
Brad Bishop | dd2e4fa | 2016-06-13 12:53:41 -0400 | [diff] [blame] | 18 | systemd \ |
Deepak Kodihalli | 5df911b | 2017-02-16 07:50:37 -0600 | [diff] [blame] | 19 | sdbusplus \ |
Brad Bishop | 2c5db6a | 2017-01-28 13:00:52 -0500 | [diff] [blame] | 20 | python-mako-native \ |
| 21 | python-pyyaml-native \ |
Brad Bishop | c30d7bb | 2017-01-17 10:07:14 -0500 | [diff] [blame] | 22 | phosphor-ipmi-host \ |
Matthew Barth | 2c455f0 | 2016-10-19 16:00:49 -0500 | [diff] [blame] | 23 | phosphor-mapper \ |
| 24 | autoconf-archive-native \ |
Patrick Venture | c1887af | 2018-10-16 19:50:55 -0700 | [diff] [blame] | 25 | phosphor-logging \ |
Brad Bishop | dd2e4fa | 2016-06-13 12:53:41 -0400 | [diff] [blame] | 26 | " |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 27 | |
Deepak Kodihalli | 5df911b | 2017-02-16 07:50:37 -0600 | [diff] [blame] | 28 | RDEPENDS_${PN} += " \ |
| 29 | sdbusplus \ |
| 30 | " |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 31 | |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 32 | SYSTEMD_SERVICE_${PN} += "obmc-read-eeprom@.service" |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 33 | |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 34 | S = "${WORKDIR}/git" |
| 35 | |
Tom Joseph | 40b4e3f | 2017-02-01 19:47:27 +0530 | [diff] [blame] | 36 | HOSTIPMI_PROVIDER_LIBRARY += "libstrgfnhandler.so" |
| 37 | |
| 38 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
Matthew Barth | 2c455f0 | 2016-10-19 16:00:49 -0500 | [diff] [blame] | 39 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
Tom Joseph | 40b4e3f | 2017-02-01 19:47:27 +0530 | [diff] [blame] | 40 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
Brad Bishop | 2c5db6a | 2017-01-28 13:00:52 -0500 | [diff] [blame] | 41 | |
| 42 | # TODO: Fix the the ipmi-fru-parser code generator to handle split |
| 43 | # host firmware / inventory YAML and replace the OECONF below with: |
| 44 | # |
| 45 | # EXTRA_OECONF += "INVENTORY_YAML=${inventory_datadir}/config.yaml" |
| 46 | # EXTRA_OECONF += "HOSTFW_YAML=${hostfw_datadir}/config.yaml" |
| 47 | # |
| 48 | # For now the generator requires them to already be combined so we have: |
Deepak Kodihalli | 5b183e0 | 2017-02-20 04:55:20 -0600 | [diff] [blame] | 49 | EXTRA_OECONF = " \ |
| 50 | YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/config.yaml \ |
Ratan Gupta | dccf5ad | 2017-03-30 14:32:02 +0530 | [diff] [blame] | 51 | PROP_YAML=${STAGING_DIR_NATIVE}${properties_datadir}/extra-properties.yaml \ |
Deepak Kodihalli | 5b183e0 | 2017-02-20 04:55:20 -0600 | [diff] [blame] | 52 | " |