blob: 62b680a457d5e9c4d18db6feb28b1fb36a43503c [file] [log] [blame]
Matthew Barth91460422017-02-24 13:14:43 -06001SUMMARY = "Phosphor Fan Presence"
2DESCRIPTION = "Phosphor fan presence provides a set of fan presence \
3daemons to monitor fan presence changes by different methods of \
4presence detection."
Matthew Barth91460422017-02-24 13:14:43 -06005PR = "r1"
Matt Spinlerc943de32017-03-21 15:02:13 -05006
7require ${PN}.inc
Matthew Barth91460422017-02-24 13:14:43 -06008
9inherit autotools pkgconfig pythonnative
10inherit obmc-phosphor-systemd
Matt Spinlerc943de32017-03-21 15:02:13 -050011inherit phosphor-fan-presence
Matthew Barth91460422017-02-24 13:14:43 -060012
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "python-pyyaml-native"
Matt Spinlerc943de32017-03-21 15:02:13 -050015DEPENDS += "python-mako-native"
Matthew Barth91460422017-02-24 13:14:43 -060016DEPENDS += "sdbusplus"
17DEPENDS += "phosphor-logging"
Matt Spinlerc943de32017-03-21 15:02:13 -050018DEPENDS += "virtual/phosphor-fan-presence-config"
Brad Bishop96960aa2017-04-03 10:44:23 -040019DEPENDS += "libevdev"
Matthew Barth91460422017-02-24 13:14:43 -060020
21FAN_PRESENCE_PACKAGES = " \
22 ${PN}-tach \
23"
24PACKAGES_remove = "${PN}"
25PACKAGES += "${FAN_PRESENCE_PACKAGES}"
26SYSTEMD_PACKAGES = "${FAN_PRESENCE_PACKAGES}"
27RDEPENDS_${PN}-dev = "${FAN_PRESENCE_PACKAGES}"
28
Brad Bishop74fe8ff2017-04-11 21:51:26 -040029RDEPENDS_${PN}-tach += "sdbusplus"
30
Matthew Barth91460422017-02-24 13:14:43 -060031# Needed to install into the obmc-chassis-start target
32TMPL = "phosphor-fan-presence-tach@.service"
33INSTFMT = "phosphor-fan-presence-tach@{0}.service"
34TGTFMT = "obmc-chassis-start@{0}.target"
35FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
36
37FILES_${PN}-tach = "${sbindir}/phosphor-fan-presence-tach"
38SYSTEMD_SERVICE_${PN}-tach += "${TMPL}"
39SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
40
Matthew Barth91460422017-02-24 13:14:43 -060041S = "${WORKDIR}/git"
Matt Spinlerc943de32017-03-21 15:02:13 -050042
43EXTRA_OECONF = \
44 "FAN_DETECT_YAML_FILE=${STAGING_DIR_NATIVE}${presence_datadir}/config.yaml"