Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor Fan Presence" |
| 2 | DESCRIPTION = "Phosphor fan presence provides a set of fan presence \ |
| 3 | daemons to monitor fan presence changes by different methods of \ |
| 4 | presence detection." |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 5 | PR = "r1" |
Matt Spinler | c943de3 | 2017-03-21 15:02:13 -0500 | [diff] [blame] | 6 | |
| 7 | require ${PN}.inc |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 8 | |
| 9 | inherit autotools pkgconfig pythonnative |
| 10 | inherit obmc-phosphor-systemd |
Matt Spinler | c943de3 | 2017-03-21 15:02:13 -0500 | [diff] [blame] | 11 | inherit phosphor-fan-presence |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 12 | |
| 13 | DEPENDS += "autoconf-archive-native" |
| 14 | DEPENDS += "python-pyyaml-native" |
Matt Spinler | c943de3 | 2017-03-21 15:02:13 -0500 | [diff] [blame] | 15 | DEPENDS += "python-mako-native" |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 16 | DEPENDS += "sdbusplus" |
| 17 | DEPENDS += "phosphor-logging" |
Matt Spinler | c943de3 | 2017-03-21 15:02:13 -0500 | [diff] [blame] | 18 | DEPENDS += "virtual/phosphor-fan-presence-config" |
Brad Bishop | 96960aa | 2017-04-03 10:44:23 -0400 | [diff] [blame] | 19 | DEPENDS += "libevdev" |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 20 | |
| 21 | FAN_PRESENCE_PACKAGES = " \ |
| 22 | ${PN}-tach \ |
| 23 | " |
| 24 | PACKAGES_remove = "${PN}" |
| 25 | PACKAGES += "${FAN_PRESENCE_PACKAGES}" |
| 26 | SYSTEMD_PACKAGES = "${FAN_PRESENCE_PACKAGES}" |
| 27 | RDEPENDS_${PN}-dev = "${FAN_PRESENCE_PACKAGES}" |
| 28 | |
Brad Bishop | 74fe8ff | 2017-04-11 21:51:26 -0400 | [diff] [blame^] | 29 | RDEPENDS_${PN}-tach += "sdbusplus" |
| 30 | |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 31 | # Needed to install into the obmc-chassis-start target |
| 32 | TMPL = "phosphor-fan-presence-tach@.service" |
| 33 | INSTFMT = "phosphor-fan-presence-tach@{0}.service" |
| 34 | TGTFMT = "obmc-chassis-start@{0}.target" |
| 35 | FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}" |
| 36 | |
| 37 | FILES_${PN}-tach = "${sbindir}/phosphor-fan-presence-tach" |
| 38 | SYSTEMD_SERVICE_${PN}-tach += "${TMPL}" |
| 39 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}" |
| 40 | |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 41 | S = "${WORKDIR}/git" |
Matt Spinler | c943de3 | 2017-03-21 15:02:13 -0500 | [diff] [blame] | 42 | |
| 43 | EXTRA_OECONF = \ |
| 44 | "FAN_DETECT_YAML_FILE=${STAGING_DIR_NATIVE}${presence_datadir}/config.yaml" |