Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 1 | SUMMARY = "Phosphor PID Fan Control" |
| 2 | DESCRIPTION = "Fan Control" |
Patrick Venture | c311dec | 2018-09-29 09:19:22 -0700 | [diff] [blame] | 3 | HOMEPAGE = "github.com/openbmc/phosphor-pid-control" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 4 | PR = "r1" |
Patrick Venture | c311dec | 2018-09-29 09:19:22 -0700 | [diff] [blame] | 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 8 | |
Patrick Venture | eb6d9cb | 2019-07-03 10:32:22 -0700 | [diff] [blame] | 9 | inherit autotools pkgconfig |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 10 | |
| 11 | inherit phosphor-pid-control |
| 12 | inherit obmc-phosphor-ipmiprovider-symlink |
Vijay Khemka | d1c8ba8 | 2019-06-20 14:37:11 -0700 | [diff] [blame] | 13 | inherit systemd |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 14 | |
Patrick Venture | c311dec | 2018-09-29 09:19:22 -0700 | [diff] [blame] | 15 | S = "${WORKDIR}/git" |
| 16 | SRC_URI = "git://github.com/openbmc/phosphor-pid-control" |
Andrew Geissler | 7bf906f | 2020-04-16 01:01:51 +0000 | [diff] [blame] | 17 | SRCREV = "298a95cbb192ecc678b1a496acc954a3b2adf450" |
Patrick Venture | c311dec | 2018-09-29 09:19:22 -0700 | [diff] [blame] | 18 | |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 19 | # Each platform will need a service file that starts |
| 20 | # at an appropriate time per system. For instance, if |
| 21 | # your system relies on passive dbus for fans or other |
| 22 | # sensors then it may be prudent to wait for all of them. |
| 23 | |
| 24 | DEPENDS += "autoconf-archive-native" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 25 | DEPENDS += "sdbusplus" |
Brad Bishop | 26873c9 | 2019-03-22 23:41:42 -0400 | [diff] [blame] | 26 | DEPENDS += "phosphor-dbus-interfaces" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 27 | DEPENDS += "phosphor-logging" |
| 28 | DEPENDS += "libevdev" |
Patrick Venture | 9b40f49 | 2019-02-12 08:59:31 -0800 | [diff] [blame] | 29 | DEPENDS += "nlohmann-json" |
Patrick Venture | d074256 | 2019-03-11 08:45:12 -0700 | [diff] [blame] | 30 | DEPENDS += "cli11" |
Andrew Geissler | 7c617d0 | 2019-04-15 14:22:02 +0000 | [diff] [blame] | 31 | DEPENDS += "boost" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 32 | |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 33 | # We depend on this to be built first so we can build our providers. |
| 34 | DEPENDS += "phosphor-ipmi-host" |
| 35 | |
Vijay Khemka | d1c8ba8 | 2019-06-20 14:37:11 -0700 | [diff] [blame] | 36 | SERVICE_FILE = "phosphor-pid-control.service" |
| 37 | SYSTEMD_PACKAGES = "${PN}" |
| 38 | SYSTEMD_SERVICE_${PN} = "${SERVICE_FILE}" |
| 39 | |
| 40 | EXTRA_OECONF = " \ |
| 41 | SYSTEMD_TARGET="multi-user.target" \ |
| 42 | " |
| 43 | |
Andrew Geissler | f0bbd18 | 2019-03-29 16:11:53 +0000 | [diff] [blame] | 44 | FILES_${PN} = "${bindir}/swampd ${bindir}/setsensor" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 45 | |
Patrick Venture | 13a1e6b | 2018-07-27 07:27:01 -0700 | [diff] [blame] | 46 | # The following installs the OEM IPMI handler for the fan controls. |
| 47 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 48 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 49 | FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 50 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 51 | |
Patrick Venture | 13a1e6b | 2018-07-27 07:27:01 -0700 | [diff] [blame] | 52 | HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so" |