blob: d72a4c1afbcfeaaa37334f63de7b4ca28721fb31 [file] [log] [blame]
Brad Bishopb0c3b272017-01-11 11:12:32 -05001SUMMARY = "OpenBMC hwmon poller"
2DESCRIPTION = "OpenBMC hwmon poller."
3PR = "r1"
Patrick Venture8f1d06b2018-10-01 20:22:40 -07004PV = "1.0+git${SRCPV}"
Brad Bishopb0c3b272017-01-11 11:12:32 -05005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Patrick Venture8f1d06b2018-10-01 20:22:40 -07008inherit autotools pkgconfig
9inherit obmc-phosphor-systemd
Brad Bishop030da252017-01-11 15:30:07 -050010
Brad Bishop1d34ddd2017-08-01 21:33:30 -040011PACKAGE_BEFORE_PN = "max31785-msl"
12SYSTEMD_PACKAGES = "${PN} max31785-msl"
13
Brad Bishop030da252017-01-11 15:30:07 -050014SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Hwmon@.service"
Brad Bishop1d34ddd2017-08-01 21:33:30 -040015SYSTEMD_SERVICE_max31785-msl = "phosphor-max31785-msl@.service"
Brad Bishopb0c3b272017-01-11 11:12:32 -050016
17DEPENDS += "autoconf-archive-native"
Brad Bishopf4393bf2017-02-20 14:36:31 -050018DEPENDS += " \
19 sdbusplus \
William A. Kennington III4223a352018-10-18 19:23:49 -070020 sdeventplus \
Brad Bishopf4393bf2017-02-20 14:36:31 -050021 phosphor-dbus-interfaces \
22 phosphor-logging \
Patrick Venture03c53912018-09-14 09:54:18 -070023 gpioplus \
Brad Bishopf4393bf2017-02-20 14:36:31 -050024 "
25
Brad Bishopb0c3b272017-01-11 11:12:32 -050026
27RDEPENDS_${PN} += "\
Joel Stanley7b29e202017-09-05 17:44:33 +100028 bash \
Brad Bishopb0c3b272017-01-11 11:12:32 -050029 "
30
Brad Bishopfe7871c2017-02-22 20:50:13 -050031RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_phosphor-hwmon-config}"
32
Brad Bishop1d34ddd2017-08-01 21:33:30 -040033FILES_max31785-msl = "${bindir}/max31785-msl"
34RDEPENDS_max31785-msl = "${VIRTUAL-RUNTIME_base-utils} i2c-tools"
35
Brad Bishopb0c3b272017-01-11 11:12:32 -050036SRC_URI += "git://github.com/openbmc/phosphor-hwmon"
Brad Bishop030da252017-01-11 15:30:07 -050037SRC_URI += "file://70-hwmon.rules"
Brandon Wyman675ce0b2017-06-21 16:32:56 -050038SRC_URI += "file://70-iio.rules"
Joel Stanley7b29e202017-09-05 17:44:33 +100039SRC_URI += "file://start_hwmon.sh"
Brad Bishopb0c3b272017-01-11 11:12:32 -050040
Andrew Geissler92ee9482019-02-13 20:22:12 +000041SRCREV = "09d9c23699f625479c85724c34421c52be7b17e4"
Brad Bishopb0c3b272017-01-11 11:12:32 -050042
43S = "${WORKDIR}/git"
Brad Bishop030da252017-01-11 15:30:07 -050044
45do_install_append() {
46
Brad Bishopf5812fd2017-01-26 09:12:57 -050047 install -d ${D}/${base_libdir}/udev/rules.d/
48 install ${WORKDIR}/70-hwmon.rules ${D}/${base_libdir}/udev/rules.d/
Brandon Wyman675ce0b2017-06-21 16:32:56 -050049 install ${WORKDIR}/70-iio.rules ${D}/${base_libdir}/udev/rules.d/
Joel Stanley7b29e202017-09-05 17:44:33 +100050
51 install -d ${D}${bindir}
52 install -m 0755 ${WORKDIR}/start_hwmon.sh ${D}${bindir}
Brad Bishop030da252017-01-11 15:30:07 -050053}