blob: 4ee1e16a3a762e343181736981f17d6a02b67146 [file] [log] [blame]
Brad Bishopff7bf4b2017-01-17 09:14:15 -05001SUMMARY = "Phosphor IPMI Inventory Plugin"
2DESCRIPTION = "A Phosphor IPMI plugin that updates inventory."
Chris Austenf7cefb12015-11-01 22:27:34 -06003PR = "r1"
Patrick Venture6f1857e2018-10-01 20:56:22 -07004PV = "1.0+git${SRCPV}"
Chris Austenf7cefb12015-11-01 22:27:34 -06005
Matthew Barth2c455f02016-10-19 16:00:49 -05006inherit autotools pkgconfig
Brad Bishop0fe80462016-08-17 20:27:37 -04007inherit obmc-phosphor-systemd
Tom Joseph40b4e3f2017-02-01 19:47:27 +05308inherit obmc-phosphor-ipmiprovider-symlink
Brad Bishop2c5db6a2017-01-28 13:00:52 -05009inherit phosphor-ipmi-fru
Andrew Geissler0c95d6e2020-04-04 07:31:23 +000010inherit python3native
Chris Austenf7cefb12015-11-01 22:27:34 -060011
Patrick Williamsc7d848e2020-04-03 15:48:30 -050012require ${BPN}.inc
Brad Bishopee064612017-01-17 10:10:02 -050013
Brad Bishopdd2e4fa2016-06-13 12:53:41 -040014DEPENDS += " \
Brad Bishop2c5db6a2017-01-28 13:00:52 -050015 virtual/phosphor-ipmi-fru-inventory \
Deepak Kodihalli5b183e02017-02-20 04:55:20 -060016 virtual/phosphor-ipmi-fru-properties \
Brad Bishopdd2e4fa2016-06-13 12:53:41 -040017 systemd \
Deepak Kodihalli5df911b2017-02-16 07:50:37 -060018 sdbusplus \
Andrew Geissler0c95d6e2020-04-04 07:31:23 +000019 ${PYTHON_PN}-mako-native \
20 ${PYTHON_PN}-pyyaml-native \
Brad Bishopc30d7bb2017-01-17 10:07:14 -050021 phosphor-ipmi-host \
Matthew Barth2c455f02016-10-19 16:00:49 -050022 phosphor-mapper \
23 autoconf-archive-native \
Patrick Venturec1887af2018-10-16 19:50:55 -070024 phosphor-logging \
Patrick Venturee60de052019-03-26 11:07:32 -070025 cli11 \
Brad Bishopdd2e4fa2016-06-13 12:53:41 -040026 "
Chris Austenf7cefb12015-11-01 22:27:34 -060027
William A. Kennington III1eada362020-03-30 12:03:28 -070028RDEPENDS_${PN} += "bash"
29
30SRC_URI += "file://of-name-to-eeprom.sh"
31
Brad Bishop0fe80462016-08-17 20:27:37 -040032SYSTEMD_SERVICE_${PN} += "obmc-read-eeprom@.service"
Chris Austenf7cefb12015-11-01 22:27:34 -060033
Chris Austenf7cefb12015-11-01 22:27:34 -060034S = "${WORKDIR}/git"
35
Tom Joseph40b4e3f2017-02-01 19:47:27 +053036HOSTIPMI_PROVIDER_LIBRARY += "libstrgfnhandler.so"
37
William A. Kennington III1eada362020-03-30 12:03:28 -070038FILES_${PN} += "${bindir}/of-name-to-eeprom.sh"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053039FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Matthew Barth2c455f02016-10-19 16:00:49 -050040FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053041FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Brad Bishop2c5db6a2017-01-28 13:00:52 -050042
Deepak Kodihalli5b183e02017-02-20 04:55:20 -060043EXTRA_OECONF = " \
44 YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/config.yaml \
Ratan Guptadccf5ad2017-03-30 14:32:02 +053045 PROP_YAML=${STAGING_DIR_NATIVE}${properties_datadir}/extra-properties.yaml \
Deepak Kodihalli5b183e02017-02-20 04:55:20 -060046 "
William A. Kennington III1eada362020-03-30 12:03:28 -070047
48do_install_append() {
49 install -d ${D}${bindir}
50 install -m 0755 ${WORKDIR}/of-name-to-eeprom.sh ${D}${bindir}
51}