Brad Bishop | 667938f | 2017-01-12 21:44:51 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenBMC - Applications" |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 2 | PR = "r1" |
| 3 | |
| 4 | inherit packagegroup |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 5 | |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 6 | PROVIDES = "${PACKAGES}" |
| 7 | PACKAGES = " \ |
Brad Bishop | 4663170 | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 8 | ${PN}-bmc-state-mgmt \ |
| 9 | ${PN}-chassis-state-mgmt \ |
Brad Bishop | 6165ec3 | 2016-09-06 22:44:21 -0400 | [diff] [blame] | 10 | ${PN}-extras \ |
| 11 | ${PN}-extrasdev \ |
Adriana Kobylak | 0bce532 | 2017-11-09 10:39:02 -0600 | [diff] [blame] | 12 | ${PN}-extrasdevtools \ |
Brad Bishop | 11909e0 | 2017-05-01 11:54:34 -0400 | [diff] [blame] | 13 | ${PN}-fan-control \ |
Brad Bishop | 4663170 | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 14 | ${PN}-host-state-mgmt \ |
Brad Bishop | 45f8b57 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 15 | ${PN}-inventory \ |
| 16 | ${PN}-leds \ |
Brad Bishop | 0948691 | 2018-03-23 13:07:46 -0400 | [diff] [blame] | 17 | ${PN}-logging \ |
Adriana Kobylak | a4c5db0 | 2018-10-16 11:02:54 -0500 | [diff] [blame] | 18 | ${PN}-remote-logging \ |
Brad Bishop | 45f8b57 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 19 | ${PN}-sensors \ |
Gunnar Mills | c868f92 | 2017-02-15 16:01:45 -0600 | [diff] [blame] | 20 | ${PN}-software \ |
Andrew Geissler | a94faf4 | 2017-05-08 15:58:01 -0500 | [diff] [blame] | 21 | ${PN}-host-check-mgmt \ |
Jayanth Othayoth | 9963d17 | 2017-05-08 09:25:05 -0500 | [diff] [blame] | 22 | ${PN}-debug-collector \ |
Deepak Kodihalli | 3e3c88c | 2017-05-17 06:42:51 -0500 | [diff] [blame] | 23 | ${PN}-settings \ |
Ratan Gupta | b6de45c | 2017-07-06 21:09:14 +0530 | [diff] [blame] | 24 | ${PN}-network \ |
Vishwanatha Subbanna | 0f2b7b0 | 2017-10-18 15:47:54 +0530 | [diff] [blame] | 25 | ${PN}-user-mgmt \ |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 26 | " |
| 27 | |
Brad Bishop | 4663170 | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 28 | SUMMARY_${PN}-bmc-state-mgmt = "BMC state management" |
| 29 | RDEPENDS_${PN}-bmc-state-mgmt = " \ |
| 30 | ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \ |
| 31 | " |
| 32 | |
| 33 | SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management" |
| 34 | RDEPENDS_${PN}-chassis-state-mgmt = " \ |
| 35 | ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \ |
| 36 | " |
| 37 | |
Brad Bishop | 6165ec3 | 2016-09-06 22:44:21 -0400 | [diff] [blame] | 38 | SUMMARY_${PN}-extras = "Extra features" |
| 39 | RDEPENDS_${PN}-extras = " \ |
Ed Tanous | 7bfe296 | 2018-09-18 08:46:34 -0700 | [diff] [blame] | 40 | bmcweb \ |
Brad Bishop | f1cc41b | 2017-05-31 14:08:33 -0400 | [diff] [blame] | 41 | phosphor-dbus-monitor \ |
Andrew Geissler | 6543033 | 2018-07-19 11:44:03 -0700 | [diff] [blame] | 42 | phosphor-systemd-policy \ |
Ed Tanous | 72615f5 | 2018-10-15 09:13:46 -0700 | [diff] [blame] | 43 | dbus-broker \ |
Brad Bishop | 70436da | 2015-09-16 14:49:27 -0400 | [diff] [blame] | 44 | " |
| 45 | |
Brad Bishop | 6165ec3 | 2016-09-06 22:44:21 -0400 | [diff] [blame] | 46 | SUMMARY_${PN}-extrasdev = "Development features" |
| 47 | RDEPENDS_${PN}-extrasdev = " \ |
Adriana Kobylak | eaa56c9 | 2016-06-16 14:46:06 -0500 | [diff] [blame] | 48 | rest-dbus \ |
| 49 | " |
Brad Bishop | 45f8b57 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 50 | |
Adriana Kobylak | 0bce532 | 2017-11-09 10:39:02 -0600 | [diff] [blame] | 51 | SUMMARY_${PN}-extrasdevtools = "Development tools" |
| 52 | RDEPENDS_${PN}-extrasdevtools = " \ |
| 53 | " |
| 54 | |
Brad Bishop | 11909e0 | 2017-05-01 11:54:34 -0400 | [diff] [blame] | 55 | # Use the fan control package group for applications |
| 56 | # implementing fan control or system fan policy only. |
| 57 | # Applications that create inventory or sensors should |
| 58 | # be added those respective package groups instead. |
| 59 | SUMMARY_${PN}-fan-control = "Fan control" |
| 60 | RDEPENDS_${PN}-fan-control = " \ |
Matt Spinler | bd9fdd9 | 2017-04-19 08:23:50 -0500 | [diff] [blame] | 61 | ${VIRTUAL-RUNTIME_obmc-fan-control} \ |
Matt Spinler | 39652c8 | 2017-05-01 14:29:20 -0500 | [diff] [blame] | 62 | phosphor-fan-monitor \ |
Brad Bishop | 11909e0 | 2017-05-01 11:54:34 -0400 | [diff] [blame] | 63 | " |
| 64 | |
Brad Bishop | 4663170 | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 65 | SUMMARY_${PN}-host-state-mgmt = "Host state management" |
| 66 | RDEPENDS_${PN}-host-state-mgmt = " \ |
| 67 | ${VIRTUAL-RUNTIME_obmc-host-state-manager} \ |
Michael Tritz | 1f792e0 | 2017-03-31 12:04:32 -0500 | [diff] [blame] | 68 | ${VIRTUAL-RUNTIME_obmc-discover-system-state} \ |
Brad Bishop | 4663170 | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 69 | " |
| 70 | |
Brad Bishop | 45f8b57 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 71 | SUMMARY_${PN}-inventory = "Inventory applications" |
| 72 | RDEPENDS_${PN}-inventory = " \ |
| 73 | ${VIRTUAL-RUNTIME_obmc-inventory-manager} \ |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 74 | ${VIRTUAL-RUNTIME_obmc-fan-presence} \ |
Brad Bishop | 45f8b57 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 75 | " |
| 76 | |
| 77 | SUMMARY_${PN}-leds = "LED applications" |
| 78 | RDEPENDS_${PN}-leds = " \ |
Brad Bishop | c1d30c5 | 2017-02-27 11:59:49 -0500 | [diff] [blame] | 79 | ${VIRTUAL-RUNTIME_obmc-leds-manager} \ |
| 80 | ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \ |
Dhruvaraj Subhashchandran | e1266ad | 2017-04-27 05:29:56 -0500 | [diff] [blame] | 81 | ${VIRTUAL-RUNTIME_obmc-led-monitor} \ |
Brad Bishop | 45f8b57 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 82 | " |
| 83 | |
Brad Bishop | 0948691 | 2018-03-23 13:07:46 -0400 | [diff] [blame] | 84 | SUMMARY_${PN}-logging = "Logging applications" |
| 85 | RDEPENDS_${PN}-logging = " \ |
| 86 | phosphor-logging \ |
Adriana Kobylak | a4c5db0 | 2018-10-16 11:02:54 -0500 | [diff] [blame] | 87 | " |
| 88 | |
| 89 | SUMMARY_${PN}-remote-logging = "Remote logging applications" |
| 90 | RDEPENDS_${PN}-remote-logging = " \ |
Deepak Kodihalli | a549e75 | 2018-08-21 06:40:53 -0500 | [diff] [blame] | 91 | rsyslog \ |
Adriana Kobylak | 78fbcc3 | 2018-10-16 11:02:54 -0500 | [diff] [blame] | 92 | rsyslog-policy \ |
Deepak Kodihalli | f99f3c8 | 2018-08-28 11:39:41 -0500 | [diff] [blame] | 93 | phosphor-rsyslog-config \ |
Brad Bishop | 0948691 | 2018-03-23 13:07:46 -0400 | [diff] [blame] | 94 | " |
| 95 | |
Brad Bishop | 45f8b57 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 96 | SUMMARY_${PN}-sensors = "Sensor applications" |
| 97 | RDEPENDS_${PN}-sensors = " \ |
| 98 | ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \ |
| 99 | " |
Gunnar Mills | c868f92 | 2017-02-15 16:01:45 -0600 | [diff] [blame] | 100 | |
Brad Bishop | 811eeec | 2018-03-09 00:04:00 -0500 | [diff] [blame] | 101 | # These packages are not required with UBI enabled |
| 102 | ${PN}-software-extras = " \ |
| 103 | obmc-flash-bmc \ |
| 104 | obmc-mgr-download \ |
| 105 | " |
| 106 | |
Eddie James | 1a623ef | 2018-02-09 11:59:18 -0600 | [diff] [blame] | 107 | ${PN}-software-extras_df-obmc-ubi-fs = " \ |
| 108 | phosphor-image-signing \ |
Adriana Kobylak | 3aeee11 | 2018-06-04 13:06:52 -0500 | [diff] [blame] | 109 | phosphor-software-manager-updater-ubi \ |
Eddie James | 1a623ef | 2018-02-09 11:59:18 -0600 | [diff] [blame] | 110 | " |
Brad Bishop | 811eeec | 2018-03-09 00:04:00 -0500 | [diff] [blame] | 111 | |
Gunnar Mills | c868f92 | 2017-02-15 16:01:45 -0600 | [diff] [blame] | 112 | SUMMARY_${PN}-software = "Software applications" |
| 113 | RDEPENDS_${PN}-software = " \ |
Deepak Kodihalli | 60d1de5 | 2017-04-13 23:23:42 -0500 | [diff] [blame] | 114 | ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \ |
Gunnar Mills | 30131f7 | 2017-05-15 15:40:58 -0500 | [diff] [blame] | 115 | ${VIRTUAL-RUNTIME_obmc-bmc-updater} \ |
Andrew Geissler | 1f95752 | 2018-02-09 12:50:57 -0800 | [diff] [blame] | 116 | ${VIRTUAL-RUNTIME_obmc-bmc-version} \ |
Brad Bishop | 811eeec | 2018-03-09 00:04:00 -0500 | [diff] [blame] | 117 | ${${PN}-software-extras} \ |
Andrew Geissler | 1f95752 | 2018-02-09 12:50:57 -0800 | [diff] [blame] | 118 | " |
| 119 | |
Jayanth Othayoth | 9963d17 | 2017-05-08 09:25:05 -0500 | [diff] [blame] | 120 | SUMMARY_${PN}-debug-collector = "BMC debug collector" |
| 121 | RDEPENDS_${PN}-debug-collector = " \ |
Jayanth Othayoth | 9d21d6c | 2017-05-31 06:25:55 -0500 | [diff] [blame] | 122 | ${VIRTUAL-RUNTIME_obmc-dump-manager} \ |
| 123 | ${VIRTUAL-RUNTIME_obmc-dump-monitor} \ |
Jayanth Othayoth | d259249 | 2017-07-29 22:28:44 -0500 | [diff] [blame] | 124 | phosphor-debug-collector-dreport \ |
Marri Devender Rao | 3360392 | 2017-10-11 02:22:46 -0500 | [diff] [blame] | 125 | phosphor-debug-collector-scripts \ |
Vishwanatha Subbanna | 14609cb | 2017-05-12 23:31:55 +0530 | [diff] [blame] | 126 | " |
Deepak Kodihalli | 3e3c88c | 2017-05-17 06:42:51 -0500 | [diff] [blame] | 127 | |
| 128 | SUMMARY_${PN}-settings = "Settings applications" |
| 129 | RDEPENDS_${PN}-settings = " \ |
Andrew Geissler | 78e0454 | 2018-02-05 12:02:35 -0800 | [diff] [blame] | 130 | ${VIRTUAL-RUNTIME_obmc-settings-mgmt} \ |
Deepak Kodihalli | 3e3c88c | 2017-05-17 06:42:51 -0500 | [diff] [blame] | 131 | " |
Ratan Gupta | b6de45c | 2017-07-06 21:09:14 +0530 | [diff] [blame] | 132 | |
| 133 | SUMMARY_${PN}-network = "BMC Network Manager" |
| 134 | RDEPENDS_${PN}-network = " \ |
| 135 | ${VIRTUAL-RUNTIME_obmc-network-manager} \ |
| 136 | " |
Vishwanatha Subbanna | 0f2b7b0 | 2017-10-18 15:47:54 +0530 | [diff] [blame] | 137 | |
| 138 | SUMMARY_${PN}-user-mgmt = "User management applications" |
| 139 | RDEPENDS_${PN}-user-mgmt = " \ |
| 140 | ${VIRTUAL-RUNTIME_obmc-user-mgmt} \ |
Ratan Gupta | 4835bb3 | 2018-09-03 08:41:52 +0530 | [diff] [blame] | 141 | ${@bb.utils.contains('DISTRO_FEATURES', 'ldap', 'nss-pam-ldapd', '', d)} \ |
Nagaraju Goruganti | 6d7f640 | 2018-09-03 21:56:42 -0500 | [diff] [blame] | 142 | ${@bb.utils.contains('DISTRO_FEATURES', 'ldap', 'phosphor-ldap', '', d)} \ |
Vishwanatha Subbanna | 0f2b7b0 | 2017-10-18 15:47:54 +0530 | [diff] [blame] | 143 | " |