blob: dd050f0835c551377839eeb26d952880cddaeae9 [file] [log] [blame]
Brad Bishop37653df2017-05-12 13:02:56 -04001SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3 supporting tools for OpenBMC."
Adriana Kobylakb02da7b2016-10-19 14:58:25 -05004HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
5PR = "r1"
6
7inherit autotools pkgconfig
8inherit pythonnative
9inherit obmc-phosphor-license
10inherit obmc-phosphor-dbus-service
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050011inherit phosphor-logging
Marri Devender Raobf369d02017-06-06 08:39:39 -050012inherit phosphor-dbus-yaml
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050013
14DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
15
16DEPENDS += "autoconf-archive-native"
17DEPENDS += "systemd"
18DEPENDS += "python-mako-native"
19DEPENDS += "python-pyyaml-native"
Patrick Williams845123d2016-12-09 08:56:38 -060020DEPENDS += "sdbusplus sdbusplus-native"
Deepak Kodihalli0ac54522017-03-23 03:52:28 -050021DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050022DEPENDS += "virtual/phosphor-logging-callouts"
Marri Devender Rao3b1e30e2017-05-14 09:01:35 -050023DEPENDS += "phosphor-logging-error-logs-native"
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050024DEPENDS += "phosphor-logging-native"
Deepak Kodihallid7963ee2017-06-13 12:52:19 -050025DEPENDS += "cereal"
Adriana Kobylak385287c2017-02-09 15:06:41 -060026RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050027PROVIDES += "virtual/obmc-logging-mgmt"
28RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"
29
Michael Tritz026fbaf2017-03-13 14:54:24 -050030PACKAGE_BEFORE_PN = "${PN}-test"
31FILES_${PN}-test = "${bindir}/*-test"
32
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050033PACKAGE_BEFORE_PN += "${PN}-elog"
34FILES_${PN}-elog += "${elog_dir}"
35
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050036SRC_URI += "git://github.com/openbmc/phosphor-logging"
Andrew Geissler2e98cf42018-01-18 15:00:17 +000037SRCREV = "4e5f521a62251659ebd432e0a336f2735f8a1dd0"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050038
39S = "${WORKDIR}/git"
40
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050041# Do not DEPEND on the specified packages for native build
42# as they will not be available in host machine
Brad Bishop096e4b42018-01-27 00:27:21 -050043DEPENDS_remove_class-native = " \
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050044 virtual/phosphor-logging-callouts \
Brad Bishop096e4b42018-01-27 00:27:21 -050045 sdbus++ \
46 systemd \
47 cereal \
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050048 "
49
50# Do not DEPEND on the specified packages for native SDK build
51# as they will not be available in host machine
52DEPENDS_remove_class-nativesdk = " \
53 virtual/phosphor-logging-callouts \
54 sdbus++-native \
Brad Bishop096e4b42018-01-27 00:27:21 -050055 cereal \
56 systemd \
57 phosphor-dbus-interfaces \
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050058 "
59
60PACKAGECONFIG ??= "metadata-processing install_scripts"
61
Deepak Kodihalli430a5062017-03-28 07:47:51 -050062PACKAGECONFIG[metadata-processing] = " \
63 --enable-metadata-processing, \
64 --disable-metadata-processing, , \
65 "
66
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050067# Provide a means to enable/disable install_scripts feature
68PACKAGECONFIG[install_scripts] = " \
69 --enable-install_scripts, \
70 --disable-install_scripts, ,\
71 "
72
73# Enable install_scripts during native and native SDK build
74PACKAGECONFIG_add_class-native = "install_scripts"
75PACKAGECONFIG_add_class-nativesdk = "install_scripts"
76
77# Disable install_scripts during target build
78PACKAGECONFIG_remove_class-target = "install_scripts"
79
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050080EXTRA_OECONF = " \
81 YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
82 CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
83 "
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050084
85BBCLASSEXTEND += "native nativesdk"