blob: e954341ffeb705e9c06ab6d6712fc82b4ce204ae [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \
2server for multi-processor machines. It is a new implementation of the \
3JACK server core features that aims in removing some limitations of \
4the JACK1 design. The activation system has been changed for a data \
5flow model and lock-free programming techniques for graph access have \
6been used to have a more dynamic and robust system."
7SECTION = "libs/multimedia"
8
9LICENSE = "GPLv2 & LGPLv2.1"
10LIC_FILES_CHKSUM = " \
11 file://common/jack/control.h;beginline=2;endline=21;md5=e6df0bf30cde8b3b825451459488195d \
12 file://common/jack/jack.h;beginline=1;endline=19;md5=6b736ed6b810592b135480a5e853392e \
13"
14
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015DEPENDS = "libsamplerate0 libsndfile1 readline"
Patrick Williamsddad1a12017-02-23 20:36:32 -060016
Brad Bishop0e2770c2020-01-21 07:31:46 -050017SRC_URI = "git://github.com/jackaudio/jack2.git \
18 file://0001-example-clients-Use-c-compiler-for-jack_simdtests.patch \
19 "
Brad Bishop996bc452019-12-02 13:05:15 -050020SRCREV = "b54a09bf7ef760d81fdb8544ad10e45575394624"
21
Patrick Williamsddad1a12017-02-23 20:36:32 -060022S = "${WORKDIR}/git"
23
24inherit waf pkgconfig
25
26PACKAGECONFIG ??= "alsa"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027PACKAGECONFIG[alsa] = "--alsa=yes,--alsa=no,alsa-lib"
Brad Bishop19323692019-04-05 15:28:33 -040028# --dbus only stops building jackd -> add --classic
29PACKAGECONFIG[dbus] = "--dbus --classic,,dbus"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050030PACKAGECONFIG[opus] = "--opus=yes,--opus=no,libopus"
Patrick Williamsddad1a12017-02-23 20:36:32 -060031
32# portaudio is for windows builds only
33EXTRA_OECONF = "--portaudio=no"
34
Brad Bishop996bc452019-12-02 13:05:15 -050035do_install_append() {
36 if ! ${@bb.utils.contains('PACKAGECONFIG', 'dbus', True, False, d)}; then
37 rm -f ${D}${bindir}/jack_control
38 fi
39}
40
Patrick Williamsddad1a12017-02-23 20:36:32 -060041PACKAGES =+ "libjack jack-server jack-utils"
42
Brad Bishop6e60e8b2018-02-01 10:27:11 -050043RDEPENDS_jack-dev_remove = "${PN} (= ${EXTENDPKGV})"
44
Patrick Williamsddad1a12017-02-23 20:36:32 -060045FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
Brad Bishop19323692019-04-05 15:28:33 -040046FILES_jack-server = " \
47 ${datadir}/dbus-1/services \
48 ${bindir}/jackdbus \
49 ${bindir}/jackd \
50"
Patrick Williamsddad1a12017-02-23 20:36:32 -060051FILES_jack-utils = "${bindir}/*"
Brad Bishop19323692019-04-05 15:28:33 -040052
Brad Bishop996bc452019-12-02 13:05:15 -050053FILES_${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/*"