blob: a1a9f523599c91ebfa3e3c949fbaa3f66997ee5f [file] [log] [blame]
Patrick Venture7ebe0262018-03-30 11:23:16 -07001SUMMARY = "Phosphor OpenBMC Post Code Daemon"
2DESCRIPTION = "Phosphor OpenBMC Post Code Daemon"
Patrick Venture6b91f732018-09-28 19:21:26 -07003HOMEPAGE = "http://github.com/openbmc/phosphor-host-postd"
Patrick Venture7ebe0262018-03-30 11:23:16 -07004PR = "r1"
Patrick Venture6b91f732018-09-28 19:21:26 -07005PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture7ebe0262018-03-30 11:23:16 -07008
9inherit autotools pkgconfig
Patrick Venture20b4af62018-10-23 11:57:36 -070010inherit systemd
Patrick Venture7ebe0262018-03-30 11:23:16 -070011
Benjamin Fair14f1b6a2020-04-07 11:48:40 -070012PACKAGECONFIG ?= ""
13PACKAGECONFIG[7seg] = "--enable-7seg,--disable-7seg,,udev"
14
Patrick Venture7ebe0262018-03-30 11:23:16 -070015DEPENDS += "autoconf-archive-native"
16DEPENDS += "sdbusplus"
Kun Yi41d3e4d2018-09-12 11:01:33 -070017DEPENDS += "sdeventplus"
Patrick Venture7ebe0262018-03-30 11:23:16 -070018DEPENDS += "phosphor-dbus-interfaces"
19DEPENDS += "systemd"
20
Patrick Venture6b91f732018-09-28 19:21:26 -070021S = "${WORKDIR}/git"
22SRC_URI = "git://github.com/openbmc/phosphor-host-postd"
Andrew Geisslerd27240d2020-04-08 05:41:04 +000023SRCREV = "ad2a08c7de9198246fec77c457d4c14f7bc4c1fb"
Patrick Venture6b91f732018-09-28 19:21:26 -070024
Benjamin Fair89e86cd2018-06-29 13:00:14 -070025SNOOP_DEVICE ?= "aspeed-lpc-snoop0"
26POST_CODE_BYTES ?= "1"
27
28SERVICE_FILE = "lpcsnoop.service"
Patrick Venture20b4af62018-10-23 11:57:36 -070029SYSTEMD_PACKAGES = "${PN}"
Benjamin Fair89e86cd2018-06-29 13:00:14 -070030SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}"
Patrick Venture20b4af62018-10-23 11:57:36 -070031
32EXTRA_OECONF = " \
33 SNOOP_DEVICE="${SNOOP_DEVICE}" \
34 POST_CODE_BYTES="${POST_CODE_BYTES}" \
Brad Bishopfc81e382019-04-06 13:58:07 -040035 SYSTEMD_TARGET="multi-user.target" \
Patrick Venture20b4af62018-10-23 11:57:36 -070036"
Benjamin Fair14f1b6a2020-04-07 11:48:40 -070037
38POSTCODE_SEVENSEG_DEVICE ?= "seven_seg_disp_val"
39SERVICE_FILE_7SEG = " \
40 postcode-7seg@.service \
41 postcode-7seg@${POSTCODE_SEVENSEG_DEVICE}.service \
42"
43SYSTEMD_SERVICE_${PN} += "${@bb.utils.contains('PACKAGECONFIG', '7seg', '${SERVICE_FILE_7SEG}', '', d)}"