blob: 51c96e2ce902d09a52fa3a651a447d70de0f5d2b [file] [log] [blame]
James Feist9ed709c2018-10-02 16:45:42 -07001SUMMARY = "Entity Manager"
2DESCRIPTION = "Entity Manager provides d-bus configuration data \
3and configures system sensors"
4
George Liu80184e22022-02-08 11:25:30 +08005SRC_URI = "git://github.com/openbmc/entity-manager.git;branch=master;protocol=https \
6 file://blocklist.json \
7 "
Andrew Geissler18c0ef92022-07-05 12:20:20 -05008SRCREV = "c492ab868fcc2f9b2ce9af45f2dc7b8e1210a618"
James Feist9ed709c2018-10-02 16:45:42 -07009PV = "0.1+git${SRCPV}"
10
11LICENSE = "Apache-2.0"
12LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
13
James Feist9ed709c2018-10-02 16:45:42 -070014DEPENDS = "boost \
Brad Bishoped869752020-11-06 09:39:44 -050015 dbus \
James Feist9ed709c2018-10-02 16:45:42 -070016 nlohmann-json \
17 sdbusplus \
Ed Tanous4bdc6352021-12-20 16:09:03 -080018 valijson \
19 ${PYTHON_PN}-jsonschema-native \
20"
James Feist9ed709c2018-10-02 16:45:42 -070021
Brad Bishopd8b59672020-10-27 09:22:51 -040022S = "${WORKDIR}/git"
Ed Tanous4bdc6352021-12-20 16:09:03 -080023inherit pkgconfig meson systemd python3native
Brad Bishop6d17b7b2020-03-18 16:33:02 -040024
Brad Bishopc83dff02020-03-30 14:16:34 -040025EXTRA_OEMESON = "-Dtests=disabled"
26
Brad Bishopc1371fd2020-08-18 19:30:11 -040027PACKAGECONFIG ??= "ipmi-fru"
Brad Bishop6d17b7b2020-03-18 16:33:02 -040028PACKAGECONFIG[ipmi-fru] = "-Dfru-device=true, -Dfru-device=false, i2c-tools,"
Brad Bishopf55c8752020-08-18 19:06:53 -040029
Brad Bishopc1371fd2020-08-18 19:30:11 -040030EXTRA_ENTITY_MANAGER_PACKAGES = " \
31 ${@bb.utils.contains('PACKAGECONFIG', 'ipmi-fru', 'fru-device', '', d)} \
32 "
33
34PACKAGE_BEFORE_PN = "${EXTRA_ENTITY_MANAGER_PACKAGES}"
35
Patrick Williams12fc9392021-08-06 09:16:53 -050036do_install:append() {
Brad Bishopf55c8752020-08-18 19:06:53 -040037 install -D ${WORKDIR}/blocklist.json ${D}${datadir}/${BPN}/blacklist.json
38}
Brad Bishopc1371fd2020-08-18 19:30:11 -040039
Patrick Williams12fc9392021-08-06 09:16:53 -050040FILES:${PN} += " \
Brad Bishoped869752020-11-06 09:39:44 -050041 ${datadir}/dbus-1/system-services/xyz.openbmc_project.EntityManager.service \
42 "
Patrick Williams12fc9392021-08-06 09:16:53 -050043FILES:fru-device = "${bindir}/fru-device ${datadir}/${BPN}/blacklist.json"
Brad Bishopc1371fd2020-08-18 19:30:11 -040044
45SYSTEMD_PACKAGES = "${PN} ${EXTRA_ENTITY_MANAGER_PACKAGES}"
Patrick Williams12fc9392021-08-06 09:16:53 -050046SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.EntityManager.service"
47SYSTEMD_SERVICE:fru-device = "xyz.openbmc_project.FruDevice.service"
48SYSTEMD_AUTO_ENABLE:fru-device_ibm-power-cpu = "disable"