blob: c0a1560cdbf501689115beac9b9be5b9388749e3 [file] [log] [blame]
James Feiste3322992018-10-04 16:15:37 -07001SUMMARY = "JSON for modern C++"
2HOMEPAGE = "https://nlohmann.github.io/json/"
3SECTION = "libs"
4LICENSE = "MIT"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05005LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=dd0607f896f392c8b7d0290a676efc24"
James Feiste3322992018-10-04 16:15:37 -07006
Andrew Geisslerdce5cf92020-05-17 11:54:15 -05007SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1 \
Andrew Geisslerdce5cf92020-05-17 11:54:15 -05008 "
James Feiste3322992018-10-04 16:15:37 -07009
Andrew Geisslerd688a012020-09-18 13:36:00 -050010SRCREV = "db78ac1d7716f56fc9f1b030b715f872f93964e4"
James Feiste3322992018-10-04 16:15:37 -070011
12S = "${WORKDIR}/git"
13
14inherit cmake
15
16EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
17
18# nlohmann-json is a header only C++ library, so the main package will be empty.
19
Patrick Williams213cb262021-08-07 19:21:33 -050020RDEPENDS:${PN}-dev = ""
James Feiste3322992018-10-04 16:15:37 -070021
22BBCLASSEXTEND = "native nativesdk"
James Feistcb07cdf2018-10-11 13:47:04 -070023
24# other packages commonly reference the file directly as "json.hpp"
25# create symlink to allow this usage
Patrick Williams213cb262021-08-07 19:21:33 -050026do_install:append() {
James Feistcb07cdf2018-10-11 13:47:04 -070027 ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp
28}