blob: 2bc7a9230b5b9f2b3cc9630f11a087ab24a2067c [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Userspace NFS server v3 protocol"
Brad Bishopf3f93bb2019-10-16 14:33:32 -04002DESCRIPTION = "UNFS3 is a user-space implementation of the NFSv3 server \
3specification. It provides a daemon for the MOUNT and NFS protocols, which \
4are used by NFS clients for accessing files on the server."
Andrew Geissler90fd73c2021-03-05 15:25:55 -06005HOMEPAGE = "https://github.com/unfs3/unfs3"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05006SECTION = "console/network"
7LICENSE = "unfs3"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=9475885294e17c0cc0067820d042792e"
9
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050010DEPENDS = "flex-native bison-native flex"
Brad Bishop00111322018-04-01 22:23:53 -040011DEPENDS += "libtirpc"
Patrick Williams213cb262021-08-07 19:21:33 -050012DEPENDS:append:class-nativesdk = " flex-nativesdk"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050013
Brad Bishop00111322018-04-01 22:23:53 -040014ASNEEDED = ""
15
Brad Bishop96ff1982019-08-19 13:50:42 -040016S = "${WORKDIR}/git"
17SRC_URI = "git://github.com/unfs3/unfs3.git;protocol=https \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050018 file://unfs3_parallel_build.patch \
19 file://alternate_rpc_ports.patch \
20 file://fix_pid_race_parent_writes_child_pid.patch \
21 file://fix_compile_warning.patch \
22 file://rename_fh_cache.patch \
23 file://relative_max_socket_path_len.patch \
24 file://tcp_no_delay.patch \
Brad Bishop00111322018-04-01 22:23:53 -040025 file://0001-daemon.c-Libtirpc-porting-fixes.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026 file://0001-attr-fix-utime-for-symlink.patch \
Brad Bishop64c979e2019-11-04 13:55:29 -050027 file://0001-Add-listen-action-for-a-tcp-socket.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060028 file://no-yywrap.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029 "
Brad Bishop96ff1982019-08-19 13:50:42 -040030SRCREV = "c12a5c69a8d59be6916cbd0e0f41c159f1962425"
31UPSTREAM_CHECK_GITTAGREGEX = "unfs3\-(?P<pver>.+)"
32
33PV = "0.9.22+${SRCPV}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050034
35BBCLASSEXTEND = "native nativesdk"
36
37inherit autotools
Patrick Williams213cb262021-08-07 19:21:33 -050038EXTRA_OECONF:append:class-native = " --sbindir=${bindir}"
39CFLAGS:append = " -I${STAGING_INCDIR}/tirpc"
40EXTRA_OECONF:append = " LIBS=-ltirpc"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050041
42# Turn off these header detects else the inode search
43# will walk entire file systems and this is a real problem
44# if you have 2 TB of files to walk in your file system
45CACHED_CONFIGUREVARS = "ac_cv_header_mntent_h=no ac_cv_header_sys_mnttab_h=no"