blob: 3ff82517ef1b67d2171f16041a9aa52b06439987 [file] [log] [blame]
Andrew Geissler26e4bea2020-11-30 19:54:03 -06001SUMMARY = "cmdline.txt file used to boot the kernel on a Raspberry Pi device"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5COMPATIBLE_MACHINE = "^rpi$"
6INHIBIT_DEFAULT_DEPS = "1"
7inherit deploy nopackages
8
9CMDLINE_DWC_OTG ?= "dwc_otg.lpm_enable=0"
Andrew Geisslerad7fa352021-07-23 12:55:23 -040010
11CMDLINE_ROOT_FSTYPE ?= "rootfstype=ext4"
12CMDLINE_ROOTFS ?= "root=/dev/mmcblk0p2 ${CMDLINE_ROOT_FSTYPE} rootwait"
Andrew Geissler26e4bea2020-11-30 19:54:03 -060013
14CMDLINE_SERIAL ?= "${@oe.utils.conditional("ENABLE_UART", "1", "console=serial0,115200", "", d)}"
15
Andrew Geissler26e4bea2020-11-30 19:54:03 -060016CMDLINE_PITFT ?= "${@bb.utils.contains("MACHINE_FEATURES", "pitft", "fbcon=map:10 fbcon=font:VGA8x8", "", d)}"
17
18# Add the kernel debugger over console kernel command line option if enabled
19CMDLINE_KGDB ?= '${@oe.utils.conditional("ENABLE_KGDB", "1", "kgdboc=serial0,115200", "", d)}'
20
21# Disable rpi logo on boot
22CMDLINE_LOGO ?= '${@oe.utils.conditional("DISABLE_RPI_BOOT_LOGO", "1", "logo.nologo", "", d)}'
23
24# You can define CMDLINE_DEBUG as "debug" in your local.conf or distro.conf
25# to enable kernel debugging.
26CMDLINE_DEBUG ?= ""
27
Patrick Williamsde0582f2022-04-08 10:23:27 -050028# Add a request to isolate processors from the Linux scheduler. ISOLATED_CPUS
29# may have the form of a comma separated list of processor numbers "0,1,3", a
30# range "0-2", a combination of the two "0-1,3", or a single processor you may
31# not specify ALL processors simultaneously
32def setup_isolcpus(d):
33 string = ""
34 if d.getVar('ISOLATED_CPUS'):
35 string = 'isolcpus=' + d.getVar('ISOLATED_CPUS')
36 return string
37
38CMDLINE_ISOL_CPUS ?= "${@setup_isolcpus(d)}"
39
Andrew Geissler5199d832021-09-24 16:47:35 -050040# Add RNDIS capabilities (must be after rootwait)
41# example:
42# CMDLINE_RNDIS = "modules-load=dwc2,g_ether g_ether.host_addr=<some MAC
43# address> g_ether.dev_addr=<some MAC address>"
44# if the MAC addresses are omitted, random values will be used
45CMDLINE_RNDIS ?= ""
46
Andrew Geissler26e4bea2020-11-30 19:54:03 -060047CMDLINE = " \
Patrick Williamsde0582f2022-04-08 10:23:27 -050048 ${CMDLINE_ISOL_CPUS} \
Andrew Geissler26e4bea2020-11-30 19:54:03 -060049 ${CMDLINE_DWC_OTG} \
50 ${CMDLINE_SERIAL} \
51 ${CMDLINE_ROOTFS} \
52 ${CMDLINE_CMA} \
53 ${CMDLINE_KGDB} \
54 ${CMDLINE_LOGO} \
55 ${CMDLINE_PITFT} \
56 ${CMDLINE_DEBUG} \
Andrew Geissler5199d832021-09-24 16:47:35 -050057 ${CMDLINE_RNDIS} \
Andrew Geissler26e4bea2020-11-30 19:54:03 -060058 "
59
60do_compile() {
Patrick Williams92b42cb2022-09-03 06:53:57 -050061 echo "${@' '.join(d.getVar('CMDLINE').split())}" > "${WORKDIR}/cmdline.txt"
Andrew Geissler26e4bea2020-11-30 19:54:03 -060062}
63
64do_deploy() {
65 install -d "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
66 install -m 0644 "${WORKDIR}/cmdline.txt" "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
67}
68
69addtask deploy before do_build after do_install
70do_deploy[dirs] += "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
Andrew Geisslera4353c82021-06-25 14:23:27 -050071
72PACKAGE_ARCH = "${MACHINE_ARCH}"