blob: 6fb3a1bcc3d8b8c86c02369e4c9335a5dfacaf5f [file] [log] [blame]
Andrew Geissler26e4bea2020-11-30 19:54:03 -06001SUMMARY = "cmdline.txt file used to boot the kernel on a Raspberry Pi device"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5COMPATIBLE_MACHINE = "^rpi$"
6INHIBIT_DEFAULT_DEPS = "1"
7inherit deploy nopackages
8
9CMDLINE_DWC_OTG ?= "dwc_otg.lpm_enable=0"
Andrew Geisslerad7fa352021-07-23 12:55:23 -040010
11CMDLINE_ROOT_FSTYPE ?= "rootfstype=ext4"
12CMDLINE_ROOTFS ?= "root=/dev/mmcblk0p2 ${CMDLINE_ROOT_FSTYPE} rootwait"
Andrew Geissler26e4bea2020-11-30 19:54:03 -060013
14CMDLINE_SERIAL ?= "${@oe.utils.conditional("ENABLE_UART", "1", "console=serial0,115200", "", d)}"
15
16CMDLINE_CMA ?= "${@oe.utils.conditional("RASPBERRYPI_CAMERA_V2", "1", "cma=64M", "", d)}"
17
William A. Kennington IIIa99e9b62021-06-02 12:47:56 -070018CMDLINE_CMA ?= "${@oe.utils.conditional("RASPBERRYPI_HD_CAMERA", "1", "cma=64M", "", d)}"
19
Andrew Geissler26e4bea2020-11-30 19:54:03 -060020CMDLINE_PITFT ?= "${@bb.utils.contains("MACHINE_FEATURES", "pitft", "fbcon=map:10 fbcon=font:VGA8x8", "", d)}"
21
22# Add the kernel debugger over console kernel command line option if enabled
23CMDLINE_KGDB ?= '${@oe.utils.conditional("ENABLE_KGDB", "1", "kgdboc=serial0,115200", "", d)}'
24
25# Disable rpi logo on boot
26CMDLINE_LOGO ?= '${@oe.utils.conditional("DISABLE_RPI_BOOT_LOGO", "1", "logo.nologo", "", d)}'
27
28# You can define CMDLINE_DEBUG as "debug" in your local.conf or distro.conf
29# to enable kernel debugging.
30CMDLINE_DEBUG ?= ""
31
Patrick Williamsde0582f2022-04-08 10:23:27 -050032# Add a request to isolate processors from the Linux scheduler. ISOLATED_CPUS
33# may have the form of a comma separated list of processor numbers "0,1,3", a
34# range "0-2", a combination of the two "0-1,3", or a single processor you may
35# not specify ALL processors simultaneously
36def setup_isolcpus(d):
37 string = ""
38 if d.getVar('ISOLATED_CPUS'):
39 string = 'isolcpus=' + d.getVar('ISOLATED_CPUS')
40 return string
41
42CMDLINE_ISOL_CPUS ?= "${@setup_isolcpus(d)}"
43
Andrew Geissler5199d832021-09-24 16:47:35 -050044# Add RNDIS capabilities (must be after rootwait)
45# example:
46# CMDLINE_RNDIS = "modules-load=dwc2,g_ether g_ether.host_addr=<some MAC
47# address> g_ether.dev_addr=<some MAC address>"
48# if the MAC addresses are omitted, random values will be used
49CMDLINE_RNDIS ?= ""
50
Andrew Geissler26e4bea2020-11-30 19:54:03 -060051CMDLINE = " \
Patrick Williamsde0582f2022-04-08 10:23:27 -050052 ${CMDLINE_ISOL_CPUS} \
Andrew Geissler26e4bea2020-11-30 19:54:03 -060053 ${CMDLINE_DWC_OTG} \
54 ${CMDLINE_SERIAL} \
55 ${CMDLINE_ROOTFS} \
56 ${CMDLINE_CMA} \
57 ${CMDLINE_KGDB} \
58 ${CMDLINE_LOGO} \
59 ${CMDLINE_PITFT} \
60 ${CMDLINE_DEBUG} \
Andrew Geissler5199d832021-09-24 16:47:35 -050061 ${CMDLINE_RNDIS} \
Andrew Geissler26e4bea2020-11-30 19:54:03 -060062 "
63
64do_compile() {
Patrick Williams92b42cb2022-09-03 06:53:57 -050065 echo "${@' '.join(d.getVar('CMDLINE').split())}" > "${WORKDIR}/cmdline.txt"
Andrew Geissler26e4bea2020-11-30 19:54:03 -060066}
67
68do_deploy() {
69 install -d "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
70 install -m 0644 "${WORKDIR}/cmdline.txt" "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
71}
72
73addtask deploy before do_build after do_install
74do_deploy[dirs] += "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
Andrew Geisslera4353c82021-06-25 14:23:27 -050075
76PACKAGE_ARCH = "${MACHINE_ARCH}"