blob: d2015771ac54f39481df8a73d88ca786204ecb4e [file] [log] [blame]
James Feiste3322992018-10-04 16:15:37 -07001SUMMARY = "JSON for modern C++"
2HOMEPAGE = "https://nlohmann.github.io/json/"
3SECTION = "libs"
4LICENSE = "MIT"
William A. Kennington III49e95662021-09-15 16:19:36 -07005LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=441793d25a658d58d79a1f87516a6ad1"
James Feiste3322992018-10-04 16:15:37 -07006
Andrew Geisslerdce5cf92020-05-17 11:54:15 -05007SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1 \
Andrew Geisslerdce5cf92020-05-17 11:54:15 -05008 "
James Feiste3322992018-10-04 16:15:37 -07009
William A. Kennington III49e95662021-09-15 16:19:36 -070010SRCREV = "626e7d61e44dee32887126c8f437dd077dec09cf"
James Feiste3322992018-10-04 16:15:37 -070011
12S = "${WORKDIR}/git"
13
14inherit cmake
15
16EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
17
18# nlohmann-json is a header only C++ library, so the main package will be empty.
19
Patrick Williams213cb262021-08-07 19:21:33 -050020RDEPENDS:${PN}-dev = ""
James Feiste3322992018-10-04 16:15:37 -070021
22BBCLASSEXTEND = "native nativesdk"
James Feistcb07cdf2018-10-11 13:47:04 -070023
24# other packages commonly reference the file directly as "json.hpp"
25# create symlink to allow this usage
Patrick Williams213cb262021-08-07 19:21:33 -050026do_install:append() {
James Feistcb07cdf2018-10-11 13:47:04 -070027 ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp
28}