blob: 82d983b5714118a79724b5b22a38694762e6063f [file] [log] [blame]
Patrick Williams314e8332023-10-06 17:41:44 -05001HOMEPAGE = "https://github.com/openbmc/pldm"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
4SRC_URI = "git://github.com/openbmc/pldm;branch=master;protocol=https"
5SRCREV = "d310f8213a41b29c8e36e67c1a9570b72deaa958"
6
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -05007SUMMARY = "PLDM Stack"
8DESCRIPTION = "Implementation of the PLDM specifications"
Tom Josephf6785aa2021-06-15 07:12:34 -07009DEPENDS += "function2"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050010DEPENDS += "systemd"
Matt Spinlere2375b52020-01-20 14:09:47 -060011DEPENDS += "sdeventplus"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050012DEPENDS += "phosphor-dbus-interfaces"
13DEPENDS += "nlohmann-json"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050014DEPENDS += "cli11"
Manojkiran Edac5934752022-09-27 13:59:35 -050015DEPENDS += "libpldm"
Riya Dixit1b221332023-03-28 01:42:41 -050016DEPENDS += "phosphor-logging"
Ed Tanous9936f862022-09-19 09:13:20 -070017PV = "1.0+git${SRCPV}"
18PR = "r1"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050019
20S = "${WORKDIR}/git"
Patrick Williams12fc9392021-08-06 09:16:53 -050021SYSTEMD_SERVICE:${PN} += "pldmd.service"
22SYSTEMD_SERVICE:${PN} += "pldmSoftPowerOff.service"
Deepak Kodihallia7482012020-06-22 05:25:35 -050023
Ed Tanous9936f862022-09-19 09:13:20 -070024inherit meson pkgconfig
25inherit systemd
26
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050027EXTRA_OEMESON = " \
28 -Dtests=disabled \
29 -Doem-ibm=disabled \
30 "
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050031
Ed Tanous9936f862022-09-19 09:13:20 -070032pkg_prerm:${PN} () {
33 LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
34 rm $LINK
35 LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
36 rm $LINK
37}
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050038# Install pldmSoftPowerOff.service in correct targets
Patrick Williams12fc9392021-08-06 09:16:53 -050039pkg_postinst:${PN} () {
Manojkiran Eda842eb7f2021-09-15 18:47:42 +053040 mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants
41 LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050042 TARGET="../pldmSoftPowerOff.service"
43 ln -s $TARGET $LINK
Manojkiran Eda842eb7f2021-09-15 18:47:42 +053044 mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants
45 LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050046 TARGET="../pldmSoftPowerOff.service"
47 ln -s $TARGET $LINK
48}