blob: ba14c42698115e95dc40290c55680bf2c66b6a7b [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Target Communication Framework for the Eclipse IDE"
2HOMEPAGE = "http://wiki.eclipse.org/TCF"
3BUGTRACKER = "https://bugs.eclipse.org/bugs/"
4
5LICENSE = "EPL-1.0 | EDL-1.0"
6LIC_FILES_CHKSUM = "file://edl-v10.html;md5=522a390a83dc186513f0500543ad3679"
7
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008SRCREV = "2dddd5f440a15d5406032fac20f206484513646f"
9PV = "1.4.0+git${SRCPV}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050010
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050011UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060012SRC_URI = "git://git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent;branch=1.4_neon_bugfix \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013 file://fix_ranlib.patch \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050014 file://ldflags.patch \
15 file://0001-canonicalize_file_name-is-specific-to-glibc.patch;striplevel=2 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016 file://tcf-agent.init \
17 file://tcf-agent.service \
18 "
19
20DEPENDS = "util-linux openssl"
21RDEPENDS_${PN} = "bash"
22
23S = "${WORKDIR}/git/agent"
24
25inherit update-rc.d systemd
26
27SYSTEMD_SERVICE_${PN} = "tcf-agent.service"
28
29INITSCRIPT_NAME = "tcf-agent"
30INITSCRIPT_PARAMS = "start 99 3 5 . stop 20 0 1 2 6 ."
31
32# mangling needed for make
Brad Bishop316dfdd2018-06-25 12:45:53 -040033MAKE_ARCH = "`echo ${TARGET_ARCH} | sed s,i.86,i686, | sed s,aarch64.*,a64,`"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034MAKE_OS = "`echo ${TARGET_OS} | sed s,^linux.*,GNU/Linux,`"
35
36EXTRA_OEMAKE = "MACHINE=${MAKE_ARCH} OPSYS=${MAKE_OS} 'CC=${CC}' 'AR=${AR}'"
37
Brad Bishopd7bf8c12018-02-25 22:55:05 -050038LCL_STOP_SERVICES = "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039 -DSERVICE_Memory=0 -DSERVICE_Registers=0 -DSERVICE_MemoryMap=0 \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050040 -DSERVICE_StackTrace=0 -DSERVICE_Expressions=0"
41
42
43# These features don't compile for several cases.
44#
45CFLAGS_append_mips = " ${LCL_STOP_SERVICES}"
46CFLAGS_append_mips64 = " ${LCL_STOP_SERVICES}"
47CFLAGS_append_libc-musl = " ${LCL_STOP_SERVICES}"
48CFLAGS_append_powerpc64 = " ${LCL_STOP_SERVICES}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050049
50do_install() {
51 oe_runmake install INSTALLROOT=${D}
52 install -d ${D}${sysconfdir}/init.d/
53 install -m 0755 ${WORKDIR}/tcf-agent.init ${D}${sysconfdir}/init.d/tcf-agent
54 install -d ${D}${systemd_unitdir}/system
55 install -m 0644 ${WORKDIR}/tcf-agent.service ${D}${systemd_unitdir}/system
56 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/tcf-agent.service
57}
58