blob: b936ad8a7303948044298230a5ad87b466f9c44c [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "OpenGL driver testing framework"
2LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4
5SRC_URI = "git://anongit.freedesktop.org/piglit \
Patrick Williamsc0f7c042017-02-23 20:41:17 -06006 file://0001-cmake-install-bash-completions-in-the-right-place.patch \
7 file://0001-tests-Use-FE_UPWARD-only-if-its-defined-in-fenv.h.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008 "
Brad Bishop316dfdd2018-06-25 12:45:53 -04009UPSTREAM_CHECK_COMMITS = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050010
Brad Bishop316dfdd2018-06-25 12:45:53 -040011# From 2018-02-26
12SRCREV = "4ce0887e2f7f848d2be2e435a2d0f3c80e44ea3b"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013# (when PV goes above 1.0 remove the trailing r)
14PV = "1.0+gitr${SRCPV}"
15
16S = "${WORKDIR}/git"
17
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018DEPENDS = "libpng virtual/libx11 libxkbcommon libxrender waffle virtual/libgl libglu python3-mako-native python3-numpy-native python3-six-native virtual/egl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050019
Patrick Williamsc0f7c042017-02-23 20:41:17 -060020inherit cmake python3native distro_features_check bash-completion
Patrick Williamsc124f4f2015-09-15 14:41:29 -050021# depends on virtual/libx11
22REQUIRED_DISTRO_FEATURES = "x11"
23
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024# depends on virtual/libgl
25REQUIRED_DISTRO_FEATURES += "opengl"
26
Patrick Williamsf1e5d692016-03-30 15:21:19 -050027# The built scripts go into the temporary directory according to tempfile
28# (typically /tmp) which can race if multiple builds happen on the same machine,
29# so tell it to use a directory in ${B} to avoid overwriting.
30export TEMP = "${B}/temp/"
31do_compile[dirs] =+ "${B}/temp/"
32
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033PACKAGECONFIG ??= ""
34PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
35
36do_configure_prepend() {
37 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
38 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
39 sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
40 fi
41}
42
Brad Bishop316dfdd2018-06-25 12:45:53 -040043OECMAKE_TARGET_INSTALL = "install/strip"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060044
45RDEPENDS_${PN} = "waffle python3 python3-mako python3-json \
Brad Bishop316dfdd2018-06-25 12:45:53 -040046 python3-misc \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060047 python3-unixadmin python3-xml python3-multiprocessing \
Brad Bishop316dfdd2018-06-25 12:45:53 -040048 python3-six python3-shell python3-io \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050049 python3-netserver mesa-demos bash \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050050 "
51
Patrick Williamsc0f7c042017-02-23 20:41:17 -060052INSANE_SKIP_${PN} += "dev-so already-stripped"