blob: 568a6320c1445fddde35eb141e390999e6b4f4f0 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.0-or-later & LGPL-2.1-or-later & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
9 file://testcases/network/can/filter-tests/COPYING;md5=5b155ea7d7f86eae8e8832955d8b70bc \
10"
11
12DEPENDS = "attr libaio libcap acl openssl zip-native"
13DEPENDS:append:libc-musl = " fts "
14EXTRA_OEMAKE:append:libc-musl = " LIBC=musl "
15EXTRA_OECONF:append:libc-musl = " LIBS=-lfts "
16
17# since ltp contains x86-64 assembler which uses the frame-pointer register,
18# set -fomit-frame-pointer x86-64 to handle cases where optimisation
19# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
20# earlier in CFLAGS, etc.
21CFLAGS:append:x86-64 = " -fomit-frame-pointer"
Andrew Geissler615f2f12022-07-15 14:00:58 -050022TUNE_CCARGS:remove:x86 = "-mfpmath=sse"
Patrick Williams92b42cb2022-09-03 06:53:57 -050023TUNE_CCARGS:remove:x86-64 = "-mfpmath=sse"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000024
25CFLAGS:append:powerpc64 = " -D__SANE_USERSPACE_TYPES__"
26CFLAGS:append:mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
Patrick Williams7784c422022-11-17 07:29:11 -060027SRCREV = "b763f81998f19f783982d3937d1fd05bcf649c16"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000028
29SRC_URI = "git://github.com/linux-test-project/ltp.git;branch=master;protocol=https \
30 file://0001-Remove-OOM-tests-from-runtest-mm.patch \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000031 file://disable_hanging_tests.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060032 file://0001-testcases-Fix-largefile-support.patch \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000033 "
34
35S = "${WORKDIR}/git"
36
37inherit autotools-brokensep pkgconfig
38
Andrew Geissler78b72792022-06-14 06:47:25 -050039# Version 20220527 added KVM test infrastructure which currently fails to build with gold due to
40# SORT_NONE in linker script which isn't supported by gold:
41# https://sourceware.org/bugzilla/show_bug.cgi?id=18097
42# https://github.com/linux-test-project/ltp/commit/3fce2064b54843218d085aae326c8f7ecf3a8c41#diff-39268f0855c634ca48c8993fcd2c95b12a65b79e8d9fa5ccd6b0f5a8785c0dd6R36
43LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd', '', d)}"
44
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050045# After 0002-kvm-use-LD-instead-of-hardcoding-ld.patch
46# https://github.com/linux-test-project/ltp/commit/f94e0ef3b7280f886384703ef9019aaf2f2dfebb
47# it fails with gold also a bit later when trying to use *-payload.bin
48# http://errors.yoctoproject.org/Errors/Details/663094/
49# work around this by forcing .bfd linked in LD when ld-is-gold is in DISTRO_FEATURES
50KVM_LD = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', '${HOST_PREFIX}ld.bfd${TOOLCHAIN_OPTIONS} ${HOST_LD_ARCH}', '${LD}', d)}"
51
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000052TARGET_CC_ARCH += "${LDFLAGS}"
53
54export prefix = "/opt/${PN}"
55export exec_prefix = "/opt/${PN}"
56
57PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
58EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
59EXTRA_OECONF = " --with-realtime-testsuite --with-open-posix-testsuite "
60# ltp network/rpc test cases ftbfs when libtirpc is found
61EXTRA_OECONF += " --without-tirpc "
62
63do_compile() {
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050064 oe_runmake HOSTCC="${CC_FOR_BUILD}" HOST_CFLAGS="${CFLAGS_FOR_BUILD}" HOST_LDFLAGS="${LDFLAGS_FOR_BUILD}" KVM_LD="${KVM_LD}"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000065}
66
67do_install(){
68 install -d ${D}${prefix}/
69 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install include-install
70
71 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
72 # as it lacks dependency on some perl moudle such as LWP::Simple
73 # And this script previously works as a tool for analyzing failures from LTP
74 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
75 # http://khack.osdl.org to retrieve ltp test results run on
76 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
77 rm -rf ${D}${prefix}/bin/STPfailure_report.pl
78
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000079 # The controllers memcg_stree test seems to cause us hangs and takes 900s
80 # (maybe we expect more regular output?), anyhow, skip it
81 sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000082}
83
84RDEPENDS:${PN} = "\
85 attr \
86 bash \
87 bc \
88 coreutils \
89 cpio \
90 cronie \
91 curl \
92 e2fsprogs \
93 e2fsprogs-mke2fs \
94 expect \
95 file \
96 gawk \
97 gdb \
98 gzip \
99 iproute2 \
100 ldd \
101 libaio \
102 logrotate \
103 net-tools \
104 perl \
105 python3-core \
106 procps \
107 quota \
108 unzip \
109 util-linux \
110 which \
111 tar \
112"
113
114FILES:${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a"
115
116# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
117INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01"
118INSANE_SKIP:${PN} += "already-stripped staticdev"
119
120remove_broken_musl_sources() {
121 [ "${TCLIBC}" = "musl" ] || return 0
122
123 cd ${S}
124 echo "WARNING: remove unsupported tests (until they're fixed)"
125
126 # sync with upstream
127 # https://github.com/linux-test-project/ltp/blob/master/ci/alpine.sh#L33
128 rm -rfv \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +0000129 testcases/kernel/syscalls/fmtmsg/fmtmsg01.c \
130 testcases/kernel/syscalls/getcontext/getcontext01.c \
131 testcases/kernel/syscalls/rt_tgsigqueueinfo/rt_tgsigqueueinfo01.c \
132 testcases/kernel/syscalls/timer_create/timer_create01.c \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500133 testcases/kernel/syscalls/timer_create/timer_create03.c
Andrew Geissler7e0e3c02022-02-25 20:34:39 +0000134}
135do_patch[postfuncs] += "remove_broken_musl_sources"
136
137# Avoid file dependency scans, as LTP checks for things that may or may not
138# exist on the running system. For instance it has specific checks for
139# csh and ksh which are not typically part of OpenEmbedded systems (but
140# can be added via additional layers.)
141SKIP_FILEDEPS:${PN} = '1'