blob: 219d6ff32dda69745c509b51f76a95a360e805ea [file] [log] [blame]
Brad Bishopbd9931f2017-04-22 16:26:22 -04001SUMMARY = "Phosphor Fan"
2DESCRIPTION = "Phosphor fan provides a set of fan monitoring and \
3control applications."
4PR = "r1"
Patrick Venture5def7e72018-10-21 08:25:11 -07005PV = "1.0+git${SRCPV}"
Brad Bishopbd9931f2017-04-22 16:26:22 -04006
7require ${PN}.inc
8
9inherit autotools pkgconfig pythonnative
10inherit obmc-phosphor-systemd
11inherit phosphor-fan
12
13S = "${WORKDIR}/git"
14
15# Common build dependencies
16DEPENDS += "autoconf-archive-native"
17DEPENDS += "python-pyyaml-native"
18DEPENDS += "python-mako-native"
19DEPENDS += "sdbusplus"
Brad Bishop04ff12c2018-01-26 21:48:20 -050020DEPENDS += "sdbusplus-native"
William A. Kennington IIIaa5d9452018-10-19 18:24:31 -070021DEPENDS += "sdeventplus"
William A. Kennington III3bb26b92018-10-29 16:32:26 -070022DEPENDS += "gpioplus"
Brad Bishopbd9931f2017-04-22 16:26:22 -040023DEPENDS += "phosphor-logging"
Brad Bishop4785fdf2017-07-30 21:25:23 -040024DEPENDS += "libevdev"
Brad Bishopbd9931f2017-04-22 16:26:22 -040025
26# Package configuration
27FAN_PACKAGES = " \
28 ${PN}-presence-tach \
29 ${PN}-control \
Matt Spinlerdd7a0802017-05-01 14:29:20 -050030 ${PN}-monitor \
Brad Bishopbd9931f2017-04-22 16:26:22 -040031"
Brandon Wymanc50a8c42017-04-28 18:26:45 -050032
Brad Bishop93df99a2018-04-11 11:41:50 -040033ALLOW_EMPTY_${PN} = "1"
34PACKAGE_BEFORE_PN += "${FAN_PACKAGES}"
Brandon Wyman5b42b742017-06-09 17:50:42 -050035PACKAGECONFIG ?= "presence control monitor"
Brad Bishopbd9931f2017-04-22 16:26:22 -040036SYSTEMD_PACKAGES = "${FAN_PACKAGES}"
Brad Bishopbd9931f2017-04-22 16:26:22 -040037
38# --------------------------------------
39# ${PN}-presence-tach specific configuration
40PACKAGECONFIG[presence] = " \
41 --enable-presence \
Brad Bishop8861a872017-08-02 14:01:24 -040042 PRESENCE_CONFIG=${STAGING_DIR_NATIVE}${presence_datadir}/config.yaml, \
Brad Bishopbd9931f2017-04-22 16:26:22 -040043 --disable-presence, \
44 virtual/phosphor-fan-presence-config \
45 , \
46"
Brad Bishopbd9931f2017-04-22 16:26:22 -040047
Matt Spinlerc133ec12017-04-19 08:23:50 -050048# Needed to install into the obmc-chassis-poweron target
49TMPL_TACH = "phosphor-fan-presence-tach@.service"
50INSTFMT_TACH = "phosphor-fan-presence-tach@{0}.service"
Matt Spinlerbde651b2017-05-16 10:49:57 -050051POWERON_TGT = "obmc-chassis-poweron@{0}.target"
52FMT_TACH = "../${TMPL_TACH}:${POWERON_TGT}.requires/${INSTFMT_TACH}"
Brad Bishopbd9931f2017-04-22 16:26:22 -040053
54FILES_${PN}-presence-tach = "${sbindir}/phosphor-fan-presence-tach"
Matt Spinlerc133ec12017-04-19 08:23:50 -050055SYSTEMD_SERVICE_${PN}-presence-tach += "${TMPL_TACH}"
56SYSTEMD_LINK_${PN}-presence-tach += "${@compose_list(d, 'FMT_TACH', 'OBMC_CHASSIS_INSTANCES')}"
Brad Bishopbd9931f2017-04-22 16:26:22 -040057
58# --------------------------------------
59# ${PN}-control specific configuration
Matt Spinlerc133ec12017-04-19 08:23:50 -050060PACKAGECONFIG[control] = "--enable-control \
61 FAN_DEF_YAML_FILE=${STAGING_DIR_NATIVE}${control_datadir}/fans.yaml \
62 FAN_ZONE_YAML_FILE=${STAGING_DIR_NATIVE}${control_datadir}/zones.yaml \
Matthew Barth2bfd71d2017-05-24 17:06:13 -050063 ZONE_EVENTS_YAML_FILE=${STAGING_DIR_NATIVE}${control_datadir}/events.yaml \
Gunnar Millsc8228da2017-06-26 11:35:38 -050064 ZONE_CONDITIONS_YAML_FILE=${STAGING_DIR_NATIVE}${control_datadir}/zone_conditions.yaml \
Matt Spinlerc133ec12017-04-19 08:23:50 -050065 FAN_ZONE_OUTPUT_DIR=${S}/control, \
66 --disable-control, \
67 virtual/phosphor-fan-control-fan-config \
68 phosphor-fan-control-zone-config-native \
Matthew Barth2bfd71d2017-05-24 17:06:13 -050069 phosphor-fan-control-events-config-native \
Gunnar Millsc8228da2017-06-26 11:35:38 -050070 phosphor-fan-control-zone-conditions-config-native \
Matt Spinlerc133ec12017-04-19 08:23:50 -050071 , \
72"
73
Matt Spinlerbde651b2017-05-16 10:49:57 -050074FAN_CONTROL_TGT = "obmc-fan-control-ready@{0}.target"
75
Matt Spinlerc133ec12017-04-19 08:23:50 -050076TMPL_CONTROL = "phosphor-fan-control@.service"
77INSTFMT_CONTROL = "phosphor-fan-control@{0}.service"
Matt Spinlerbde651b2017-05-16 10:49:57 -050078FMT_CONTROL = "../${TMPL_CONTROL}:${FAN_CONTROL_TGT}.requires/${INSTFMT_CONTROL}"
79
80TMPL_CONTROL_INIT = "phosphor-fan-control-init@.service"
81INSTFMT_CONTROL_INIT = "phosphor-fan-control-init@{0}.service"
Matthew Barthb5e69d62017-10-24 14:04:46 -050082FMT_CONTROL_INIT = "../${TMPL_CONTROL_INIT}:${POWERON_TGT}.wants/${INSTFMT_CONTROL_INIT}"
Matt Spinlerc133ec12017-04-19 08:23:50 -050083
Brad Bishopbd9931f2017-04-22 16:26:22 -040084FILES_${PN}-control = "${sbindir}/phosphor-fan-control"
Matt Spinlerbde651b2017-05-16 10:49:57 -050085SYSTEMD_SERVICE_${PN}-control += "${TMPL_CONTROL} ${TMPL_CONTROL_INIT}"
Matt Spinlerc133ec12017-04-19 08:23:50 -050086SYSTEMD_LINK_${PN}-control += "${@compose_list(d, 'FMT_CONTROL', 'OBMC_CHASSIS_INSTANCES')}"
Matt Spinlerbde651b2017-05-16 10:49:57 -050087SYSTEMD_LINK_${PN}-control += "${@compose_list(d, 'FMT_CONTROL_INIT', 'OBMC_CHASSIS_INSTANCES')}"
Brad Bishopbd9931f2017-04-22 16:26:22 -040088
89# --------------------------------------
Matt Spinlerdd7a0802017-05-01 14:29:20 -050090# ${PN}-monitor specific configuration
91PACKAGECONFIG[monitor] = "--enable-monitor \
92 FAN_MONITOR_YAML_FILE=${STAGING_DIR_NATIVE}${monitor_datadir}/monitor.yaml \
93 FAN_MONITOR_OUTPUT_DIR=${S}/monitor, \
94 --disable-monitor, \
95 phosphor-fan-monitor-config-native \
96 , \
97"
98
Matt Spinlerdd7a0802017-05-01 14:29:20 -050099TMPL_MONITOR = "phosphor-fan-monitor@.service"
100INSTFMT_MONITOR = "phosphor-fan-monitor@{0}.service"
Matt Spinlerbde651b2017-05-16 10:49:57 -0500101FMT_MONITOR = "../${TMPL_MONITOR}:${FAN_CONTROL_TGT}.requires/${INSTFMT_MONITOR}"
Matt Spinlerdd7a0802017-05-01 14:29:20 -0500102
Matthew Barthcac2ecf2017-08-23 13:18:01 -0500103TMPL_MONITOR_INIT = "phosphor-fan-monitor-init@.service"
104INSTFMT_MONITOR_INIT = "phosphor-fan-monitor-init@{0}.service"
Matthew Barthb5e69d62017-10-24 14:04:46 -0500105FMT_MONITOR_INIT = "../${TMPL_MONITOR_INIT}:${POWERON_TGT}.wants/${INSTFMT_MONITOR_INIT}"
Matthew Barthcac2ecf2017-08-23 13:18:01 -0500106
Matt Spinlerdd7a0802017-05-01 14:29:20 -0500107FILES_${PN}-monitor = "${sbindir}/phosphor-fan-monitor"
Matthew Barthcac2ecf2017-08-23 13:18:01 -0500108SYSTEMD_SERVICE_${PN}-monitor += "${TMPL_MONITOR} ${TMPL_MONITOR_INIT}"
Matt Spinlerdd7a0802017-05-01 14:29:20 -0500109SYSTEMD_LINK_${PN}-monitor += "${@compose_list(d, 'FMT_MONITOR', 'OBMC_CHASSIS_INSTANCES')}"
Matthew Barthcac2ecf2017-08-23 13:18:01 -0500110SYSTEMD_LINK_${PN}-monitor += "${@compose_list(d, 'FMT_MONITOR_INIT', 'OBMC_CHASSIS_INSTANCES')}"
Brandon Wymanc50a8c42017-04-28 18:26:45 -0500111
112# --------------------------------------
113# phosphor-cooling-type specific configuration
Brad Bishop4785fdf2017-07-30 21:25:23 -0400114PACKAGECONFIG[cooling-type] = "--enable-cooling-type,--disable-cooling-type,,"