blob: 3c29dfab07b48a5cacb2793b76a392b18ec6c463 [file] [log] [blame]
Brad Bishop4c3712f2019-04-24 19:44:31 -04001inherit systemd
Ed Tanous2c2a1c52018-01-29 10:56:52 -08002inherit useradd
3
4USERADD_PACKAGES = "${PN}"
5
6# add a user called httpd for the server to assume
Patrick Williams12fc9392021-08-06 09:16:53 -05007USERADD_PARAM:${PN} = "-r -s /usr/sbin/nologin bmcweb"
8GROUPADD_PARAM:${PN} = "web; redfish"
Ed Tanous2c2a1c52018-01-29 10:56:52 -08009
10LICENSE = "Apache-2.0"
Andrew Geisslere11f5e22021-07-20 18:10:59 +000011LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080012
Andrew Geisslerbda00222022-02-02 21:30:58 +000013SRC_URI = "git://github.com/openbmc/bmcweb.git;branch=master;protocol=https;nobranch=1"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080014
15PV = "1.0+git${SRCPV}"
Andrew Geisslerbda00222022-02-02 21:30:58 +000016SRCREV = "67df073b1f0950fdeafc6d30240d360bd162d0f8"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080017
18S = "${WORKDIR}/git"
19
Ed Tanous5ac61442022-02-02 21:30:58 +000020CXXFLAGS:append = " -DNEW_BOOST_URL"
21
Andrew Geisslerec34cc62021-11-03 09:57:52 -050022inherit pkgconfig meson ptest
Ed Tanousa443c542021-02-26 13:28:37 -080023
24SRC_URI += " \
25 file://run-ptest \
26"
27
Ed Tanous07f48cc2021-02-22 10:49:30 -080028DEPENDS = " \
29 openssl \
30 zlib \
31 boost \
32 boost-url \
33 libpam \
34 sdbusplus \
35 gtest \
36 nlohmann-json \
37 libtinyxml2 \
Ed Tanousa443c542021-02-26 13:28:37 -080038 ${@bb.utils.contains('PTEST_ENABLED', '1', 'gtest', '', d)} \
39 ${@bb.utils.contains('PTEST_ENABLED', '1', 'gmock', '', d)} \
Ed Tanous07f48cc2021-02-22 10:49:30 -080040"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080041
Patrick Williams12fc9392021-08-06 09:16:53 -050042RDEPENDS:${PN} += " \
Ed Tanous07f48cc2021-02-22 10:49:30 -080043 jsnbd \
Ed Tanous4073a4f2021-02-22 10:50:59 -080044 phosphor-mapper \
Ed Tanous07f48cc2021-02-22 10:49:30 -080045"
Adriana Kobylak7e0ff54f2018-12-13 11:01:05 -060046
Ed Tanousa443c542021-02-26 13:28:37 -080047do_install_ptest() {
48 install -d ${D}${PTEST_PATH}/test
Ed Tanousd7afac72021-04-01 16:09:06 -070049 cp -rf ${B}/*_test ${D}${PTEST_PATH}/test/
Ed Tanousa443c542021-02-26 13:28:37 -080050}
51
Patrick Williams12fc9392021-08-06 09:16:53 -050052FILES:${PN} += "${datadir}/** "
Ed Tanous2c2a1c52018-01-29 10:56:52 -080053
Ed Tanous2c2a1c52018-01-29 10:56:52 -080054
Ed Tanousa443c542021-02-26 13:28:37 -080055EXTRA_OEMESON = " \
56 --buildtype=minsize \
57 -Dtests=${@bb.utils.contains('PTEST_ENABLED', '1', 'enabled', 'disabled', d)} \
58 -Dyocto-deps=enabled \
59"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080060
Patrick Williams12fc9392021-08-06 09:16:53 -050061SYSTEMD_SERVICE:${PN} += "bmcweb.service bmcweb.socket"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080062
Manojkiran Edaf1f2e242020-09-02 21:48:12 +053063FULL_OPTIMIZATION = "-Os "