blob: 1887a5582fa0e0312cef851409a3aee7824b734d [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001#
2# Copyright (C) 2013 Wind River Systems, Inc.
3#
4
5SUMMARY = "Simple Protocol for Independent Computing Environments"
6DESCRIPTION = "SPICE (the Simple Protocol for Independent Computing \
7Environments) is a remote-display system built for virtual \
8environments which allows users to view a computing 'desktop' \
9environment - not only on its computer-server machine, but also from \
10anywhere on the Internet and using a wide variety of machine \
11architectures."
12
Andrew Geissler9aee5002022-03-30 16:27:02 +000013LICENSE = "LGPL-2.1-or-later"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
15
Brad Bishop15ae2502019-06-18 21:44:24 -040016PV = "0.14.2+git${SRCPV}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017
Brad Bishop15ae2502019-06-18 21:44:24 -040018SRCREV_spice = "7cbd70b931db76c69c89c2d9d5d704f67381a81b"
19SRCREV_spice-common = "4fc4c2db36c7f07b906e9a326a9d3dc0ae6a2671"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
21SRCREV_FORMAT = "spice_spice-common"
22
23SRC_URI = " \
Andrew Geissler595f6302022-01-24 19:11:47 +000024 git://anongit.freedesktop.org/spice/spice;name=spice;branch=master \
25 git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/subprojects/spice-common;name=spice-common;branch=master \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026 file://0001-Convert-pthread_t-to-be-numeric.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040027 file://0001-Fix-compile-errors-on-Linux-32bit-system.patch \
Andrew Geisslerac970dd2021-02-12 15:32:45 -060028 file://0001-configure.ac-explicitly-link-to-jpeg-lib.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029"
30
31S = "${WORKDIR}/git"
32
Andrew Geissler615f2f12022-07-15 14:00:58 -050033CVE_CHECK_IGNORE += "\
34 CVE-2016-0749 \
35 CVE-2016-2150 \
36 CVE-2018-10893 \
37"
38
Andrew Geissler82c905d2020-04-13 13:39:40 -050039inherit autotools gettext python3native python3-dir pkgconfig
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080040
Andrew Geissler82c905d2020-04-13 13:39:40 -050041DEPENDS += "spice-protocol jpeg pixman alsa-lib glib-2.0 python3-pyparsing-native python3-six-native glib-2.0-native"
Patrick Williams213cb262021-08-07 19:21:33 -050042DEPENDS:append:class-nativesdk = " nativesdk-openssl"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080043
Andrew Geissler82c905d2020-04-13 13:39:40 -050044export PYTHON="${STAGING_BINDIR_NATIVE}/python3-native/python3"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080045
Patrick Williams213cb262021-08-07 19:21:33 -050046CFLAGS:append = " -Wno-error"
Brad Bishop15ae2502019-06-18 21:44:24 -040047
Patrick Williams213cb262021-08-07 19:21:33 -050048PACKAGECONFIG:class-native = ""
49PACKAGECONFIG:class-nativesdk = ""
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080050PACKAGECONFIG ?= "sasl"
51
52PACKAGECONFIG[celt051] = "--enable-celt051,--disable-celt051,celt051"
53PACKAGECONFIG[smartcard] = "--enable-smartcard,--disable-smartcard,libcacard,"
54PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl,"
55PACKAGECONFIG[client] = "--enable-client,--disable-client,,"
56PACKAGECONFIG[gui] = "--enable-gui,--disable-gui,,"
57PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus,"
58PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,,"
59PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama,"
60
61COMPATIBLE_HOST = '(x86_64|i.86).*-linux'
62
Brad Bishop36a3e3e2019-10-02 13:29:27 -040063BBCLASSEXTEND = "native nativesdk"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080064
Patrick Williams213cb262021-08-07 19:21:33 -050065EXTRA_OECONF:append:toolchain-clang = " --disable-werror"