blob: 50c9baf9dd9481eed313ec4413af3cd8bc127722 [file] [log] [blame]
Andrew Geissler82cfa662020-02-17 15:11:03 -06001SUMMARY = "OpenPOWER processor control services installation"
2PR = "r1"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit allarch
8
Adriana Kobylak8c6707f2021-08-06 17:35:36 +00009RDEPENDS:${PN} += "op-proc-control"
10RDEPENDS:${PN} += "phosphor-state-manager-obmc-targets"
Andrew Geissler82cfa662020-02-17 15:11:03 -060011
Adriana Kobylak8c6707f2021-08-06 17:35:36 +000012ALLOW_EMPTY:${PN} = "1"
Andrew Geissler82cfa662020-02-17 15:11:03 -060013
Adriana Kobylak8c6707f2021-08-06 17:35:36 +000014pkg_postinst:${PN}() {
Andrew Geissler55bd4492020-03-31 13:43:46 -050015 mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.wants
Andrew Geissler82cfa662020-02-17 15:11:03 -060016 mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
Dhruvaraj Subhashchandranc8aa6a12020-03-09 13:04:32 -050017 mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
18 mkdir -p $D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires
Andrew Geisslerf95063e2020-04-14 15:08:43 -050019 mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires
Andrew Geisslerc3f1beb2020-12-09 15:05:02 -060020 mkdir -p $D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants
Andrew Geissler82cfa662020-02-17 15:11:03 -060021
Andrew Geissler55bd4492020-03-31 13:43:46 -050022 LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -060023 TARGET="../op-stop-instructions@.service"
24 ln -s $TARGET $LINK
25
Andrew Geisslerc3f1beb2020-12-09 15:05:02 -060026 LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/op-stop-instructions@0.service"
27 TARGET="../op-stop-instructions@.service"
28 ln -s $TARGET $LINK
29
Andrew Geisslerf95063e2020-04-14 15:08:43 -050030 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service"
31 TARGET="../op-cfam-reset.service"
32 ln -s $TARGET $LINK
33
34 LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -060035 TARGET="../op-cfam-reset.service"
36 ln -s $TARGET $LINK
Andrew Geissler4e174d12020-02-26 14:11:53 -060037
38 # Only install cfam override if p9 system
39 if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then
40 mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
41 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service"
42 TARGET="../cfam_override@.service"
43 ln -s $TARGET $LINK
44 fi
Dhruvaraj Subhashchandranc8aa6a12020-03-09 13:04:32 -050045
46 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
47 TARGET="../op-continue-mpreboot@.service"
48 ln -s $TARGET $LINK
49
Andrew Geissler88eef192020-12-17 11:37:11 -060050 # Only install certain units if phal enabled
Patrick Williams8c561ee2021-10-22 14:20:12 -050051 if [ "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}" = phal ]; then
Andrew Geisslerf158d902022-04-08 16:24:35 -050052 LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-clear-sys-dump-active@0.service"
53 TARGET="../op-clear-sys-dump-active@.service"
54 ln -s $TARGET $LINK
55
56 mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
57 LINK="$D$systemd_system_unitdir/multi-user.target.wants/op-clear-sys-dump-active@0.service"
58 TARGET="../op-clear-sys-dump-active@.service"
59 ln -s $TARGET $LINK
60
Ramesh Iyyard6d9b542020-09-17 10:02:08 -050061 mkdir -p $D$systemd_system_unitdir/obmc-host-start@0.target.requires
62 LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
63 TARGET="../phal-reinit-devtree.service"
64 ln -s $TARGET $LINK
Chirag Sharma5ec16a32020-12-11 03:45:15 -060065
66 LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
67 TARGET="../proc-pre-poweroff@.service"
68 ln -s $TARGET $LINK
Andrew Geissler4d2fd8d2021-06-24 15:28:47 -050069
70 LINK="$D$systemd_system_unitdir/obmc-host-reset@0.target.requires/op-reset-host-check@0.service"
71 TARGET="../op-reset-host-check@.service"
72 ln -s $TARGET $LINK
Jayanth Othayothad68ba32021-07-30 06:35:44 -050073
Jayanth Othayothad68ba32021-07-30 06:35:44 -050074 LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service"
75 TARGET="../phal-import-devtree@.service"
76 ln -s $TARGET $LINK
Jayanth Othayothce7dbec2021-07-30 06:46:57 -050077
78 mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.wants
79 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/phal-export-devtree@0.service"
80 TARGET="../phal-export-devtree@.service"
81 ln -s $TARGET $LINK
Ramesh Iyyard0aedb92022-02-24 03:35:40 -060082
83 mkdir -p $D$systemd_system_unitdir/obmc-host-start@0.target.wants
84 LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.wants/phal-create-boottime-guard-indicator.service"
85 TARGET="../phal-create-boottime-guard-indicator.service"
86 ln -s $TARGET $LINK
87 LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/phal-create-boottime-guard-indicator.service"
88 ln -s $TARGET $LINK
Jayanth Othayoth633a9cc2022-09-12 06:23:45 -050089
90 mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.wants
91 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/op-clock-data-logger@0.service"
92 TARGET="../op-clock-data-logger@.service"
93 ln -s $TARGET $LINK
Jayanth Othayothad68ba32021-07-30 06:35:44 -050094 fi
Andrew Geissler88eef192020-12-17 11:37:11 -060095
Andrew Geissleraa25e2c2021-02-01 14:14:25 -060096 # If the memory preserving reboot feature is enabled, set it up
97 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'mpreboot', d)}" = mpreboot ]; then
98 # on mpreboot systems, obmc-host-crash@.target is used for mpreboot
Andrew Geissler88eef192020-12-17 11:37:11 -060099 mkdir -p $D$systemd_system_unitdir/obmc-host-crash@0.target.requires
100 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-force-warm-reboot@0.target"
101 TARGET="../obmc-host-force-warm-reboot@.target"
102 ln -s $TARGET $LINK
103
104 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/op-enter-mpreboot@0.service"
105 TARGET="../op-enter-mpreboot@.service"
106 ln -s $TARGET $LINK
107
Andrew Geissleraa25e2c2021-02-01 14:14:25 -0600108 # ensure diagnostic mode is shown for MPREBOOT
Andrew Geissler88eef192020-12-17 11:37:11 -0600109 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-diagnostic-mode@0.target"
110 TARGET="../obmc-host-diagnostic-mode@.target"
111 ln -s $TARGET $LINK
112 else
Andrew Geissleraa25e2c2021-02-01 14:14:25 -0600113 # If not a mpreboot system, default to quiesce target in crash target to support
Andrew Geissler88eef192020-12-17 11:37:11 -0600114 # older system designs like witherspoon
115 mkdir -p $D$systemd_system_unitdir/obmc-host-crash@0.target.wants
116 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.wants/obmc-host-quiesce@0.target"
117 TARGET="../obmc-host-quiesce@.target"
118 ln -s $TARGET $LINK
Ramesh Iyyard6d9b542020-09-17 10:02:08 -0500119 fi
Andrew Geissler82cfa662020-02-17 15:11:03 -0600120}
121
Adriana Kobylak8c6707f2021-08-06 17:35:36 +0000122pkg_prerm:${PN}() {
Andrew Geissler55bd4492020-03-31 13:43:46 -0500123 LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -0600124 rm $LINK
Andrew Geisslerf95063e2020-04-14 15:08:43 -0500125 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service"
126 rm $LINK
127 LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -0600128 rm $LINK
Andrew Geissler4e174d12020-02-26 14:11:53 -0600129 # Only uninstall cfam override if p9 system
130 if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then
131 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service"
132 rm $LINK
133 fi
Dhruvaraj Subhashchandranc8aa6a12020-03-09 13:04:32 -0500134 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
135 rm $LINK
Ramesh Iyyard6d9b542020-09-17 10:02:08 -0500136
Andrew Geissler88eef192020-12-17 11:37:11 -0600137 # Remove phal specific units if enabled
Patrick Williams8c561ee2021-10-22 14:20:12 -0500138 if [ "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}" = phal ]; then
Ramesh Iyyard6d9b542020-09-17 10:02:08 -0500139 LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
140 rm $LINK
Chirag Sharma5ec16a32020-12-11 03:45:15 -0600141
142 LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
143 rm $LINK
Jayanth Othayothad68ba32021-07-30 06:35:44 -0500144
145 LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service"
146 rm $LINK
Jayanth Othayothce7dbec2021-07-30 06:46:57 -0500147
148 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/phal-export-devtree@0.service"
149 rm $LINK
Ramesh Iyyard0aedb92022-02-24 03:35:40 -0600150
151 LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.wants/phal-create-boottime-guard-indicator.service"
152 rm $LINK
153 LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/phal-create-boottime-guard-indicator.service"
154 rm $LINK
Jayanth Othayoth633a9cc2022-09-12 06:23:45 -0500155
156 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/op-clock-data-logger@0.service"
157 rm $LINK
Andrew Geissleraa25e2c2021-02-01 14:14:25 -0600158 fi
Andrew Geissler88eef192020-12-17 11:37:11 -0600159
Andrew Geissleraa25e2c2021-02-01 14:14:25 -0600160 # Remove mpreboot specific units if enabled
161 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'mpreboot', d)}" = mpreboot ]; then
Andrew Geissler88eef192020-12-17 11:37:11 -0600162 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-force-warm-reboot@0.target"
163 rm $LINK
164
165 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/op-enter-mpreboot@0.service"
166 rm $LINK
167 else
168 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.wants/obmc-host-quiesce@0.target"
169 rm $LINK
Ramesh Iyyard6d9b542020-09-17 10:02:08 -0500170 fi
Andrew Geissler82cfa662020-02-17 15:11:03 -0600171}