blob: dd2ca6c95d5f5ae8634fd09fc4008f67c1aa6cbb [file] [log] [blame]
Brad Bishope3278032016-11-09 20:43:11 -05001SUMMARY = "C++ bindings for systemd dbus APIs"
2DESCRIPTION = "C++ bindings for systemd dbus APIs."
3HOMEPAGE = "http://github.com/openbmc/sdbusplus"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
7
8inherit autotools pkgconfig
Patrick Williams8fc96292016-11-22 07:01:14 -06009inherit obmc-phosphor-python-autotools
Brad Bishope3278032016-11-09 20:43:11 -050010
11DEPENDS += "autoconf-archive-native"
Brad Bishop13b8afa2017-01-12 14:06:43 -050012RDEPENDS_sdbus++ += " \
Brad Bishope3278032016-11-09 20:43:11 -050013 python-inflection \
14 python-mako \
15 python-pyyaml \
16 "
17
Brad Bishop6b4da622017-01-18 13:59:33 -050018# sdbus++ has a handful of runtime dependencies on other python packages.
19# Bitbake doesn't do anything with RDEPENDS in native context because
20# native context doesn't have packages.
21#
22# While technically sdbus++ doesn't require its runtime dependencies to be
23# installed to build, work around the above native context behavior
24# by adding a build dependency so that clients don't have to DEPEND
25# on sdbus++ runtime dependencies manually.
26
27DEPENDS_append_class-native = " \
28 python-inflection-native \
29 python-mako-native \
30 python-pyyaml-native \
31 "
32
Brad Bishope3278032016-11-09 20:43:11 -050033SRC_URI += "git://github.com/openbmc/sdbusplus"
Patrick Williamseb2a4322017-01-18 21:40:03 -060034SRCREV = "b6dcf97fdf0d9c673812942f5b4e8b2691ceb5a3"
Brad Bishope3278032016-11-09 20:43:11 -050035
36PACKAGECONFIG ??= "libsdbusplus"
37PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
38
39S = "${WORKDIR}/git"
40
Patrick Williams592d7982016-11-22 11:05:11 -060041PROVIDES_prepend = "sdbus++ "
42PACKAGES_prepend = "sdbus++ "
43FILES_sdbus++_append = " ${bindir}/sdbus++"
44PYTHON_AUTOTOOLS_PACKAGE = "sdbus++"
45
Brad Bishope3278032016-11-09 20:43:11 -050046PACKAGECONFIG_remove_class-native = "libsdbusplus"
47PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus"
Patrick Williams56d9b5d2016-11-22 13:28:33 -060048ALLOW_EMPTY_${PN} = "1"
Brad Bishope3278032016-11-09 20:43:11 -050049
Brad Bishope3278032016-11-09 20:43:11 -050050BBCLASSEXTEND += "native nativesdk"