blob: d843e7c4aced6d20c5b29e17af32ed54afa6e84b [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001# This class is used to check recipes against public CVEs.
2#
3# In order to use this class just inherit the class in the
4# local.conf file and it will add the cve_check task for
5# every recipe. The task can be used per recipe, per image,
6# or using the special cases "world" and "universe". The
7# cve_check task will print a warning for every unpatched
8# CVE found and generate a file in the recipe WORKDIR/cve
9# directory. If an image is build it will generate a report
10# in DEPLOY_DIR_IMAGE for all the packages used.
11#
12# Example:
13# bitbake -c cve_check openssl
14# bitbake core-image-sato
15# bitbake -k -c cve_check universe
16#
17# DISCLAIMER
18#
19# This class/tool is meant to be used as support and not
20# the only method to check against CVEs. Running this tool
21# doesn't guarantee your packages are free of CVEs.
22
Brad Bishop37a0e4d2017-12-04 01:01:44 -050023# The product name that the CVE database uses. Defaults to BPN, but may need to
24# be overriden per recipe (for example tiff.bb sets CVE_PRODUCT=libtiff).
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025CVE_PRODUCT ??= "${BPN}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040026CVE_VERSION ??= "${PV}"
Brad Bishop37a0e4d2017-12-04 01:01:44 -050027
Patrick Williamsc0f7c042017-02-23 20:41:17 -060028CVE_CHECK_DB_DIR ?= "${DL_DIR}/CVE_CHECK"
Andrew Geissler82c905d2020-04-13 13:39:40 -050029CVE_CHECK_DB_FILE ?= "${CVE_CHECK_DB_DIR}/nvdcve_1.1.db"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050030CVE_CHECK_DB_FILE_LOCK ?= "${CVE_CHECK_DB_FILE}.lock"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060031
Brad Bishop316dfdd2018-06-25 12:45:53 -040032CVE_CHECK_LOG ?= "${T}/cve.log"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060033CVE_CHECK_TMP_FILE ?= "${TMPDIR}/cve_check"
Andrew Geisslerb7d28612020-07-24 16:15:54 -050034CVE_CHECK_SUMMARY_DIR ?= "${LOG_DIR}/cve"
35CVE_CHECK_SUMMARY_FILE_NAME ?= "cve-summary"
36CVE_CHECK_SUMMARY_FILE ?= "${CVE_CHECK_SUMMARY_DIR}/${CVE_CHECK_SUMMARY_FILE_NAME}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060037
38CVE_CHECK_DIR ??= "${DEPLOY_DIR}/cve"
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050039CVE_CHECK_RECIPE_FILE ?= "${CVE_CHECK_DIR}/${PN}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060040CVE_CHECK_MANIFEST ?= "${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.cve"
41CVE_CHECK_COPY_FILES ??= "1"
42CVE_CHECK_CREATE_MANIFEST ??= "1"
43
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050044CVE_CHECK_REPORT_PATCHED ??= "1"
45
Patrick Williamsc0f7c042017-02-23 20:41:17 -060046# Whitelist for packages (PN)
Brad Bishop96ff1982019-08-19 13:50:42 -040047CVE_CHECK_PN_WHITELIST ?= ""
Patrick Williamsc0f7c042017-02-23 20:41:17 -060048
Brad Bishop96ff1982019-08-19 13:50:42 -040049# Whitelist for CVE. If a CVE is found, then it is considered patched.
50# The value is a string containing space separated CVE values:
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050051#
Brad Bishop96ff1982019-08-19 13:50:42 -040052# CVE_CHECK_WHITELIST = 'CVE-2014-2524 CVE-2018-1234'
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050053#
Brad Bishop96ff1982019-08-19 13:50:42 -040054CVE_CHECK_WHITELIST ?= ""
Patrick Williamsc0f7c042017-02-23 20:41:17 -060055
Andrew Geisslerb7d28612020-07-24 16:15:54 -050056python cve_save_summary_handler () {
57 import shutil
58 import datetime
59
60 cve_tmp_file = d.getVar("CVE_CHECK_TMP_FILE")
61
62 cve_summary_name = d.getVar("CVE_CHECK_SUMMARY_FILE_NAME")
63 cvelogpath = d.getVar("CVE_CHECK_SUMMARY_DIR")
64 bb.utils.mkdirhier(cvelogpath)
65
66 timestamp = datetime.datetime.now().strftime('%Y%m%d%H%M%S')
67 cve_summary_file = os.path.join(cvelogpath, "%s-%s.txt" % (cve_summary_name, timestamp))
68
Andrew Geisslerc9f78652020-09-18 14:11:35 -050069 if os.path.exists(cve_tmp_file):
70 shutil.copyfile(cve_tmp_file, cve_summary_file)
Andrew Geisslerb7d28612020-07-24 16:15:54 -050071
Andrew Geisslerc9f78652020-09-18 14:11:35 -050072 if cve_summary_file and os.path.exists(cve_summary_file):
73 cvefile_link = os.path.join(cvelogpath, cve_summary_name)
Andrew Geisslerb7d28612020-07-24 16:15:54 -050074
Andrew Geisslerc9f78652020-09-18 14:11:35 -050075 if os.path.exists(os.path.realpath(cvefile_link)):
76 os.remove(cvefile_link)
77 os.symlink(os.path.basename(cve_summary_file), cvefile_link)
Andrew Geisslerb7d28612020-07-24 16:15:54 -050078}
79
80addhandler cve_save_summary_handler
81cve_save_summary_handler[eventmask] = "bb.event.BuildCompleted"
82
Patrick Williamsc0f7c042017-02-23 20:41:17 -060083python do_cve_check () {
84 """
85 Check recipe for patched and unpatched CVEs
86 """
87
Brad Bishop96ff1982019-08-19 13:50:42 -040088 if os.path.exists(d.getVar("CVE_CHECK_DB_FILE")):
Andrew Geissler82c905d2020-04-13 13:39:40 -050089 try:
90 patched_cves = get_patches_cves(d)
91 except FileNotFoundError:
92 bb.fatal("Failure in searching patches")
93 whitelisted, patched, unpatched = check_cves(d, patched_cves)
Patrick Williamsc0f7c042017-02-23 20:41:17 -060094 if patched or unpatched:
95 cve_data = get_cve_info(d, patched + unpatched)
Andrew Geissler82c905d2020-04-13 13:39:40 -050096 cve_write_data(d, patched, unpatched, whitelisted, cve_data)
Patrick Williamsc0f7c042017-02-23 20:41:17 -060097 else:
Brad Bishop96ff1982019-08-19 13:50:42 -040098 bb.note("No CVE database found, skipping CVE check")
99
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600100}
101
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500102addtask cve_check before do_build after do_fetch
Andrew Geisslerc9f78652020-09-18 14:11:35 -0500103do_cve_check[depends] = "cve-update-db-native:do_fetch"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600104do_cve_check[nostamp] = "1"
105
106python cve_check_cleanup () {
107 """
108 Delete the file used to gather all the CVE information.
109 """
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500110 bb.utils.remove(e.data.getVar("CVE_CHECK_TMP_FILE"))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600111}
112
113addhandler cve_check_cleanup
114cve_check_cleanup[eventmask] = "bb.cooker.CookerExit"
115
116python cve_check_write_rootfs_manifest () {
117 """
118 Create CVE manifest when building an image
119 """
120
121 import shutil
122
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500123 if d.getVar("CVE_CHECK_COPY_FILES") == "1":
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500124 deploy_file = d.getVar("CVE_CHECK_RECIPE_FILE")
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500125 if os.path.exists(deploy_file):
126 bb.utils.remove(deploy_file)
127
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500128 if os.path.exists(d.getVar("CVE_CHECK_TMP_FILE")):
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600129 bb.note("Writing rootfs CVE manifest")
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500130 deploy_dir = d.getVar("DEPLOY_DIR_IMAGE")
131 link_name = d.getVar("IMAGE_LINK_NAME")
132 manifest_name = d.getVar("CVE_CHECK_MANIFEST")
133 cve_tmp_file = d.getVar("CVE_CHECK_TMP_FILE")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600134
135 shutil.copyfile(cve_tmp_file, manifest_name)
136
137 if manifest_name and os.path.exists(manifest_name):
138 manifest_link = os.path.join(deploy_dir, "%s.cve" % link_name)
139 # If we already have another manifest, update symlinks
140 if os.path.exists(os.path.realpath(manifest_link)):
141 os.remove(manifest_link)
142 os.symlink(os.path.basename(manifest_name), manifest_link)
143 bb.plain("Image CVE report stored in: %s" % manifest_name)
144}
145
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500146ROOTFS_POSTPROCESS_COMMAND_prepend = "${@'cve_check_write_rootfs_manifest; ' if d.getVar('CVE_CHECK_CREATE_MANIFEST') == '1' else ''}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500147do_rootfs[recrdeptask] += "${@'do_cve_check' if d.getVar('CVE_CHECK_CREATE_MANIFEST') == '1' else ''}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600148
149def get_patches_cves(d):
150 """
151 Get patches that solve CVEs using the "CVE: " tag.
152 """
153
154 import re
155
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500156 pn = d.getVar("PN")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600157 cve_match = re.compile("CVE:( CVE\-\d{4}\-\d+)+")
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500158
159 # Matches last CVE-1234-211432 in the file name, also if written
160 # with small letters. Not supporting multiple CVE id's in a single
161 # file name.
162 cve_file_name_match = re.compile(".*([Cc][Vv][Ee]\-\d{4}\-\d+)")
163
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600164 patched_cves = set()
165 bb.debug(2, "Looking for patches that solves CVEs for %s" % pn)
166 for url in src_patches(d):
167 patch_file = bb.fetch.decodeurl(url)[2]
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500168
Andrew Geissler82c905d2020-04-13 13:39:40 -0500169 if not os.path.isfile(patch_file):
170 bb.error("File Not found: %s" % patch_file)
171 raise FileNotFoundError
172
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500173 # Check patch file name for CVE ID
174 fname_match = cve_file_name_match.search(patch_file)
175 if fname_match:
176 cve = fname_match.group(1).upper()
177 patched_cves.add(cve)
178 bb.debug(2, "Found CVE %s from patch file name %s" % (cve, patch_file))
179
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600180 with open(patch_file, "r", encoding="utf-8") as f:
181 try:
182 patch_text = f.read()
183 except UnicodeDecodeError:
184 bb.debug(1, "Failed to read patch %s using UTF-8 encoding"
185 " trying with iso8859-1" % patch_file)
186 f.close()
187 with open(patch_file, "r", encoding="iso8859-1") as f:
188 patch_text = f.read()
189
Brad Bishopbba38f32018-08-23 16:11:46 +0800190 # Search for one or more "CVE: " lines
191 text_match = False
192 for match in cve_match.finditer(patch_text):
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600193 # Get only the CVEs without the "CVE: " tag
194 cves = patch_text[match.start()+5:match.end()]
195 for cve in cves.split():
196 bb.debug(2, "Patch %s solves %s" % (patch_file, cve))
197 patched_cves.add(cve)
Brad Bishopbba38f32018-08-23 16:11:46 +0800198 text_match = True
199
200 if not fname_match and not text_match:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600201 bb.debug(2, "Patch %s doesn't solve CVEs" % patch_file)
202
203 return patched_cves
204
205def check_cves(d, patched_cves):
206 """
Brad Bishopf3fd2882019-06-21 08:06:37 -0400207 Connect to the NVD database and find unpatched cves.
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600208 """
Brad Bishopf3fd2882019-06-21 08:06:37 -0400209 from distutils.version import LooseVersion
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600210
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600211 pn = d.getVar("PN")
212 real_pv = d.getVar("PV")
213
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600214 cves_unpatched = []
Brad Bishopf3fd2882019-06-21 08:06:37 -0400215 # CVE_PRODUCT can contain more than one product (eg. curl/libcurl)
Brad Bishop96ff1982019-08-19 13:50:42 -0400216 products = d.getVar("CVE_PRODUCT").split()
Brad Bishop316dfdd2018-06-25 12:45:53 -0400217 # If this has been unset then we're not scanning for CVEs here (for example, image recipes)
Brad Bishop96ff1982019-08-19 13:50:42 -0400218 if not products:
Andrew Geissler82c905d2020-04-13 13:39:40 -0500219 return ([], [], [])
Brad Bishop316dfdd2018-06-25 12:45:53 -0400220 pv = d.getVar("CVE_VERSION").split("+git")[0]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600221
222 # If the recipe has been whitlisted we return empty lists
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600223 if pn in d.getVar("CVE_CHECK_PN_WHITELIST").split():
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600224 bb.note("Recipe has been whitelisted, skipping check")
Andrew Geissler82c905d2020-04-13 13:39:40 -0500225 return ([], [], [])
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600226
Brad Bishop96ff1982019-08-19 13:50:42 -0400227 old_cve_whitelist = d.getVar("CVE_CHECK_CVE_WHITELIST")
228 if old_cve_whitelist:
229 bb.warn("CVE_CHECK_CVE_WHITELIST is deprecated, please use CVE_CHECK_WHITELIST.")
230 cve_whitelist = d.getVar("CVE_CHECK_WHITELIST").split()
231
Brad Bishopf3fd2882019-06-21 08:06:37 -0400232 import sqlite3
Brad Bishop6dbb3162019-11-25 09:41:34 -0500233 db_file = d.expand("file:${CVE_CHECK_DB_FILE}?mode=ro")
234 conn = sqlite3.connect(db_file, uri=True)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600235
Brad Bishop6dbb3162019-11-25 09:41:34 -0500236 # For each of the known product names (e.g. curl has CPEs using curl and libcurl)...
Brad Bishop96ff1982019-08-19 13:50:42 -0400237 for product in products:
Brad Bishop96ff1982019-08-19 13:50:42 -0400238 if ":" in product:
239 vendor, product = product.split(":", 1)
Brad Bishop96ff1982019-08-19 13:50:42 -0400240 else:
Brad Bishop6dbb3162019-11-25 09:41:34 -0500241 vendor = "%"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600242
Brad Bishop6dbb3162019-11-25 09:41:34 -0500243 # Find all relevant CVE IDs.
244 for cverow in conn.execute("SELECT DISTINCT ID FROM PRODUCTS WHERE PRODUCT IS ? AND VENDOR LIKE ?", (product, vendor)):
245 cve = cverow[0]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600246
Brad Bishop96ff1982019-08-19 13:50:42 -0400247 if cve in cve_whitelist:
248 bb.note("%s-%s has been whitelisted for %s" % (product, pv, cve))
Brad Bishop64c979e2019-11-04 13:55:29 -0500249 # TODO: this should be in the report as 'whitelisted'
250 patched_cves.add(cve)
Brad Bishop6dbb3162019-11-25 09:41:34 -0500251 continue
Brad Bishopf3fd2882019-06-21 08:06:37 -0400252 elif cve in patched_cves:
253 bb.note("%s has been patched" % (cve))
Brad Bishop6dbb3162019-11-25 09:41:34 -0500254 continue
255
256 vulnerable = False
257 for row in conn.execute("SELECT * FROM PRODUCTS WHERE ID IS ? AND PRODUCT IS ? AND VENDOR LIKE ?", (cve, product, vendor)):
258 (_, _, _, version_start, operator_start, version_end, operator_end) = row
259 #bb.debug(2, "Evaluating row " + str(row))
260
Andrew Geissler82c905d2020-04-13 13:39:40 -0500261 if (operator_start == '=' and pv == version_start) or version_start == '-':
Brad Bishop6dbb3162019-11-25 09:41:34 -0500262 vulnerable = True
Brad Bishop96ff1982019-08-19 13:50:42 -0400263 else:
264 if operator_start:
265 try:
Brad Bishop6dbb3162019-11-25 09:41:34 -0500266 vulnerable_start = (operator_start == '>=' and LooseVersion(pv) >= LooseVersion(version_start))
267 vulnerable_start |= (operator_start == '>' and LooseVersion(pv) > LooseVersion(version_start))
Brad Bishop96ff1982019-08-19 13:50:42 -0400268 except:
Brad Bishop64c979e2019-11-04 13:55:29 -0500269 bb.warn("%s: Failed to compare %s %s %s for %s" %
Brad Bishop96ff1982019-08-19 13:50:42 -0400270 (product, pv, operator_start, version_start, cve))
Brad Bishop6dbb3162019-11-25 09:41:34 -0500271 vulnerable_start = False
Brad Bishop96ff1982019-08-19 13:50:42 -0400272 else:
Brad Bishop6dbb3162019-11-25 09:41:34 -0500273 vulnerable_start = False
Brad Bishop96ff1982019-08-19 13:50:42 -0400274
275 if operator_end:
276 try:
Brad Bishop6dbb3162019-11-25 09:41:34 -0500277 vulnerable_end = (operator_end == '<=' and LooseVersion(pv) <= LooseVersion(version_end))
278 vulnerable_end |= (operator_end == '<' and LooseVersion(pv) < LooseVersion(version_end))
Brad Bishop96ff1982019-08-19 13:50:42 -0400279 except:
Brad Bishop64c979e2019-11-04 13:55:29 -0500280 bb.warn("%s: Failed to compare %s %s %s for %s" %
Brad Bishop96ff1982019-08-19 13:50:42 -0400281 (product, pv, operator_end, version_end, cve))
Brad Bishop6dbb3162019-11-25 09:41:34 -0500282 vulnerable_end = False
Brad Bishop96ff1982019-08-19 13:50:42 -0400283 else:
Brad Bishop6dbb3162019-11-25 09:41:34 -0500284 vulnerable_end = False
Brad Bishop96ff1982019-08-19 13:50:42 -0400285
286 if operator_start and operator_end:
Brad Bishop6dbb3162019-11-25 09:41:34 -0500287 vulnerable = vulnerable_start and vulnerable_end
Brad Bishop96ff1982019-08-19 13:50:42 -0400288 else:
Brad Bishop6dbb3162019-11-25 09:41:34 -0500289 vulnerable = vulnerable_start or vulnerable_end
Brad Bishop96ff1982019-08-19 13:50:42 -0400290
Brad Bishop6dbb3162019-11-25 09:41:34 -0500291 if vulnerable:
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600292 bb.note("%s-%s is vulnerable to %s" % (pn, real_pv, cve))
Brad Bishop96ff1982019-08-19 13:50:42 -0400293 cves_unpatched.append(cve)
Brad Bishop6dbb3162019-11-25 09:41:34 -0500294 break
295
296 if not vulnerable:
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600297 bb.note("%s-%s is not vulnerable to %s" % (pn, real_pv, cve))
Brad Bishop6dbb3162019-11-25 09:41:34 -0500298 # TODO: not patched but not vulnerable
299 patched_cves.add(cve)
300
Brad Bishopf3fd2882019-06-21 08:06:37 -0400301 conn.close()
302
Andrew Geissler82c905d2020-04-13 13:39:40 -0500303 return (list(cve_whitelist), list(patched_cves), cves_unpatched)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600304
305def get_cve_info(d, cves):
306 """
Brad Bishop96ff1982019-08-19 13:50:42 -0400307 Get CVE information from the database.
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600308 """
309
Brad Bishop6dbb3162019-11-25 09:41:34 -0500310 import sqlite3
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600311
312 cve_data = {}
Brad Bishop6dbb3162019-11-25 09:41:34 -0500313 conn = sqlite3.connect(d.getVar("CVE_CHECK_DB_FILE"))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600314
Brad Bishop6dbb3162019-11-25 09:41:34 -0500315 for cve in cves:
316 for row in conn.execute("SELECT * FROM NVD WHERE ID IS ?", (cve,)):
317 cve_data[row[0]] = {}
318 cve_data[row[0]]["summary"] = row[1]
319 cve_data[row[0]]["scorev2"] = row[2]
320 cve_data[row[0]]["scorev3"] = row[3]
321 cve_data[row[0]]["modified"] = row[4]
322 cve_data[row[0]]["vector"] = row[5]
323
324 conn.close()
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600325 return cve_data
326
Andrew Geissler82c905d2020-04-13 13:39:40 -0500327def cve_write_data(d, patched, unpatched, whitelisted, cve_data):
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600328 """
329 Write CVE information in WORKDIR; and to CVE_CHECK_DIR, and
330 CVE manifest if enabled.
331 """
332
Brad Bishop316dfdd2018-06-25 12:45:53 -0400333 cve_file = d.getVar("CVE_CHECK_LOG")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600334 nvd_link = "https://web.nvd.nist.gov/view/vuln/detail?vulnId="
335 write_string = ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500336 unpatched_cves = []
Brad Bishop316dfdd2018-06-25 12:45:53 -0400337 bb.utils.mkdirhier(os.path.dirname(cve_file))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600338
339 for cve in sorted(cve_data):
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500340 is_patched = cve in patched
341 if is_patched and (d.getVar("CVE_CHECK_REPORT_PATCHED") != "1"):
342 continue
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500343 write_string += "PACKAGE NAME: %s\n" % d.getVar("PN")
Andrew Geissler4ed12e12020-06-05 18:00:41 -0500344 write_string += "PACKAGE VERSION: %s%s\n" % (d.getVar("EXTENDPE"), d.getVar("PV"))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600345 write_string += "CVE: %s\n" % cve
Andrew Geissler82c905d2020-04-13 13:39:40 -0500346 if cve in whitelisted:
347 write_string += "CVE STATUS: Whitelisted\n"
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500348 elif is_patched:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600349 write_string += "CVE STATUS: Patched\n"
350 else:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500351 unpatched_cves.append(cve)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600352 write_string += "CVE STATUS: Unpatched\n"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600353 write_string += "CVE SUMMARY: %s\n" % cve_data[cve]["summary"]
Brad Bishopf3fd2882019-06-21 08:06:37 -0400354 write_string += "CVSS v2 BASE SCORE: %s\n" % cve_data[cve]["scorev2"]
355 write_string += "CVSS v3 BASE SCORE: %s\n" % cve_data[cve]["scorev3"]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600356 write_string += "VECTOR: %s\n" % cve_data[cve]["vector"]
357 write_string += "MORE INFORMATION: %s%s\n\n" % (nvd_link, cve)
358
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500359 if unpatched_cves:
360 bb.warn("Found unpatched CVE (%s), for more information check %s" % (" ".join(unpatched_cves),cve_file))
361
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500362 if write_string:
363 with open(cve_file, "w") as f:
364 bb.note("Writing file %s with CVE information" % cve_file)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600365 f.write(write_string)
366
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500367 if d.getVar("CVE_CHECK_COPY_FILES") == "1":
368 deploy_file = d.getVar("CVE_CHECK_RECIPE_FILE")
369 bb.utils.mkdirhier(os.path.dirname(deploy_file))
370 with open(deploy_file, "w") as f:
371 f.write(write_string)
Andrew Geisslerb7d28612020-07-24 16:15:54 -0500372
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500373 if d.getVar("CVE_CHECK_CREATE_MANIFEST") == "1":
374 cvelogpath = d.getVar("CVE_CHECK_SUMMARY_DIR")
375 bb.utils.mkdirhier(cvelogpath)
376
377 with open(d.getVar("CVE_CHECK_TMP_FILE"), "a") as f:
378 f.write("%s" % write_string)