blob: f80afd95cba2f9082e5ba7be2960afcf9449e7d1 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require grub2.inc
2
Brad Bishopa34c0302019-09-23 22:34:48 -04003require conf/image-uefi.conf
4
Brad Bishopd7bf8c12018-02-25 22:55:05 -05005GRUBPLATFORM = "efi"
6
Andrew Geisslerd25ed322020-06-27 00:28:28 -05007DEPENDS_append = " grub-native"
8RDEPENDS_${PN} = "grub-common virtual/grub-bootconf"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009
10SRC_URI += " \
11 file://cfg \
12 "
13
14S = "${WORKDIR}/grub-${PV}"
15
16# Determine the target arch for the grub modules
17python __anonymous () {
18 import re
19 target = d.getVar('TARGET_ARCH')
Brad Bishop316dfdd2018-06-25 12:45:53 -040020 prefix = "" if d.getVar('EFI_PROVIDER') == "grub-efi" else "grub-efi-"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021 if target == "x86_64":
22 grubtarget = 'x86_64'
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023 elif re.match('i.86', target):
24 grubtarget = 'i386'
Brad Bishop316dfdd2018-06-25 12:45:53 -040025 elif re.match('aarch64', target):
26 grubtarget = 'arm64'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027 elif re.match('arm', target):
28 grubtarget = 'arm'
Andrew Geissler6ce62a22020-11-30 19:58:47 -060029 elif re.match('riscv64', target):
30 grubtarget = 'riscv64'
31 elif re.match('riscv32', target):
32 grubtarget = 'riscv32'
Brad Bishopd7bf8c12018-02-25 22:55:05 -050033 else:
Brad Bishop316dfdd2018-06-25 12:45:53 -040034 raise bb.parse.SkipRecipe("grub-efi is incompatible with target %s" % target)
Brad Bishopa34c0302019-09-23 22:34:48 -040035 grubimage = prefix + d.getVar("EFI_BOOT_IMAGE")
Brad Bishopd7bf8c12018-02-25 22:55:05 -050036 d.setVar("GRUB_TARGET", grubtarget)
37 d.setVar("GRUB_IMAGE", grubimage)
Brad Bishop316dfdd2018-06-25 12:45:53 -040038 prefix = "grub-efi-" if prefix == "" else ""
39 d.setVar("GRUB_IMAGE_PREFIX", prefix)
Brad Bishopd7bf8c12018-02-25 22:55:05 -050040}
41
42inherit deploy
43
44CACHED_CONFIGUREVARS += "ac_cv_path_HELP2MAN="
45EXTRA_OECONF += "--enable-efiemu=no"
46
Brad Bishop316dfdd2018-06-25 12:45:53 -040047do_mkimage() {
48 cd ${B}
49 # Search for the grub.cfg on the local boot media by using the
50 # built in cfg file provided via this recipe
Brad Bishopa34c0302019-09-23 22:34:48 -040051 grub-mkimage -c ../cfg -p ${EFIDIR} -d ./grub-core/ \
Brad Bishop316dfdd2018-06-25 12:45:53 -040052 -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} \
53 ${GRUB_BUILDIN}
54}
55
56addtask mkimage before do_install after do_compile
57
Andrew Geisslerd25ed322020-06-27 00:28:28 -050058do_install() {
Brad Bishop316dfdd2018-06-25 12:45:53 -040059 oe_runmake 'DESTDIR=${D}' -C grub-core install
60
Brad Bishopd7bf8c12018-02-25 22:55:05 -050061 # Remove build host references...
62 find "${D}" -name modinfo.sh -type f -exec \
63 sed -i \
64 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
65 -e 's|${DEBUG_PREFIX_MAP}||g' \
66 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
67 {} +
Andrew Geisslerd25ed322020-06-27 00:28:28 -050068
69 install -d ${D}${EFI_FILES_PATH}
70 install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${D}${EFI_FILES_PATH}/${GRUB_IMAGE}
Brad Bishopd7bf8c12018-02-25 22:55:05 -050071}
72
Brad Bishop08902b02019-08-20 09:16:51 -040073do_install_append_aarch64() {
74 rm -rf ${D}/${prefix}/
75}
76
Brad Bishopd7bf8c12018-02-25 22:55:05 -050077GRUB_BUILDIN ?= "boot linux ext2 fat serial part_msdos part_gpt normal \
Brad Bishop316dfdd2018-06-25 12:45:53 -040078 efi_gop iso9660 configfile search loadenv test"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050079
80do_deploy() {
Brad Bishop316dfdd2018-06-25 12:45:53 -040081 install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${DEPLOYDIR}
Brad Bishopd7bf8c12018-02-25 22:55:05 -050082}
83
Brad Bishopd7bf8c12018-02-25 22:55:05 -050084addtask deploy after do_install before do_build
85
Brad Bishop316dfdd2018-06-25 12:45:53 -040086FILES_${PN} = "${libdir}/grub/${GRUB_TARGET}-efi \
87 ${datadir}/grub \
Brad Bishopa34c0302019-09-23 22:34:48 -040088 ${EFI_FILES_PATH}/${GRUB_IMAGE} \
Brad Bishop316dfdd2018-06-25 12:45:53 -040089 "
90
Brad Bishop08902b02019-08-20 09:16:51 -040091FILES_${PN}_remove_aarch64 = "${libdir}/grub/${GRUB_TARGET}-efi"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050092
93# 64-bit binaries are expected for the bootloader with an x32 userland
94INSANE_SKIP_${PN}_append_linux-gnux32 = " arch"
95INSANE_SKIP_${PN}-dbg_append_linux-gnux32 = " arch"
96INSANE_SKIP_${PN}_append_linux-muslx32 = " arch"
97INSANE_SKIP_${PN}-dbg_append_linux-muslx32 = " arch"