blob: c9f95b01254f162117c210ecc5330912c8aec633 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001#
2# Copyright (C) 2013 Wind River Systems, Inc.
3#
4
5SUMMARY = "Simple Protocol for Independent Computing Environments"
6DESCRIPTION = "SPICE (the Simple Protocol for Independent Computing \
7Environments) is a remote-display system built for virtual \
8environments which allows users to view a computing 'desktop' \
9environment - not only on its computer-server machine, but also from \
10anywhere on the Internet and using a wide variety of machine \
11architectures."
12
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000013LICENSE = "LGPLv2.1+"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
15
Brad Bishop15ae2502019-06-18 21:44:24 -040016PV = "0.14.2+git${SRCPV}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017
Brad Bishop15ae2502019-06-18 21:44:24 -040018SRCREV_spice = "7cbd70b931db76c69c89c2d9d5d704f67381a81b"
19SRCREV_spice-common = "4fc4c2db36c7f07b906e9a326a9d3dc0ae6a2671"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
21SRCREV_FORMAT = "spice_spice-common"
22
23SRC_URI = " \
Andrew Geissler595f6302022-01-24 19:11:47 +000024 git://anongit.freedesktop.org/spice/spice;name=spice;branch=master \
25 git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/subprojects/spice-common;name=spice-common;branch=master \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026 file://0001-Convert-pthread_t-to-be-numeric.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040027 file://0001-Fix-compile-errors-on-Linux-32bit-system.patch \
Andrew Geisslerac970dd2021-02-12 15:32:45 -060028 file://0001-configure.ac-explicitly-link-to-jpeg-lib.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029"
30
31S = "${WORKDIR}/git"
32
Andrew Geissler82c905d2020-04-13 13:39:40 -050033inherit autotools gettext python3native python3-dir pkgconfig
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080034
Andrew Geissler82c905d2020-04-13 13:39:40 -050035DEPENDS += "spice-protocol jpeg pixman alsa-lib glib-2.0 python3-pyparsing-native python3-six-native glib-2.0-native"
Patrick Williams213cb262021-08-07 19:21:33 -050036DEPENDS:append:class-nativesdk = " nativesdk-openssl"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080037
Andrew Geissler82c905d2020-04-13 13:39:40 -050038export PYTHON="${STAGING_BINDIR_NATIVE}/python3-native/python3"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080039
Patrick Williams213cb262021-08-07 19:21:33 -050040CFLAGS:append = " -Wno-error"
Brad Bishop15ae2502019-06-18 21:44:24 -040041
Patrick Williams213cb262021-08-07 19:21:33 -050042PACKAGECONFIG:class-native = ""
43PACKAGECONFIG:class-nativesdk = ""
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080044PACKAGECONFIG ?= "sasl"
45
46PACKAGECONFIG[celt051] = "--enable-celt051,--disable-celt051,celt051"
47PACKAGECONFIG[smartcard] = "--enable-smartcard,--disable-smartcard,libcacard,"
48PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl,"
49PACKAGECONFIG[client] = "--enable-client,--disable-client,,"
50PACKAGECONFIG[gui] = "--enable-gui,--disable-gui,,"
51PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus,"
52PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,,"
53PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama,"
54
55COMPATIBLE_HOST = '(x86_64|i.86).*-linux'
56
Brad Bishop36a3e3e2019-10-02 13:29:27 -040057BBCLASSEXTEND = "native nativesdk"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080058
Patrick Williams213cb262021-08-07 19:21:33 -050059EXTRA_OECONF:append:toolchain-clang = " --disable-werror"