blob: c19c770d114d8e9296b16f8c15eae4df308056f1 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# ex:ts=4:sw=4:sts=4:et
2# -*- tab-width: 4; c-basic-offset: 4; indent-tabs-mode: nil -*-
3#
4# This bbclass is used for creating archive for:
Andrew Geissler82c905d2020-04-13 13:39:40 -05005# 1) original (or unpacked) source: ARCHIVER_MODE[src] = "original"
6# 2) patched source: ARCHIVER_MODE[src] = "patched" (default)
7# 3) configured source: ARCHIVER_MODE[src] = "configured"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008# 4) source mirror: ARCHIVER_MODE[src] = "mirror"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009# 5) The patches between do_unpack and do_patch:
10# ARCHIVER_MODE[diff] = "1"
11# And you can set the one that you'd like to exclude from the diff:
12# ARCHIVER_MODE[diff-exclude] ?= ".pc autom4te.cache patches"
13# 6) The environment data, similar to 'bitbake -e recipe':
14# ARCHIVER_MODE[dumpdata] = "1"
15# 7) The recipe (.bb and .inc): ARCHIVER_MODE[recipe] = "1"
16# 8) Whether output the .src.rpm package:
17# ARCHIVER_MODE[srpm] = "1"
18# 9) Filter the license, the recipe whose license in
19# COPYLEFT_LICENSE_INCLUDE will be included, and in
20# COPYLEFT_LICENSE_EXCLUDE will be excluded.
21# COPYLEFT_LICENSE_INCLUDE = 'GPL* LGPL*'
22# COPYLEFT_LICENSE_EXCLUDE = 'CLOSED Proprietary'
23# 10) The recipe type that will be archived:
24# COPYLEFT_RECIPE_TYPES = 'target'
25# 11) The source mirror mode:
26# ARCHIVER_MODE[mirror] = "split" (default): Sources are split into
27# per-recipe directories in a similar way to other archiver modes.
28# Post-processing may be required to produce a single mirror directory.
29# This does however allow inspection of duplicate sources and more
30# intelligent handling.
31# ARCHIVER_MODE[mirror] = "combined": All sources are placed into a single
32# directory suitable for direct use as a mirror. Duplicate sources are
33# ignored.
34# 12) Source mirror exclusions:
35# ARCHIVER_MIRROR_EXCLUDE is a list of prefixes to exclude from the mirror.
36# This may be used for sources which you are already publishing yourself
37# (e.g. if the URI starts with 'https://mysite.com/' and your mirror is
38# going to be published to the same site). It may also be used to exclude
39# local files (with the prefix 'file://') if these will be provided as part
40# of an archive of the layers themselves.
Patrick Williamsc124f4f2015-09-15 14:41:29 -050041#
42
Patrick Williamsc124f4f2015-09-15 14:41:29 -050043# Create archive for all the recipe types
44COPYLEFT_RECIPE_TYPES ?= 'target native nativesdk cross crosssdk cross-canadian'
45inherit copyleft_filter
46
47ARCHIVER_MODE[srpm] ?= "0"
48ARCHIVER_MODE[src] ?= "patched"
49ARCHIVER_MODE[diff] ?= "0"
50ARCHIVER_MODE[diff-exclude] ?= ".pc autom4te.cache patches"
51ARCHIVER_MODE[dumpdata] ?= "0"
52ARCHIVER_MODE[recipe] ?= "0"
Andrew Geissler82c905d2020-04-13 13:39:40 -050053ARCHIVER_MODE[mirror] ?= "split"
Andrew Geissler595f6302022-01-24 19:11:47 +000054ARCHIVER_MODE[compression] ?= "xz"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050055
56DEPLOY_DIR_SRC ?= "${DEPLOY_DIR}/sources"
Andrew Geisslerf0343792020-11-18 10:42:21 -060057ARCHIVER_TOPDIR ?= "${WORKDIR}/archiver-sources"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050058ARCHIVER_OUTDIR = "${ARCHIVER_TOPDIR}/${TARGET_SYS}/${PF}/"
Brad Bishop19323692019-04-05 15:28:33 -040059ARCHIVER_RPMTOPDIR ?= "${WORKDIR}/deploy-sources-rpm"
60ARCHIVER_RPMOUTDIR = "${ARCHIVER_RPMTOPDIR}/${TARGET_SYS}/${PF}/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050061ARCHIVER_WORKDIR = "${WORKDIR}/archiver-work/"
62
Andrew Geissler82c905d2020-04-13 13:39:40 -050063# When producing a combined mirror directory, allow duplicates for the case
64# where multiple recipes use the same SRC_URI.
65ARCHIVER_COMBINED_MIRRORDIR = "${ARCHIVER_TOPDIR}/mirror"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000066SSTATE_ALLOW_OVERLAP_FILES += "${DEPLOY_DIR_SRC}/mirror"
Brad Bishop19323692019-04-05 15:28:33 -040067
Patrick Williamsc124f4f2015-09-15 14:41:29 -050068do_dumpdata[dirs] = "${ARCHIVER_OUTDIR}"
69do_ar_recipe[dirs] = "${ARCHIVER_OUTDIR}"
70do_ar_original[dirs] = "${ARCHIVER_OUTDIR} ${ARCHIVER_WORKDIR}"
71do_deploy_archives[dirs] = "${WORKDIR}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050072
73# This is a convenience for the shell script to use it
74
75
76python () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050077 pn = d.getVar('PN')
78 assume_provided = (d.getVar("ASSUME_PROVIDED") or "").split()
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050079 if pn in assume_provided:
Brad Bishop6e60e8b2018-02-01 10:27:11 -050080 for p in d.getVar("PROVIDES").split():
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050081 if p != pn:
82 pn = p
83 break
Patrick Williamsc124f4f2015-09-15 14:41:29 -050084
85 included, reason = copyleft_should_include(d)
86 if not included:
87 bb.debug(1, 'archiver: %s is excluded: %s' % (pn, reason))
88 return
89 else:
90 bb.debug(1, 'archiver: %s is included: %s' % (pn, reason))
91
Brad Bishop6e60e8b2018-02-01 10:27:11 -050092
93 # glibc-locale: do_fetch, do_unpack and do_patch tasks have been deleted,
94 # so avoid archiving source here.
95 if pn.startswith('glibc-locale'):
96 return
97
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050098 # We just archive gcc-source for all the gcc related recipes
Brad Bishop6e60e8b2018-02-01 10:27:11 -050099 if d.getVar('BPN') in ['gcc', 'libgcc'] \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500100 and not pn.startswith('gcc-source'):
101 bb.debug(1, 'archiver: %s is excluded, covered by gcc-source' % pn)
102 return
103
Brad Bishop79641f22019-09-10 07:20:22 -0400104 def hasTask(task):
105 return bool(d.getVarFlag(task, "task", False)) and not bool(d.getVarFlag(task, "noexec", False))
106
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500107 ar_src = d.getVarFlag('ARCHIVER_MODE', 'src')
108 ar_dumpdata = d.getVarFlag('ARCHIVER_MODE', 'dumpdata')
109 ar_recipe = d.getVarFlag('ARCHIVER_MODE', 'recipe')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500110
111 if ar_src == "original":
112 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_original' % pn)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500113 # 'patched' and 'configured' invoke do_unpack_and_patch because
114 # do_ar_patched resp. do_ar_configured depend on it, but for 'original'
115 # we have to add it explicitly.
116 if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1':
117 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_unpack_and_patch' % pn)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500118 elif ar_src == "patched":
119 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_patched' % pn)
120 elif ar_src == "configured":
121 # We can't use "addtask do_ar_configured after do_configure" since it
Andrew Geisslerc926e172021-05-07 16:11:35 -0500122 # will cause the deptask of do_populate_sysroot to run no matter what
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500123 # archives we need, so we add the depends here.
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500124
125 # There is a corner case with "gcc-source-${PV}" recipes, they don't have
126 # the "do_configure" task, so we need to use "do_preconfigure"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800127 if hasTask("do_preconfigure"):
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500128 d.appendVarFlag('do_ar_configured', 'depends', ' %s:do_preconfigure' % pn)
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800129 elif hasTask("do_configure"):
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500130 d.appendVarFlag('do_ar_configured', 'depends', ' %s:do_configure' % pn)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500131 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_configured' % pn)
Andrew Geissler82c905d2020-04-13 13:39:40 -0500132 elif ar_src == "mirror":
133 d.appendVarFlag('do_deploy_archives', 'depends', '%s:do_ar_mirror' % pn)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500134
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500135 elif ar_src:
136 bb.fatal("Invalid ARCHIVER_MODE[src]: %s" % ar_src)
137
138 if ar_dumpdata == "1":
139 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_dumpdata' % pn)
140
141 if ar_recipe == "1":
142 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_recipe' % pn)
143
Brad Bishop316dfdd2018-06-25 12:45:53 -0400144 # Output the SRPM package
145 if d.getVarFlag('ARCHIVER_MODE', 'srpm') == "1" and d.getVar('PACKAGES'):
Brad Bishop79641f22019-09-10 07:20:22 -0400146 if "package_rpm" not in d.getVar('PACKAGE_CLASSES'):
147 bb.fatal("ARCHIVER_MODE[srpm] needs package_rpm in PACKAGE_CLASSES")
148
149 # Some recipes do not have any packaging tasks
150 if hasTask("do_package_write_rpm"):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500151 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_package_write_rpm' % pn)
Brad Bishop19323692019-04-05 15:28:33 -0400152 d.appendVarFlag('do_package_write_rpm', 'dirs', ' ${ARCHIVER_RPMTOPDIR}')
153 d.appendVarFlag('do_package_write_rpm', 'sstate-inputdirs', ' ${ARCHIVER_RPMTOPDIR}')
154 d.appendVarFlag('do_package_write_rpm', 'sstate-outputdirs', ' ${DEPLOY_DIR_SRC}')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500155 if ar_dumpdata == "1":
156 d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_dumpdata' % pn)
157 if ar_recipe == "1":
158 d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_recipe' % pn)
159 if ar_src == "original":
160 d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_original' % pn)
161 elif ar_src == "patched":
162 d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_patched' % pn)
163 elif ar_src == "configured":
164 d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_configured' % pn)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500165}
166
Andrew Geisslerc926e172021-05-07 16:11:35 -0500167# Take all the sources for a recipe and put them in WORKDIR/archiver-work/.
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500168# Files in SRC_URI are copied directly, anything that's a directory
169# (e.g. git repositories) is "unpacked" and then put into a tarball.
170python do_ar_original() {
171
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500172 import shutil, tempfile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500173
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500174 if d.getVarFlag('ARCHIVER_MODE', 'src') != "original":
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500175 return
176
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500177 ar_outdir = d.getVar('ARCHIVER_OUTDIR')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500178 bb.note('Archiving the original source...')
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500179 urls = d.getVar("SRC_URI").split()
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600180 # destsuffix (git fetcher) and subdir (everything else) are allowed to be
181 # absolute paths (for example, destsuffix=${S}/foobar).
182 # That messes with unpacking inside our tmpdir below, because the fetchers
183 # will then unpack in that directory and completely ignore the tmpdir.
184 # That breaks parallel tasks relying on ${S}, like do_compile.
185 #
186 # To solve this, we remove these parameters from all URLs.
187 # We do this even for relative paths because it makes the content of the
188 # archives more useful (no extra paths that are only used during
189 # compilation).
190 for i, url in enumerate(urls):
191 decoded = bb.fetch2.decodeurl(url)
192 for param in ('destsuffix', 'subdir'):
193 if param in decoded[5]:
194 del decoded[5][param]
195 encoded = bb.fetch2.encodeurl(decoded)
196 urls[i] = encoded
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500197
198 # Cleanup SRC_URI before call bb.fetch2.Fetch() since now SRC_URI is in the
199 # variable "urls", otherwise there might be errors like:
200 # The SRCREV_FORMAT variable must be set when multiple SCMs are used
201 ld = bb.data.createCopy(d)
202 ld.setVar('SRC_URI', '')
203 fetch = bb.fetch2.Fetch(urls, ld)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600204 tarball_suffix = {}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500205 for url in fetch.urls:
206 local = fetch.localpath(url).rstrip("/");
207 if os.path.isfile(local):
208 shutil.copy(local, ar_outdir)
209 elif os.path.isdir(local):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500210 tmpdir = tempfile.mkdtemp(dir=d.getVar('ARCHIVER_WORKDIR'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500211 fetch.unpack(tmpdir, (url,))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600212 # To handle recipes with more than one source, we add the "name"
213 # URL parameter as suffix. We treat it as an error when
214 # there's more than one URL without a name, or a name gets reused.
215 # This is an additional safety net, in practice the name has
216 # to be set when using the git fetcher, otherwise SRCREV cannot
217 # be set separately for each URL.
218 params = bb.fetch2.decodeurl(url)[5]
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500219 type = bb.fetch2.decodeurl(url)[0]
220 location = bb.fetch2.decodeurl(url)[2]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600221 name = params.get('name', '')
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500222 if type.lower() == 'file':
223 name_tmp = location.rstrip("*").rstrip("/")
224 name = os.path.basename(name_tmp)
225 else:
226 if name in tarball_suffix:
227 if not name:
228 bb.fatal("Cannot determine archive names for original source because 'name' URL parameter is unset in more than one URL. Add it to at least one of these: %s %s" % (tarball_suffix[name], url))
229 else:
230 bb.fatal("Cannot determine archive names for original source because 'name=' URL parameter '%s' is used twice. Make it unique in: %s %s" % (tarball_suffix[name], url))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600231 tarball_suffix[name] = url
232 create_tarball(d, tmpdir + '/.', name, ar_outdir)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500233
234 # Emit patch series files for 'original'
235 bb.note('Writing patch series files...')
236 for patch in src_patches(d):
237 _, _, local, _, _, parm = bb.fetch.decodeurl(patch)
238 patchdir = parm.get('patchdir')
239 if patchdir:
240 series = os.path.join(ar_outdir, 'series.subdir.%s' % patchdir.replace('/', '_'))
241 else:
242 series = os.path.join(ar_outdir, 'series')
243
244 with open(series, 'a') as s:
245 s.write('%s -p%s\n' % (os.path.basename(local), parm['striplevel']))
246}
247
248python do_ar_patched() {
249
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500250 if d.getVarFlag('ARCHIVER_MODE', 'src') != 'patched':
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500251 return
252
253 # Get the ARCHIVER_OUTDIR before we reset the WORKDIR
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500254 ar_outdir = d.getVar('ARCHIVER_OUTDIR')
Brad Bishopa34c0302019-09-23 22:34:48 -0400255 if not is_work_shared(d):
256 ar_workdir = d.getVar('ARCHIVER_WORKDIR')
257 d.setVar('WORKDIR', ar_workdir)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500258 bb.note('Archiving the patched source...')
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500259 create_tarball(d, d.getVar('S'), 'patched', ar_outdir)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500260}
261
262python do_ar_configured() {
263 import shutil
264
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500265 # Forcibly expand the sysroot paths as we're about to change WORKDIR
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500266 d.setVar('STAGING_DIR_HOST', d.getVar('STAGING_DIR_HOST'))
267 d.setVar('STAGING_DIR_TARGET', d.getVar('STAGING_DIR_TARGET'))
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500268 d.setVar('RECIPE_SYSROOT', d.getVar('RECIPE_SYSROOT'))
269 d.setVar('RECIPE_SYSROOT_NATIVE', d.getVar('RECIPE_SYSROOT_NATIVE'))
270
271 ar_outdir = d.getVar('ARCHIVER_OUTDIR')
272 if d.getVarFlag('ARCHIVER_MODE', 'src') == 'configured':
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500273 bb.note('Archiving the configured source...')
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500274 pn = d.getVar('PN')
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500275 # "gcc-source-${PV}" recipes don't have "do_configure"
276 # task, so we need to run "do_preconfigure" instead
277 if pn.startswith("gcc-source-"):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500278 d.setVar('WORKDIR', d.getVar('ARCHIVER_WORKDIR'))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500279 bb.build.exec_func('do_preconfigure', d)
280
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500281 # The libtool-native's do_configure will remove the
282 # ${STAGING_DATADIR}/aclocal/libtool.m4, so we can't re-run the
283 # do_configure, we archive the already configured ${S} to
284 # instead of.
Patrick Williams213cb262021-08-07 19:21:33 -0500285 # The kernel class functions require it to be on work-shared, we
286 # don't unpack, patch, configure again, just archive the already
287 # configured ${S}
288 elif not (pn == 'libtool-native' or is_work_shared(d)):
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800289 def runTask(task):
290 prefuncs = d.getVarFlag(task, 'prefuncs') or ''
291 for func in prefuncs.split():
292 if func != "sysroot_cleansstate":
293 bb.build.exec_func(func, d)
294 bb.build.exec_func(task, d)
295 postfuncs = d.getVarFlag(task, 'postfuncs') or ''
296 for func in postfuncs.split():
297 if func != 'do_qa_configure':
298 bb.build.exec_func(func, d)
299
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500300 # Change the WORKDIR to make do_configure run in another dir.
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500301 d.setVar('WORKDIR', d.getVar('ARCHIVER_WORKDIR'))
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800302
303 preceeds = bb.build.preceedtask('do_configure', False, d)
304 for task in preceeds:
305 if task != 'do_patch' and task != 'do_prepare_recipe_sysroot':
306 runTask(task)
307 runTask('do_configure')
308
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500309 srcdir = d.getVar('S')
310 builddir = d.getVar('B')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500311 if srcdir != builddir:
312 if os.path.exists(builddir):
313 oe.path.copytree(builddir, os.path.join(srcdir, \
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500314 'build.%s.ar_configured' % d.getVar('PF')))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500315 create_tarball(d, srcdir, 'configured', ar_outdir)
316}
317
Andrew Geissler82c905d2020-04-13 13:39:40 -0500318python do_ar_mirror() {
319 import subprocess
320
321 src_uri = (d.getVar('SRC_URI') or '').split()
322 if len(src_uri) == 0:
323 return
324
325 dl_dir = d.getVar('DL_DIR')
326 mirror_exclusions = (d.getVar('ARCHIVER_MIRROR_EXCLUDE') or '').split()
327 mirror_mode = d.getVarFlag('ARCHIVER_MODE', 'mirror')
328 have_mirror_tarballs = d.getVar('BB_GENERATE_MIRROR_TARBALLS')
329
330 if mirror_mode == 'combined':
331 destdir = d.getVar('ARCHIVER_COMBINED_MIRRORDIR')
332 elif mirror_mode == 'split':
333 destdir = d.getVar('ARCHIVER_OUTDIR')
334 else:
335 bb.fatal('Invalid ARCHIVER_MODE[mirror]: %s' % (mirror_mode))
336
337 if not have_mirror_tarballs:
338 bb.fatal('Using `ARCHIVER_MODE[src] = "mirror"` depends on setting `BB_GENERATE_MIRROR_TARBALLS = "1"`')
339
340 def is_excluded(url):
341 for prefix in mirror_exclusions:
342 if url.startswith(prefix):
343 return True
344 return False
345
346 bb.note('Archiving the source as a mirror...')
347
348 bb.utils.mkdirhier(destdir)
349
350 fetcher = bb.fetch2.Fetch(src_uri, d)
351
Andrew Geissler5a43b432020-06-13 10:46:56 -0500352 for ud in fetcher.expanded_urldata():
353 if is_excluded(ud.url):
354 bb.note('Skipping excluded url: %s' % (ud.url))
Andrew Geissler82c905d2020-04-13 13:39:40 -0500355 continue
356
Andrew Geissler5a43b432020-06-13 10:46:56 -0500357 bb.note('Archiving url: %s' % (ud.url))
Andrew Geissler82c905d2020-04-13 13:39:40 -0500358 ud.setup_localpath(d)
359 localpath = None
360
361 # Check for mirror tarballs first. We will archive the first mirror
362 # tarball that we find as it's assumed that we just need one.
363 for mirror_fname in ud.mirrortarballs:
364 mirror_path = os.path.join(dl_dir, mirror_fname)
365 if os.path.exists(mirror_path):
366 bb.note('Found mirror tarball: %s' % (mirror_path))
367 localpath = mirror_path
368 break
369
370 if len(ud.mirrortarballs) and not localpath:
371 bb.warn('Mirror tarballs are listed for a source but none are present. ' \
372 'Falling back to original download.\n' \
Andrew Geissler5a43b432020-06-13 10:46:56 -0500373 'SRC_URI = %s' % (ud.url))
Andrew Geissler82c905d2020-04-13 13:39:40 -0500374
375 # Check original download
376 if not localpath:
377 bb.note('Using original download: %s' % (ud.localpath))
378 localpath = ud.localpath
379
380 if not localpath or not os.path.exists(localpath):
381 bb.fatal('Original download is missing for a source.\n' \
Andrew Geissler5a43b432020-06-13 10:46:56 -0500382 'SRC_URI = %s' % (ud.url))
Andrew Geissler82c905d2020-04-13 13:39:40 -0500383
384 # We now have an appropriate localpath
385 bb.note('Copying source mirror')
386 cmd = 'cp -fpPRH %s %s' % (localpath, destdir)
387 subprocess.check_call(cmd, shell=True)
388}
389
Brad Bishopc4ea0752018-11-15 14:30:15 -0800390def exclude_useless_paths(tarinfo):
391 if tarinfo.isdir():
392 if tarinfo.name.endswith('/temp') or tarinfo.name.endswith('/patches') or tarinfo.name.endswith('/.pc'):
393 return None
394 elif tarinfo.name == 'temp' or tarinfo.name == 'patches' or tarinfo.name == '.pc':
395 return None
396 return tarinfo
397
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500398def create_tarball(d, srcdir, suffix, ar_outdir):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500399 """
400 create the tarball from srcdir
401 """
402 import tarfile
403
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500404 # Make sure we are only creating a single tarball for gcc sources
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500405 if (d.getVar('SRC_URI') == ""):
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500406 return
407
Brad Bishop316dfdd2018-06-25 12:45:53 -0400408 # For the kernel archive, srcdir may just be a link to the
409 # work-shared location. Use os.path.realpath to make sure
410 # that we archive the actual directory and not just the link.
411 srcdir = os.path.realpath(srcdir)
412
Andrew Geisslereff27472021-10-29 15:35:00 -0500413 compression_method = d.getVarFlag('ARCHIVER_MODE', 'compression')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500414 bb.utils.mkdirhier(ar_outdir)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500415 if suffix:
Andrew Geisslereff27472021-10-29 15:35:00 -0500416 filename = '%s-%s.tar.%s' % (d.getVar('PF'), suffix, compression_method)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500417 else:
Andrew Geisslereff27472021-10-29 15:35:00 -0500418 filename = '%s.tar.%s' % (d.getVar('PF'), compression_method)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500419 tarname = os.path.join(ar_outdir, filename)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500420
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500421 bb.note('Creating %s' % tarname)
Andrew Geisslereff27472021-10-29 15:35:00 -0500422 tar = tarfile.open(tarname, 'w:%s' % compression_method)
Brad Bishopc4ea0752018-11-15 14:30:15 -0800423 tar.add(srcdir, arcname=os.path.basename(srcdir), filter=exclude_useless_paths)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500424 tar.close()
425
426# creating .diff.gz between source.orig and source
427def create_diff_gz(d, src_orig, src, ar_outdir):
428
429 import subprocess
430
431 if not os.path.isdir(src) or not os.path.isdir(src_orig):
432 return
433
434 # The diff --exclude can't exclude the file with path, so we copy
435 # the patched source, and remove the files that we'd like to
436 # exclude.
437 src_patched = src + '.patched'
438 oe.path.copyhardlinktree(src, src_patched)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500439 for i in d.getVarFlag('ARCHIVER_MODE', 'diff-exclude').split():
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500440 bb.utils.remove(os.path.join(src_orig, i), recurse=True)
441 bb.utils.remove(os.path.join(src_patched, i), recurse=True)
442
443 dirname = os.path.dirname(src)
444 basename = os.path.basename(src)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500445 bb.utils.mkdirhier(ar_outdir)
446 cwd = os.getcwd()
447 try:
448 os.chdir(dirname)
449 out_file = os.path.join(ar_outdir, '%s-diff.gz' % d.getVar('PF'))
450 diff_cmd = 'diff -Naur %s.orig %s.patched | gzip -c > %s' % (basename, basename, out_file)
451 subprocess.check_call(diff_cmd, shell=True)
452 bb.utils.remove(src_patched, recurse=True)
453 finally:
454 os.chdir(cwd)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500455
Brad Bishop316dfdd2018-06-25 12:45:53 -0400456def is_work_shared(d):
457 pn = d.getVar('PN')
458 return bb.data.inherits_class('kernel', d) or pn.startswith('gcc-source')
459
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500460# Run do_unpack and do_patch
461python do_unpack_and_patch() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500462 if d.getVarFlag('ARCHIVER_MODE', 'src') not in \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500463 [ 'patched', 'configured'] and \
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500464 d.getVarFlag('ARCHIVER_MODE', 'diff') != '1':
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500465 return
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500466 ar_outdir = d.getVar('ARCHIVER_OUTDIR')
467 ar_workdir = d.getVar('ARCHIVER_WORKDIR')
468 ar_sysroot_native = d.getVar('STAGING_DIR_NATIVE')
469 pn = d.getVar('PN')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500470
Andrew Geisslerc926e172021-05-07 16:11:35 -0500471 # The kernel class functions require it to be on work-shared, so we don't change WORKDIR
Brad Bishop316dfdd2018-06-25 12:45:53 -0400472 if not is_work_shared(d):
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500473 # Change the WORKDIR to make do_unpack do_patch run in another dir.
474 d.setVar('WORKDIR', ar_workdir)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500475 # Restore the original path to recipe's native sysroot (it's relative to WORKDIR).
476 d.setVar('STAGING_DIR_NATIVE', ar_sysroot_native)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500477
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500478 # The changed 'WORKDIR' also caused 'B' changed, create dir 'B' for the
479 # possibly requiring of the following tasks (such as some recipes's
480 # do_patch required 'B' existed).
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500481 bb.utils.mkdirhier(d.getVar('B'))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500482
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500483 bb.build.exec_func('do_unpack', d)
484
485 # Save the original source for creating the patches
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500486 if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1':
487 src = d.getVar('S').rstrip('/')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500488 src_orig = '%s.orig' % src
489 oe.path.copytree(src, src_orig)
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500490
Patrick Williams213cb262021-08-07 19:21:33 -0500491 if bb.data.inherits_class('dos2unix', d):
492 bb.build.exec_func('do_convert_crlf_to_lf', d)
493
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500494 # Make sure gcc and kernel sources are patched only once
Brad Bishop316dfdd2018-06-25 12:45:53 -0400495 if not (d.getVar('SRC_URI') == "" or is_work_shared(d)):
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500496 bb.build.exec_func('do_patch', d)
497
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500498 # Create the patches
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500499 if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1':
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500500 bb.note('Creating diff gz...')
501 create_diff_gz(d, src_orig, src, ar_outdir)
502 bb.utils.remove(src_orig, recurse=True)
503}
504
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500505# BBINCLUDED is special (excluded from basehash signature
506# calculation). Using it in a task signature can cause "basehash
507# changed" errors.
508#
509# Depending on BBINCLUDED also causes do_ar_recipe to run again
510# for unrelated changes, like adding or removing buildhistory.bbclass.
511#
512# For these reasons we ignore the dependency completely. The versioning
513# of the output file ensures that we create it each time the recipe
514# gets rebuilt, at least as long as a PR server is used. We also rely
515# on that mechanism to catch changes in the file content, because the
Andrew Geisslerc926e172021-05-07 16:11:35 -0500516# file content is not part of the task signature either.
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500517do_ar_recipe[vardepsexclude] += "BBINCLUDED"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500518python do_ar_recipe () {
519 """
520 archive the recipe, including .bb and .inc.
521 """
522 import re
523 import shutil
524
525 require_re = re.compile( r"require\s+(.+)" )
526 include_re = re.compile( r"include\s+(.+)" )
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500527 bbfile = d.getVar('FILE')
528 outdir = os.path.join(d.getVar('WORKDIR'), \
529 '%s-recipe' % d.getVar('PF'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500530 bb.utils.mkdirhier(outdir)
531 shutil.copy(bbfile, outdir)
532
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500533 pn = d.getVar('PN')
534 bbappend_files = d.getVar('BBINCLUDED').split()
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500535 # If recipe name is aa, we need to match files like aa.bbappend and aa_1.1.bbappend
536 # Files like aa1.bbappend or aa1_1.1.bbappend must be excluded.
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500537 bbappend_re = re.compile( r".*/%s_[^/]*\.bbappend$" % re.escape(pn))
538 bbappend_re1 = re.compile( r".*/%s\.bbappend$" % re.escape(pn))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500539 for file in bbappend_files:
540 if bbappend_re.match(file) or bbappend_re1.match(file):
541 shutil.copy(file, outdir)
542
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500543 dirname = os.path.dirname(bbfile)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500544 bbpath = '%s:%s' % (dirname, d.getVar('BBPATH'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500545 f = open(bbfile, 'r')
546 for line in f.readlines():
547 incfile = None
548 if require_re.match(line):
549 incfile = require_re.match(line).group(1)
550 elif include_re.match(line):
551 incfile = include_re.match(line).group(1)
552 if incfile:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500553 incfile = d.expand(incfile)
Brad Bishop1d80a2e2019-11-15 16:35:03 -0500554 if incfile:
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500555 incfile = bb.utils.which(bbpath, incfile)
Brad Bishop1d80a2e2019-11-15 16:35:03 -0500556 if incfile:
557 shutil.copy(incfile, outdir)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500558
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500559 create_tarball(d, outdir, 'recipe', d.getVar('ARCHIVER_OUTDIR'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500560 bb.utils.remove(outdir, recurse=True)
561}
562
563python do_dumpdata () {
564 """
565 dump environment data to ${PF}-showdata.dump
566 """
567
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500568 dumpfile = os.path.join(d.getVar('ARCHIVER_OUTDIR'), \
569 '%s-showdata.dump' % d.getVar('PF'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500570 bb.note('Dumping metadata into %s' % dumpfile)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500571 with open(dumpfile, "w") as f:
572 # emit variables and shell functions
573 bb.data.emit_env(f, d, True)
574 # emit the metadata which isn't valid shell
575 for e in d.keys():
576 if d.getVarFlag(e, "python", False):
577 f.write("\npython %s () {\n%s}\n" % (e, d.getVar(e, False)))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500578}
579
580SSTATETASKS += "do_deploy_archives"
581do_deploy_archives () {
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500582 echo "Deploying source archive files from ${ARCHIVER_TOPDIR} to ${DEPLOY_DIR_SRC}."
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500583}
584python do_deploy_archives_setscene () {
585 sstate_setscene(d)
586}
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500587do_deploy_archives[dirs] = "${ARCHIVER_TOPDIR}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500588do_deploy_archives[sstate-inputdirs] = "${ARCHIVER_TOPDIR}"
589do_deploy_archives[sstate-outputdirs] = "${DEPLOY_DIR_SRC}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500590addtask do_deploy_archives_setscene
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500591
592addtask do_ar_original after do_unpack
Andrew Geissler475cb722020-07-10 16:00:51 -0500593addtask do_unpack_and_patch after do_patch do_preconfigure
594addtask do_ar_patched after do_unpack_and_patch
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500595addtask do_ar_configured after do_unpack_and_patch
Andrew Geissler82c905d2020-04-13 13:39:40 -0500596addtask do_ar_mirror after do_fetch
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500597addtask do_dumpdata
598addtask do_ar_recipe
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500599addtask do_deploy_archives
600do_build[recrdeptask] += "do_deploy_archives"
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600601do_rootfs[recrdeptask] += "do_deploy_archives"
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500602do_populate_sdk[recrdeptask] += "do_deploy_archives"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500603
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500604python () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500605 # Add tasks in the correct order, specifically for linux-yocto to avoid race condition.
606 # sstatesig.py:sstate_rundepfilter has special support that excludes this dependency
607 # so that do_kernel_configme does not need to run again when do_unpack_and_patch
608 # gets added or removed (by adding or removing archiver.bbclass).
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500609 if bb.data.inherits_class('kernel-yocto', d):
610 bb.build.addtask('do_kernel_configme', 'do_configure', 'do_unpack_and_patch', d)
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500611}