blob: c7cd9653470ef24eda8f969c597ad1af70cf6bd7 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Flex (The Fast Lexical Analyzer)"
2DESCRIPTION = "Flex is a fast lexical analyser generator. Flex is a tool for generating programs that recognize \
3lexical patterns in text."
4HOMEPAGE = "http://sourceforge.net/projects/flex/"
5SECTION = "devel"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "BSD-3-Clause & LGPL-2.0-or-later"
Patrick Williams213cb262021-08-07 19:21:33 -05007LICENSE:${PN}-libfl = "BSD-3-Clause"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
9DEPENDS = "${@bb.utils.contains('PTEST_ENABLED', '1', 'bison-native flex-native', '', d)}"
10BBCLASSEXTEND = "native nativesdk"
11
William A. Kennington IIIac69b482021-06-02 12:28:27 -070012LIC_FILES_CHKSUM = "file://COPYING;md5=e4742cf92e89040b39486a6219b68067 \
13 file://src/gettext.h;beginline=1;endline=17;md5=9c05dda2f58d89b850c399cf22e1a00c"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15SRC_URI = "https://github.com/westes/flex/releases/download/v${PV}/flex-${PV}.tar.gz \
16 file://run-ptest \
17 file://0001-tests-add-a-target-for-building-tests-without-runnin.patch \
18 ${@bb.utils.contains('PTEST_ENABLED', '1', '', 'file://disable-tests.patch', d)} \
19 file://0001-build-AC_USE_SYSTEM_EXTENSIONS-in-configure.ac.patch \
Andrew Geisslerb7d28612020-07-24 16:15:54 -050020 file://check-funcs.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060021 file://0001-Emit-no-line-directives-if-gen_line_dirs-is-false.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050022 "
23
24SRC_URI[md5sum] = "2882e3179748cc9f9c23ec593d6adc8d"
25SRC_URI[sha256sum] = "e87aae032bf07c26f85ac0ed3250998c37621d95f8bd748b31f15b33c45ee995"
26
27# Flex has moved to github from 2.6.1 onwards
28UPSTREAM_CHECK_URI = "https://github.com/westes/flex/releases"
29UPSTREAM_CHECK_REGEX = "flex-(?P<pver>\d+(\.\d+)+)\.tar"
30
Andrew Geissler5199d832021-09-24 16:47:35 -050031# Disputed - yes there is stack exhaustion but no bug and it is building the
32# parser, not running it, effectively similar to a compiler ICE. Upstream no plans to address
33# https://github.com/westes/flex/issues/414
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000034CVE_CHECK_IGNORE += "CVE-2019-6293"
Andrew Geissler5199d832021-09-24 16:47:35 -050035
Andrew Geissler82c905d2020-04-13 13:39:40 -050036inherit autotools gettext texinfo ptest
37
38M4 = "${bindir}/m4"
Patrick Williams213cb262021-08-07 19:21:33 -050039M4:class-native = "${STAGING_BINDIR_NATIVE}/m4"
Andrew Geissler82c905d2020-04-13 13:39:40 -050040EXTRA_OECONF += "ac_cv_path_M4=${M4} ac_cv_func_reallocarray=no"
41EXTRA_OEMAKE += "m4=${STAGING_BINDIR_NATIVE}/m4"
42
43EXTRA_OEMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', 'FLEX=${STAGING_BINDIR_NATIVE}/flex', '', d)}"
44
Patrick Williams213cb262021-08-07 19:21:33 -050045do_install:append:class-native() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050046 create_wrapper ${D}/${bindir}/flex M4=${M4}
47}
48
Patrick Williams213cb262021-08-07 19:21:33 -050049do_install:append:class-nativesdk() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050050 create_wrapper ${D}/${bindir}/flex M4=${M4}
51}
52
53PACKAGES =+ "${PN}-libfl"
54
Patrick Williams213cb262021-08-07 19:21:33 -050055FILES:${PN}-libfl = "${libdir}/libfl.so.* ${libdir}/libfl_pic.so.*"
Andrew Geissler82c905d2020-04-13 13:39:40 -050056
Patrick Williams213cb262021-08-07 19:21:33 -050057RDEPENDS:${PN} += "m4"
58RDEPENDS:${PN}-ptest += "bash gawk make"
Andrew Geissler82c905d2020-04-13 13:39:40 -050059
60do_compile_ptest() {
61 oe_runmake -C ${B}/tests -f ${B}/tests/Makefile top_builddir=${B} INCLUDES=-I${S}/src buildtests
62}
63
64do_install_ptest() {
65 mkdir -p ${D}${PTEST_PATH}/build-aux/
66 cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
67 cp -r ${S}/tests/* ${D}${PTEST_PATH}
68 cp -r ${B}/tests/* ${D}${PTEST_PATH}
69 sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
70 -e 's|${DEBUG_PREFIX_MAP}||g' \
71 -e 's:${HOSTTOOLS_DIR}/::g' \
72 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
73 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \-e 's/^Makefile:/_Makefile:/' \
74 -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' \
75 -e 's/^builddir = \(.*\)/builddir = ./' -e 's/^top_builddir = \(.*\)/top_builddir = ./' \
76 -e 's:${UNINATIVE_LOADER}:${base_bindir}/false:g' \
77 -i ${D}${PTEST_PATH}/Makefile
78}
79# The uninative loader is different on i386 & x86_64 hosts. Since it is only
80# being replaced with /bin/false anyway, it doesn't need to be part of the task
81# hash
82do_install_ptest[vardepsexclude] += "UNINATIVE_LOADER"
83
84# Not Apache Flex, or Adobe Flex, or IBM Flex.
85CVE_PRODUCT = "flex_project:flex"