blob: ed14fe66b12d8e732931e709725bd3ceb786e0f4 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Target Communication Framework for the Eclipse IDE"
2HOMEPAGE = "http://wiki.eclipse.org/TCF"
3BUGTRACKER = "https://bugs.eclipse.org/bugs/"
4
5LICENSE = "EPL-1.0 | EDL-1.0"
6LIC_FILES_CHKSUM = "file://edl-v10.html;md5=522a390a83dc186513f0500543ad3679"
7
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008SRCREV = "a022ef2f1acfd9209a1bf792dda14ae4b0d1b60f"
9PV = "1.7.0+git${SRCPV}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050010
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050011UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012SRC_URI = "git://git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013 file://fix_ranlib.patch \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050014 file://ldflags.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015 file://tcf-agent.init \
16 file://tcf-agent.service \
17 "
18
19DEPENDS = "util-linux openssl"
20RDEPENDS_${PN} = "bash"
21
22S = "${WORKDIR}/git/agent"
23
24inherit update-rc.d systemd
25
26SYSTEMD_SERVICE_${PN} = "tcf-agent.service"
27
28INITSCRIPT_NAME = "tcf-agent"
29INITSCRIPT_PARAMS = "start 99 3 5 . stop 20 0 1 2 6 ."
30
31# mangling needed for make
Andrew Geissler82c905d2020-04-13 13:39:40 -050032MAKE_ARCH = "`echo ${TARGET_ARCH} | sed s,i.86,i686, | sed s,aarch64.*,a64, | sed s,armeb,arm,`"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033MAKE_OS = "`echo ${TARGET_OS} | sed s,^linux.*,GNU/Linux,`"
34
35EXTRA_OEMAKE = "MACHINE=${MAKE_ARCH} OPSYS=${MAKE_OS} 'CC=${CC}' 'AR=${AR}'"
36
Brad Bishopd7bf8c12018-02-25 22:55:05 -050037LCL_STOP_SERVICES = "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050038 -DSERVICE_Memory=0 -DSERVICE_Registers=0 -DSERVICE_MemoryMap=0 \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050039 -DSERVICE_StackTrace=0 -DSERVICE_Expressions=0"
40
41
42# These features don't compile for several cases.
43#
Brad Bishop19323692019-04-05 15:28:33 -040044CFLAGS_append_arc = " ${LCL_STOP_SERVICES}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050045CFLAGS_append_mips = " ${LCL_STOP_SERVICES}"
46CFLAGS_append_mips64 = " ${LCL_STOP_SERVICES}"
47CFLAGS_append_libc-musl = " ${LCL_STOP_SERVICES}"
48CFLAGS_append_powerpc64 = " ${LCL_STOP_SERVICES}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050049CFLAGS_append_powerpc64le = " ${LCL_STOP_SERVICES}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080050CFLAGS_append_riscv64 = " ${LCL_STOP_SERVICES}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050051
52do_install() {
53 oe_runmake install INSTALLROOT=${D}
54 install -d ${D}${sysconfdir}/init.d/
55 install -m 0755 ${WORKDIR}/tcf-agent.init ${D}${sysconfdir}/init.d/tcf-agent
56 install -d ${D}${systemd_unitdir}/system
57 install -m 0644 ${WORKDIR}/tcf-agent.service ${D}${systemd_unitdir}/system
58 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/tcf-agent.service
59}
60